Debris left when polish books fails

Bug #1360385 reported by Dave Emerson on 2014-08-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

When polish books fails with an error report there are many files left scattered on the desktop, which appear to be elements of the zip package that was open, e.g. font.css, mimetype, toc.ncx, content.opf, etc.

Surely these should be in the current //temp directory.

Also, should we be capturing these error reports and sending them somewhere for analysis/resolution?

Polish books works very well most time and the first instance of an error that popped-up related to an original epub was broken, wouldn't open correctly in the reader, but all others since have happened to books that appear to be ok.

calibre-1.48.0

Windows 7 SP1 32-bit

Issue is repeatable.

description: updated

Attach a file demonstrating/reproducing the problem to this bug report. You can do that by clicking the "Add attachment or patch" link at the bottom of the bug's page. If the file you are attaching is copyrighted, mark the bug as private. You can do this by clicking the tiny lock icon next to "This report contains Public information" in the top right area of the bug's page.

 status incomplete

Changed in calibre:
status: New → Incomplete
Dave Emerson (dave-emerson) wrote :

Attached

errors logged during polish jobs
screen shot of desk top, showing debris files
debris.rar
sample epub format that fails to polish

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments