Compare AZW3 to ORIGINAL_AZW3 gives ValueError Not a ZIP file

Bug #1354624 reported by Scott Bakker on 2014-08-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Ever since the ability was added to right-click on an AZW3 file and select "Compare to the ORIGINAL_AZW3" format", all I have gotten is the following error. It has never worked for any AZW3 ebook I've tried. It also doesn't work the other way, ORIGINAL_AZW3 to AZW3.

Comparing AZW3 files inside the Edit Book to a saved AZW3 file on disk does work.

Is it perhaps because the filename extensions are different?

I just updated today to Calibre Portable version 1.48, running under Windows 8.1 64-bit with all updates installed.

Thanks!

Scott Bakker
<email address hidden>

calibre, version 1.48.0
ERROR: Unhandled exception: <b>ValueError</b>:Not a ZIP file

calibre 1.48 Portable isfrozen: True is64bit: False
Windows-8-6.2.9200 Windows ('32bit', 'WindowsPE')
32bit process running on 64bit windows
('Windows', '8', '6.2.9200')
Python 2.7.5
Windows: ('8', '6.2.9200', '', 'Multiprocessor Free')
Traceback (most recent call last):
  File "site-packages\calibre\gui2\tweak_book\diff\main.py", line 349, in ebook_diff
  File "site-packages\calibre\gui2\tweak_book\diff\main.py", line 180, in ebook_diff
  File "site-packages\calibre\ebooks\oeb\polish\container.py", line 1234, in get_container
  File "site-packages\calibre\ebooks\oeb\polish\container.py", line 930, in __init__
  File "site-packages\calibre\utils\localunzip.py", line 223, in extractall
  File "site-packages\calibre\utils\localunzip.py", line 210, in _extractall
ValueError: Not a ZIP file

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers