dict.org not available

Bug #1349548 reported by BoB on 2014-07-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Hello,
First, Thank You for this great piece of software; I am using version 1.46 [64-bit] on Windows 8 Desktop. As I was using it to read a book in my Calibre library, I tried using the dictionary function.
I highlighted a word, right-clicked it and selected "Lookup in dictionary (Ctrl-L)" and it could not access it.
I tried to manually go to Dict.org, but Chrome timed out with "Oops! Google Chrome could not connect to www.dict.org"
I do not know if the site is down, down for maintenance, or gone; I just know it was not available now.

Richo (rd2101) wrote :

I too had the same experience and the error message I got is as follows:

Failed to connect to dict.org

Traceback (most recent call last):
File "site-packages/calibre/gui2/viewer/dictionary.py", line 38, in run
File "site-packages/calibre/gui2/viewer/dictionary.py", line 31, in define
File "site-packages/calibre/utils/dictclient.py", line 43, in __init__
File "lib/python2.7/socket.py", line 224, in meth
error: [Errno 60] Operation timed out

I am using OS X 10.9.4 (Mavericks), Calibre 1.45, and the desktop viewer.

Richo (rd2101) wrote :

The same error occurs in Calibre 1.46 for Mac

dict.org is indeed down at the moment, if it does not return in a few
days I will have to look into replacing it, probably with wikitionary.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers