Calibredb setting of series_index does not work

Bug #1329724 reported by Jindrich Kubec on 2014-06-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

I'm using external data feed to externally modify some metadata fields in my Calibre library using calibredb.exe. It worked okay some versions back (unfortunately, I don't know when it exactly started).

When doing it now, with probability of 80-90% the series_index is not updated. I can't find out in which situation it works, unfortunately.

This commandline:
"D:\Program Files (x86)\Calibre2\calibredb.exe" set_metadata --field "series_index:25" --field "series:Hercule Poirot" 7226

Has this output:
Title : Herkulovské úkoly pro Hercula Poirota
Title sort : Herkulovské úkoly pro Hercula Poirota
Author(s) : Agatha Christie [Christie, Agatha]
Series : Hercule Poirot #1
Timestamp : 2011-11-17T22:08:37+00:00
Published : 2011-11-17T22:08:37+00:00
Formats : 1
Backing up metadata
Notifying calibre of the change

As you can see, the series index is 1, not 25 as expected. It does not matter in which order the options are set, does not matter if Calibre gui is running or not, does not matter if the book has any series_index set. set_metadata simply does not set/change the value.

Calibre version: 1.40 (but it definitely does not work few version back, but it worked correctly)
OS: Windows 7 64bit, EN

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers