Closing a Virtual Library Tab Flags It As Hidden

Bug #1322474 reported by Larry Statham on 2014-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

If this is not a bug, please let me know. I have searched the help, manual, forum and blog without finding any reference to the specific functionality detailed below. If it is not a bug, perhaps we should add information to the user manual to specify how it should work.

I am using calibre version 1.38 (this also happens on earlier versions), Windows 64-bit. Running Windows 7 Ultimate (all patches up to date) on a Sony VAIO laptop model VGN-FW530F with 8GB RAM.

The issue: With the Virtual Library row of tabs displayed, closing an individual library's tab (for example my Virtual Library of all books tagged "PHP") by clicking on its "Close Tab" button will not only close the library, but also flags it as hidden. My "PHP" library is now displayed in the list accessed by the "Restore Hidden Tabs" context menu option (which I get by right-clicking in the row of Virtual Libraries).

I then get the following behavior:

1. The "PHP" library is still displayed in the list of Virtual Libraries obtained by clicking on the "Virtual Library" button.
2. Choosing the "PHP" library from that list will display the expected list of books in the main window, with the "PHP" library tab overriding the "All Books" tab.
3. Selecting any other tab from the row of Virtual Libraries will then cause the "PHP" library to disappear and the "All Books" tab to re-appear.
4. If I choose the "Hide virtual library tabs" option from the Virtual Library button, the row of virtual library tabs closes as expected. But when I then select "Show virtual libraries as tabs", the hidden tab "PHP" does not display.
4. In order to get the "PHP" library to appear and remain as a tab, I must un-hide it by selecting it from the "Restore Hidden Tabs" list.

I understand the concept of being able to "hide" tabs, but the implementation as I see it seems confusing. If you intended the "Close Tab" option to cause the tab to be hidden as well as closing, perhaps you could revise the hover message for the close button to read "Close and Hide Tab". If not, then I guess I've discovered my first calibre bug. :)

Thanks,

Larry Statham
Kirkland (Seattle), WA, USA

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released

Thank you, Kovid. I am constantly amazed at your quick response and
attention to even the little details.

Larry

On 5/26/2014 6:43 AM, Kovid Goyal wrote:
> Fixed in branch master. The fix will be in the next release. calibre is
> usually released every Friday.
>
> status fixreleased
>
> ** Changed in: calibre
> Status: New => Fix Released
>

--
*Larry Statham
Kirkland, WA (Seattle)
425-207-6308*

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers