Edit book very slow

Bug #1320829 reported by Gianluigi on 2014-05-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

I try to edit a book with the editor. After the double click on the HTML file that I want to edit (180 kb), I have to wait 4/5 minutes before the editor displays the content of the file. The same wait if I try to use the "Search and replace" feature.
It's normal ? My Calibre version is up to date (1.37), the OS is Windows 7 Home Premium.

Thank you

No, that's normal. SOmething onyour system is likely interfering with
the editor. Or the HTML file you have opened is very poorly formatted,
like having all text on a single line. Try using Tools->Beautify all
files to fix the files in your book before editing them.

 status invalid

Changed in calibre:
status: New → Invalid
Gianluigi (fennelsgi) wrote :

Thank you for your reply. The problem is present with ALL the books of the library. I've tried to "Beautify" the files of a book, but I'm waiting for over 10 minutes and still did not finish. Now (15 minutes later) is finished, but the problem remains.
While waiting I've installed SIGIL that has opend the HTML files of the book immediatly. I should prefer to use Calibre for editing the books, but it's impossible to wait so long.
Nonetheless Calibre is a very very great software.

Kovid Goyal (kovid) wrote :

The other thing you can try is turning off live spell checking in
Preferences->Editor, depending on the language/dictionary, live spell
checking can be slow.

Gianluigi (fennelsgi) wrote :

I've turned off "Show mispelled words underlined in the code view" and now the editor opens the HTML files immediatly.

Thank you very much.

Kovid Goyal (kovid) wrote :

What language/dictionary are you using?

Gianluigi (fennelsgi) wrote :

I am using the italian language.

Kovid Goyal (kovid) wrote :

And which dictionary are you using for spell checking, since by default
calibre does not have an italian dictionary.

Gianluigi (fennelsgi) wrote :

I've just added the italian dictionary downloaded from Apache Open Office, marking it as the predefined. I've also turned ON the "Show mispelled words underlined in the code view" and the editor opens the HTML files immediatly.

Thank you very much

Kovid Goyal (kovid) wrote :

Ah, there is indeed a problem where the editor will consider all words
to be misspelled if the book you are editing is in a language for which
no dictionary is installed. This causes the performance problems. I will
change it so that, when no suitable dictionary is installed, all words
are considered correctly spelled.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers