Calibre can't open AZW3 books if launched from Ubuntu Dash

Bug #1315458 reported by Chuckaluphagus on 2014-05-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

  I'm having a weird issue where Calibre can't open AZW3-format ebooks in the E-Book Viewer, but only if I launch Calibre from the Unity Dash (i.e. open the launcher, click on the Calibre icon). If I run Calibre from the command line by just typing 'calibre' and hitting Enter, there are no issues.

  When the error occurs, the E-book Viewer program launches but fails and shows this message

calibre, version 1.35.0
ERROR: Could not open ebook: [Errno 5] Input/output error

Traceback (most recent call last):
  File "site-packages/calibre/gui2/viewer/main.py", line 40, in run
  File "threading.py", line 761, in run
  File "site-packages/calibre/ebooks/oeb/iterator/book.py", line 99, in __enter__
  File "site-packages/calibre/customize/conversion.py", line 241, in __call__
  File "site-packages/calibre/ebooks/conversion/plugins/mobi_input.py", line 38, in convert
  File "site-packages/calibre/utils/logging.py", line 162, in __call__
  File "site-packages/calibre/utils/logging.py", line 154, in prints
  File "site-packages/calibre/utils/logging.py", line 45, in prints
  File "site-packages/calibre/__init__.py", line 223, in prints
IOError: [Errno 5] Input/output error

  If I close the error, the Viewer displays only a blank white page. But, if I navigate to the .azw3 file in its directory on my hard drive, and double-click on it, it opens in the E-book Viewer immediately without any problems and works perfectly. And again, there are never any problems if I run Calibre from the command line.

  The issue doesn't appear at all under any circumstances if I'm trying to open a book in Calibre in a different format, such as AZW, MOBI or PDF.

  I am running Calibre 1.35 on Ubuntu Linux 14.04 64-bit. I've tried uninstalling and reinstalling Calibre, including killing the configuration files in .config in my home directory as well and then going through the Setup Wizard again - nothing seems to make a difference.

  If you have any questions, or want me to provide more information about my computer or from logs, feel free to ask.

Thank you,
Charles

That indicates that something on your install is broken. Applications
launched from the dash do not have a functioning stdout/stderr stream.
calibre assumes it can write to both stdout and stderr by default.

1) Find the calibre.desktop file somewhere on your computer and add
> /dev/null 2> /dev/null to the launch command (this redirects stdout
> and stderr to null, which will workaround the problem).

2) Find and fix the problem with yoruy Ubuntu install, for that you will
neeed to ask for help in the ubuntu fora.

 status invalid

Changed in calibre:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers