Fetch failed from New York Times

Bug #1313982 reported by David Solomon on 2014-04-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

I've been using Calibre for a to get the NY Times on my Nook. I have a full digital subscription, no issues doing this daily. Beginning yesterday the NY times fetch would fail (direct or scheduled). I upgraded to newest calibre version 1.43 (64bit), and same issues. I do not have issues fetching other news sources (National Geographic and the Economist). Is this my pc (running Windows 7, 64 bit) or calibre? I have attached the conversion error details report as a txt file.

Thanks in advance, my first reported bug.

David Solomon

calibre, version 1.34.0 (win32, isfrozen: True)
Conversion Error: Failed: Fetch news from New York Times

David Solomon (elldave) wrote :

This is caused by one the nyt articles having a URL that is so long
that it becomes longer than the maximum path windows can handle. You can
either wait a few days for that article to no longer be downloaded, or
workaround it by setting the CALIBRE_TEMP_DIR environment variable to
something short like c:\temp or wait for the next calibre release, which
will auto-truncate these long filenames.

 status fixreleased

Changed in calibre:
status: New → Fix Released

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

David Solomon (elldave) wrote :

Thanks for the response Kovid. I'm not sure how to do the workaround you suggest so I'll just wait for the new release on Friday!

Mark Isero (markisero) wrote :

Similar issue here. Calibre allows sending of books and other periodicals besides NYT. I have a subscription to NYT but I lately get an error when sending to Kindle. Using Calibre for Mac. Thank you!

Use a usb connection, the NYT is often too large for sending by email.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers