Searching metadata using Ozon.ru failed with error

Bug #1300383 reported by Sergey Gomanyuk on 2014-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
RamZesS

Bug Description

Calibre version: 1.30
OS: Mac OS X 10.8.5

Steps to reproduce:
- Select a book
- Click edit metadata button
- Setup metadata loading: leave the OZON.ru source only
- Load metadata

Unexpected result:
- Error screen appears due HTTP 403 Forbidden at http://www.ozon.ru/webservice/webservice.asmx/SearchWebService

detailed message:
calibre, version 1.30.0
ОШИБКА: Совпадений не найдено: <p>Не удалось найти ни одной книги, соответствующей заданным критериям поиска. Попробуйте сделать их <b>менее конкретными</b>. Например, используйте только фамилию автора и одно характерное слово из названия.<p>Чтобы просмотреть полный отчёт, щёлкните «Показать подробности».

Running identify query with parameters:
{u'authors': [u'\u041c\u0430\u043a\u0441 \u0424\u0440\u0430\u0439'], u'identifiers': {u'isbn': u'5942785937'}, u'timeout': 30, u'title': u'\u0421\u043a\u0430\u0437\u043a\u0438 \u0438 \u0438\u0441\u0442\u043e\u0440\u0438\u0438'}
Using plugins: OZON.ru
The log from individual plugins is below

****************************** OZON.ru ******************************
Request extra headers: [('User-agent', 'Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)')]
Found 0 results
Downloading from OZON.ru took 0.164959192276
search url: u'http://www.ozon.ru/webservice/webservice.asmx/SearchWebService?searchContext=div_book&searchText=5-94278-593-7+%22%D0%9C%D0%B0%D0%BA%D1%81+%D0%A4%D1%80%D0%B0%D0%B9%22+%22%D0%A1%D0%BA%D0%B0%D0%B7%D0%BA%D0%B8+%D0%B8+%D0%B8%D1%81%D1%82%D0%BE%D1%80%D0%B8%D0%B8%22'
Failed to make identify query: u'http://www.ozon.ru/webservice/webservice.asmx/SearchWebService?searchContext=div_book&searchText=5-94278-593-7+%22%D0%9C%D0%B0%D0%BA%D1%81+%D0%A4%D1%80%D0%B0%D0%B9%22+%22%D0%A1%D0%BA%D0%B0%D0%B7%D0%BA%D0%B8+%D0%B8+%D0%B8%D1%81%D1%82%D0%BE%D1%80%D0%B8%D0%B8%22'
Traceback (most recent call last):
  File "site-packages/calibre/ebooks/metadata/sources/ozon.py", line 108, in identify
  File "site-packages/mechanize/_mechanize.py", line 199, in open_novisit
  File "site-packages/mechanize/_mechanize.py", line 255, in _mech_open
httperror_seek_wrapper: HTTP Error 403: Forbidden: Access is denied.

********************************************************************************
The identify phase took 0.21 seconds
The longest time (0.164959) was taken by: OZON.ru
Merging results from different sources and finding earliest publication dates from the worldcat.org service
We have 0 merged results, merging took: 0.00 seconds

You will need to contact the maintainer of the ozon.ru metadata plugin,
his email address is at the top of this file:
https://github.com/kovidgoyal/calibre/blob/master/src/calibre/ebooks/metadata/sources/ozon.py

 status wontfix

Changed in calibre:
status: New → Won't Fix
RamZesS (ramses-ru) wrote :

Hello everybody

I'm the developer of this plugin. Ozon removed its API without notification. I have to switch to HTML parsing. The new solution is almost ready and the fix will be published soon. (sorry for the inconvenience, due to lack of time)

RamZesS (ramses-ru) wrote :

Here is the patch for OZON.ru metadata plugin.

Changed in calibre:
assignee: nobody → RamZesS (ramses-ru)

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers