Converting from .docx fails

Bug #1273130 reported by Bruce W. Darby on 2014-01-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

calibre, version 1.21.0 (win32, isfrozen: True)
Conversion Error: Failed: Convert book 1 of 1 (ACT2010)

I am scanning a book into MS Word 2007 with Omnipage Ultimate. If I allow Omnipage to identify website or mailto links, the conversion of the book will fail with the following output. I am running Calbre 1.21 (64 bit) on 64-bit Windows 8.1. I also scanned the document without letting the links be identified and the source converted without complaint. I then attempted to convert a hyperlink directly in the .docx and loaded it into Calibre and tried to convert with the same error occurring.

InputFormatPlugin: DOCX Input running
on C:\Users\Bruce\AppData\Local\Temp\calibre_lifxh2\jawz46.docx
Converting Word markup to HTML
Python function terminated unexpectedly
  Element is not a child of this node. (Error Code: 1)
Traceback (most recent call last):
  File "site.py", line 132, in main
  File "site.py", line 109, in run_entry_point
  File "site-packages\calibre\utils\ipc\worker.py", line 192, in main
  File "site-packages\calibre\gui2\convert\gui_conversion.py", line 31, in gui_convert_override
  File "site-packages\calibre\gui2\convert\gui_conversion.py", line 25, in gui_convert
  File "site-packages\calibre\ebooks\conversion\plumber.py", line 1035, in run
  File "site-packages\calibre\customize\conversion.py", line 241, in __call__
  File "site-packages\calibre\ebooks\conversion\plugins\docx_input.py", line 29, in convert
  File "site-packages\calibre\ebooks\docx\to_html.py", line 162, in __call__
  File "site-packages\calibre\ebooks\docx\to_html.py", line 470, in resolve_links
  File "site-packages\calibre\ebooks\docx\to_html.py", line 460, in wrap_elems
  File "lxml.etree.pyx", line 836, in lxml.etree._Element.remove (src\lxml\lxml.etree.c:40623)
ValueError: Element is not a child of this node.

Bruce W. Darby (brucewdarby) wrote :

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers