Calibre throws error when stopping wireless device connection

Bug #1262819 reported by Greg Bell on 2013-12-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Charles Haley

Bug Description

In addition to the problems reported in ​ #1214652, the following behaviour is observed when stopping a wireless connection:

calibre 1.15 /
OS X Mavericks / Firewall not enabled / DHCP enabled /
android 4.4.2 (kernel 3.4.5) on Asus MeMO HD 7, using calibre companion

Steps to reproduce
=

1. Start calbre
2. Start wireless device connection
3. Enter a port number
4. Stop wireless device connection.
5. See details below - dialog and traceback.

NOTE: the wireless connection does not stop (or appears not to stop from calibre interface. Restarting the application does not reset the wireless connection.

=

Dialog box:

ERROR: Unhandled exception
gaierror: [Errno 8] nodename nor servname provided,or not known

calibre, version 1.15.0
ERROR: Unhandled exception: <b>gaierror</b>:[Errno 8] nodename nor servname provided, or not known

=

Traceback as follows:

calibre 1.15 isfrozen: True is64bit: True
Darwin-13.0.0-x86_64-i386-64bit Darwin ('64bit', '')
('Darwin', '13.0.0', 'Darwin Kernel Version 13.0.0: Thu Sep 19 22:22:27 PDT 2013; root:xnu-2422.1.72~6/RELEASE_X86_64')
Python 2.7.5
OSX: ('10.9.1', ('', '', ''), 'x86_64')
Traceback (most recent call last):
  File "site-packages/calibre/gui2/actions/device.py", line 252, in control_smartdevice
  File "site-packages/calibre/gui2/device.py", line 652, in stop_plugin
  File "site-packages/calibre/gui2/device.py", line 642, in _call_request
  File "site-packages/calibre/devices/smart_device_app/driver.py", line 50, in _synchronizer
  File "site-packages/calibre/devices/smart_device_app/driver.py", line 1591, in stop_plugin
  File "site-packages/calibre/devices/smart_device_app/driver.py", line 50, in _synchronizer
  File "site-packages/calibre/devices/smart_device_app/driver.py", line 1576, in shutdown
  File "site-packages/calibre/utils/mdns.py", line 156, in unpublish
  File "site-packages/calibre/utils/mdns.py", line 103, in start_server
  File "site-packages/calibre/utils/Zeroconf.py", line 1263, in __init__
gaierror: [Errno 8] nodename nor servname provided, or not known

Changing the component for this bug.

 assignee cbhaley
 status triaged

Changed in calibre:
assignee: nobody → Charles Haley (cbhaley)
status: New → Triaged
Charles Haley (cbhaley) on 2014-01-06
Changed in calibre:
status: Triaged → Fix Committed

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Fix Committed → Fix Released

Thanks for the update, and the fix

On 6 Jan 2014, at 08:54, Kovid Goyal <email address hidden> wrote:

> Fixed in branch master. The fix will be in the next release. calibre is
> usually released every Friday.
>
> status fixreleased
>
> ** Changed in: calibre
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1262819
>
> Title:
> Calibre throws error when stopping wireless device connection
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1262819/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers