Google Images metadata search yields no results

Bug #1254973 reported by Natalie on 2013-11-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

In the last couple of days, the Google Images metadata source plugin has stopped yielding any results. Last known day it worked was Nov 22, 2013. I have tried the most recent version of Calibre (1.12) and the last known good version (1.11) in both Mac OS X 10.8 and 10.9, clean fresh installs of both with no custom settings and no network blocks. When I try to search for book covers with this source plugin here is the log it produces:

Starting cover download for: Knockemstiff
Query: Knockemstiff [u'Donald Ray Pollock'] {u'amazon': u'B0015KGXE6', u'google': u'UTCL2ISbcKMC', u'isbn': u'9780385525404', u'barnesnoble': u'w/knockemstiff-donald-ray-pollock/1100292087', u'goodreads': u'7004672'}

****************************** Google Images Covers ******************************
Request extra headers: [('User-agent', 'Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.63 Safari/534.3')]
Failed to download valid cover
Took 3.78553199768 seconds
No images found for, title: u'Knockemstiff' and authors: [u'Donald Ray Pollock']

********************************************************************************

The current cover I am using in my library was downloaded with this same plugin on November 22, but now it isn't finding a single cover.

I'm wondering if Google image search has changed something on the backend that has affected the Calibre plugin.

Natalie (nataliem105) on 2013-11-26
description: updated

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
ProkK (prokprok) wrote :

Hi Kovid,
Google Image Search plugin gives me no results with books in czech. The reason is that the query e.g.: "Query: Knockemstiff [u'Donald Ray Pollock']" has the "[u'Donald Ray Pollock']" part.

It's not such a bug but I want to change the query at least in my version of Calibre to reach any search results.
Tell me, please, where the Google Image Search plugin is located e.g. C/users/username/appdata/roaming/calibre or wherever and how to edit it, if it's posible. I did not find it.

Thank you for your amazing work!
prok

The code is in google_images.py and instructions on how to run calibre
from source are in the user manual.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers