quickview should be pinned on top of main GUI

Bug #1253922 reported by Eli Schwartz on 2013-11-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Charles Haley

Bug Description

Just like the Jobs window, the Quickview window should stay on screen even when the focus switches to the main library window.

It makes it much easier to use, especially when changing the viewing parameters, if you can see it while you choose stuff. Right now I have to pin it as Always on Top or else it disappears and I have to pull it up from the taskbar again.

calibre 1.12 on Ubuntu 12.04 LTS

Changing the component for this bug.

 assignee cbhaley
 status triaged

Changed in calibre:
assignee: nobody → Charles Haley (cbhaley)
status: New → Triaged
Charles Haley (cbhaley) wrote :

What do you mean by "pin"?

On my windows installation the QV window is always on top, even when focus switches to calibre's spreadsheet window. According to the graphics toolkit documentation, that should be true on all platforms. The QV window will go behind a book details or cover browser window, but I consider that to be correct behavior.

Changed in calibre:
status: Triaged → Incomplete

I mean just that; if I switch the focus to the spreadsheet, (and I was not
using book details or cover view) the QV window was getting hidden behind
the spreadsheet window. If this is not supposed to be happening, then I'm
not sure why it is, I am running the latest version installed from the
website. If there is any experiment I can try for you I will be happy to do
so.

A workaround is to right-click on the window and select Always On Top,
which is part of gnome-desktop I believe -- see screenshot.

restarting in debug mode and trying it out doesn't say anything horrible is
happening (again, see screenshot), beyond that I have no idea what to
suggest.

Also attached is a screenshot of the quickview window being partially
hidden behind the non-fullscreen main calibre window.

-- Eli Schwartz

On Fri, Nov 22, 2013 at 3:43 AM, Charles Haley
<email address hidden>wrote:

> What do you mean by "pin"?
>
> On my windows installation the QV window is always on top, even when
> focus switches to calibre's spreadsheet window. According to the
> graphics toolkit documentation, that should be true on all platforms.
> The QV window will go behind a book details or cover browser window, but
> I consider that to be correct behavior.
>
> ** Changed in: calibre
> Status: Triaged => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1253922
>
> Title:
> quickview should be pinned on top of main GUI
>
> Status in calibre: e-book management:
> Incomplete
>
> Bug description:
> Just like the Jobs window, the Quickview window should stay on screen
> even when the focus switches to the main library window.
>
> It makes it much easier to use, especially when changing the viewing
> parameters, if you can see it while you choose stuff. Right now I have
> to pin it as Always on Top or else it disappears and I have to pull it
> up from the taskbar again.
>
> calibre 1.12 on Ubuntu 12.04 LTS
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1253922/+subscriptions
>

Charles Haley (cbhaley) wrote :

I was able to reproduce the problem after I installed a linux VM.

Some further digging via google tells me that Qt is broken on several *nix systems, not respecting that modeless dialogs are supposed to remain on top of their parent window. Fortunately there is a "fix" that purportedly works most of the time (and works for me on my Debian VM), where the program (calibre) explicitly informs the window manager that the modeless dialog is to remain on top.

Changed in calibre:
status: Incomplete → Fix Committed

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers