Alias not created with Add email

Bug #1252758 reported by Kathy Pusztavari on 2013-11-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

When doing an "Add email" under "Sharing books by email" if you create a new email, create the Alias, and hit "Apply" the alias is dropped. You have to go back in and add the Alias to the newly created Email.

Very small but the program is so perfect, I can't help myself by reporting this.

Kathy Pusztavari (x-k) wrote :

Oops, this is under 1.9 with Windows 7. I looked at the changes thru 1.11 and didn't see this issue as fixed so I reported it.

I cannot replicate this, in the current calibre release, steps I tried:

1) Click preferences
2) clicking sharing by email
3) click the add email button
4) enter an email address
5) double click the alias field to enter an alias for the new email
6) enter the alias and press enter
7) click apply in the top left corner
8) re-open preferences-> the alias is still there

If there is something you are doing different, feel free to let me know.

 status invalid

Changed in calibre:
status: New → Invalid
Kathy Pusztavari (x-k) wrote :

OK, I see that you have to enter the alias and then press enter. A bit of a usability issue as it frustrated me. Seems you should have an enter key pressed for you if you just hit apply.

Alrighty then, this isn't a bug, but it is a bit of a usability issue (in my opinion).

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers