Opening a PDF in calibre changes the default "Open with" app

Bug #1249698 reported by Daniel Essin on 2013-11-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Windows 8, 64-bit Calibre
Downloaded a PDF
Used the Windows explorer to locate the file
Right-clicked and selected "Open with..." calibre.exe
Calibre added the file to the library
Then clicked on the PDF linkon the right-hand side of the screen that usually opens the item for viewing.
Instead of opening a viewer, it added the PDF to Calibre again, and again
And, attempting to view any other PDF stored in Calibre added it again.

Went to windows Explorer examing the properties of the PDF
Observed that the default "Open With" app had been changed from Acrobat to Calibre.
Changed the Default app back to Acrobat

Went back to Calibre, clicked PDF and the book opened in Acrobat

This problem does not occur on the Mac and I think it is new on Windows, as I have done this procedure many times before and never experienced this behavior until now (1.10).

I cannot reproduce this, steps I tried:

1) Associate pdf with acrobat
2) Right click a pdf file in windows explorer and choose open with
calibre
3) click the pdf file in claibre, it opens in acrobat

I am guessing you had the checkbox at the bottom of the open with screen
that say "always use this program to open files of this type" checked.

 status invalid

Changed in calibre:
status: New → Invalid

On 11/9/2013 5:33 PM, Kovid Goyal wrote:
> I cannot reproduce this, steps I tried:
>
> 1) Associate pdf with acrobat
> 2) Right click a pdf file in windows explorer and choose open with
> calibre
> 3) click the pdf file in claibre, it opens in acrobat
>
> I am guessing you had the checkbox at the bottom of the open with screen
> that say "always use this program to open files of this type" checked.
It's quite possible. I don't think Windows 8 even has a clearly defined
box. It may be indicated by some other means or it simply assumes that
is what you want.

You might consider making a check that the attempts to open a viewer are
not simply recursively calling Calibre itself to avoid the problem of
creating duplicate books in the library?

Thank you,
Dan Essin
>
> status invalid
>
> ** Changed in: calibre
> Status: New => Invalid
>

Sure, I can always adda check to see if windows is going to use calibre
to open the file.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released

Thank you

> On Nov 9, 2013, at 8:14 PM, Kovid Goyal <email address hidden> wrote:
>
> Sure, I can always adda check to see if windows is going to use calibre
> to open the file.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1249698
>
> Title:
> Opening a PDF in calibre changes the default "Open with" app
>
> Status in calibre: e-book management:
> Fix Released
>
> Bug description:
> Windows 8, 64-bit Calibre
> Downloaded a PDF
> Used the Windows explorer to locate the file
> Right-clicked and selected "Open with..." calibre.exe
> Calibre added the file to the library
> Then clicked on the PDF linkon the right-hand side of the screen that usually opens the item for viewing.
> Instead of opening a viewer, it added the PDF to Calibre again, and again
> And, attempting to view any other PDF stored in Calibre added it again.
>
> Went to windows Explorer examing the properties of the PDF
> Observed that the default "Open With" app had been changed from Acrobat to Calibre.
> Changed the Default app back to Acrobat
>
> Went back to Calibre, clicked PDF and the book opened in Acrobat
>
> This problem does not occur on the Mac and I think it is new on
> Windows, as I have done this procedure many times before and never
> experienced this behavior until now (1.10).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1249698/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers