When copying or moving book to different library, Calibre does not warn if possible duplicate exists in target library.

Bug #1245089 reported by Christine Edwards on 2013-10-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

When importing a book to a Calibre library, it provides warning if current library may already contain the book. It would be great if similar warning could appear when moving or copying a book from one library to another, if book already exists in the target library. Version 1.8.0. Windows 7 OS.

To reproduce the problem:

1. Ensure at least two libraries are set up in Calibre.
2. Ensure same book exists in two libraries.
3. Copy or move same book from one library to the other.
4. No warning will appear to advise that book may already exist in the target library.

This is not a bug, but an enhancement request for a product that is already fantastic. As libraries grow bigger over time, and multiple libraries perhaps become more common, this feature would greatly enhance library management.

Thank you.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
Christine Edwards (xanteppe) wrote :

Thank you - your addition of this feature so promptly was a wonderful surprise and is greatly appreciated!

Chris

rostyvyg (rostyvyg) wrote :

I saw this feature added to the latest release, but would like to dare the author to incorporate some fuzzy logic while looking for matches. After all, there might be a discrepancy in spelling. Also the titles sometimes differ by a word (when for for example someone adds the series or installment name into the title). Make it smarter, please!!!

If you want fuzzy matching use the duplicate finder plugin, which has
plenty of fuzzy matching algorithms, even finding words that "sound" the
same. Performnace for doing fuzzy matching on copy is not acceptable for
large libraries.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers