Calibre is deleting Series field even when it's not being modified

Bug #1245058 reported by Mel B. on 2013-10-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

This is a serious bug and has lost me metadata twice now.

1) Select some books that have Series field filled.
2) Hit "E" to edit metadata
3) Type something into Series filed
4) Delete it (as if you've made a mistake and wanted to modify some other field).
5) Save

ALL of your Series data is now completely lost. I presume all other fields are susceptible to this flawed behavior.

Calibre 1.8, running on OS X.

I have no idea what you mean. If you blank any field (except title and
author) calibre assumes you want that field blanked, it has no way to
read your mind and know that when you click OK you actually did not want
the field blanked.

If you are saying that deleting the series for one book deletes the
series for ther books, I cannot reproduce that behavior.

 status invalid

Changed in calibre:
status: New → Invalid
Mel B. (bighype) wrote :

It's not invalid. It can be daily reproduced:

http://www.mobileread.com/forums/showthread.php?p=2667953

Kovid Goyal (kovid) wrote :

Ah, you are talking about the bulk metadata edit dialog, not the single
metadata edit dialog. That is indeed a bug, series should be cleared
only if the clear series check box is checked.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers