MS Word linked pictures don't get converted

Bug #1243597 reported by Leonard Chan on 2013-10-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

When you convert a Word .docx file to epub or mobi, picture that are linked within the file (as opposed to embedded) are not converted into the final format.

If you convert the .docx file to html first and then convert the html file to epub or mobi, the pictures get included in the final format properly.

Is this a limitation with the conversion process - should I embed the pictures into the Word file or just convert to html first?

I didn't embed the pictures because it allows me to make changes to the pictures without having to re-embed the picture files after every change.

It would be nice to not have to embed all of the pictures. Plus your documentation says that .docx files are preferred above html. So I'm not sure what is lost when I start from html before the conversion process.

Calibre version 1.7
Windows 7
I prefer not to attach the files at this time. Part of the problem is that if I send you the current files, I'll need to package them all up with the linked picture files in their directory. If you need them, I'll create a simplified example and email you that instead. Let me know.

Thank you.

I am going to need a sample since docx internally has several ways
linking can be implemented, and supporting ti will depend on the details
of your particular case.

 status incomplete

Changed in calibre:
status: New → Incomplete

Hello Mr. Goyal and the Calibre Team,

Okay, how's this test file? I used all three methods of inserting a
picture. It's the first method, "Link to File," where the picture
doesn't end up in the final converted file.

The other strange thing I notice was that the Calibre viewer used my
picture at the start of the mobi file. Not sure if this is just a
side effect. I normally insert a cover in the real book, so perhaps
it's just trying to use anything it can find for a cover. The Kindle
previewer doesn't show the picture at the start. I haven't tried
downloading it to my Kindle reader, but I assume that it's not there either.

Let me know if there's anything else you need.

Thanks.

Bye.
LC

At 02:05 AM 10/23/2013, you wrote:
>I am going to need a sample since docx internally has several ways
>linking can be implemented, and supporting ti will depend on the details
>of your particular case.
>
> status incomplete
>
>** Changed in: calibre
> Status: New => Incomplete
>
>--
>You received this bug notification because you are subscribed to the bug
>report.
>https://bugs.launchpad.net/bugs/1243597
>
>Title:
> MS Word linked pictures don't get converted
>
>Status in calibre: e-book management:
> Incomplete
>
>Bug description:
> When you convert a Word .docx file to epub or mobi, picture that are
> linked within the file (as opposed to embedded) are not converted into
> the final format.
>
> If you convert the .docx file to html first and then convert the html
> file to epub or mobi, the pictures get included in the final format
> properly.
>
> Is this a limitation with the conversion process - should I embed the
> pictures into the Word file or just convert to html first?
>
> I didn't embed the pictures because it allows me to make changes to
> the pictures without having to re-embed the picture files after every
> change.
>
> It would be nice to not have to embed all of the pictures. Plus your
> documentation says that .docx files are preferred above html. So I'm
> not sure what is lost when I start from html before the conversion
> process.
>
> Calibre version 1.7
> Windows 7
> I prefer not to attach the files at this time. Part of the
> problem is that if I send you the current files, I'll need to
> package them all up with the linked picture files in their
> directory. If you need them, I'll create a simplified example and
> email you that instead. Let me know.
>
> Thank you.
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/calibre/+bug/1243597/+subscriptions

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released

Thank you.

At 11:31 PM 10/23/2013, you wrote:
>Fixed in branch master. The fix will be in the next release. calibre is
>usually released every Friday.
>
> status fixreleased
>
>** Changed in: calibre
> Status: Incomplete => Fix Released
>
>--
>You received this bug notification because you are subscribed to the bug
>report.
>https://bugs.launchpad.net/bugs/1243597
>
>Title:
> MS Word linked pictures don't get converted
>
>Status in calibre: e-book management:
> Fix Released
>
>Bug description:
> When you convert a Word .docx file to epub or mobi, picture that are
> linked within the file (as opposed to embedded) are not converted into
> the final format.
>
> If you convert the .docx file to html first and then convert the html
> file to epub or mobi, the pictures get included in the final format
> properly.
>
> Is this a limitation with the conversion process - should I embed the
> pictures into the Word file or just convert to html first?
>
> I didn't embed the pictures because it allows me to make changes to
> the pictures without having to re-embed the picture files after every
> change.
>
> It would be nice to not have to embed all of the pictures. Plus your
> documentation says that .docx files are preferred above html. So I'm
> not sure what is lost when I start from html before the conversion
> process.
>
> Calibre version 1.7
> Windows 7
> I prefer not to attach the files at this time. Part of the
> problem is that if I send you the current files, I'll need to
> package them all up with the linked picture files in their
> directory. If you need them, I'll create a simplified example and
> email you that instead. Let me know.
>
> Thank you.
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/calibre/+bug/1243597/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers