Tolino Shine: Please change (again, sorry) device order

Bug #1240504 reported by Martin on 2013-10-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Using Linux, Calibre 1.6 and Tolino Shine (firmware version 1.2.5) it happens that the internal memory and the "Card A" are swapped, so that when klicking on the internal memory (device) menu button, I see the contents of the SD card and vice versa. Some time ago, this had already been a problem (see #1151901). So sorry for bringing up this issue again.

Thanks a lot!

The problem is that there now exist two versions of the device, one with
older firmware and one with newer and there is no way to distinguish
between them, since they have the same USB ids. Therefore, I do not want
to change the driver as this would change behavior for existing users.
You can work around the problem by disabling the builtin driver and
creating a custom version, as described here:
http://manual.calibre-ebook.com/faq.html#my-device-is-non-standard-or-unusual-what-can-i-do-to-connect-to-it

(There is an option to swap main mem and card when creating the
customized driver).

 status wontfix

Changed in calibre:
status: New → Won't Fix
Martin (mdatab) wrote :

Well, I'm not sure if it's good to stick the behaviour to the older firmware since - at least with this device - I'm pretty sure that everyone want's to update to the new firmware. (On the other side I'm not aware of any other Tolino- and Linux-Users with my problem here.) But these are just me 2 cents. :)

I've tried the user defined driver (previously disabling the tolino driver) and the device is detected. But enabling/disabling the swapping the main mem and card option doesn't seem to change anything. That's weird.

Kovid Goyal (kovid) wrote :

Well, we shall see if anyone else complains.

Kovid Goyal (kovid) wrote :

There was a small typo in the linux version of the custom driver that
prevented that option from having effect, it will be fixed in the next
release.

Martin (mdatab) wrote :

Yes, in the meantime I fixed that typo, too. But, what makes me wonder... Could it be that the same typo applies to the tolino (eb600) driver? Because it looks the same (just as in the user defined driver) and after fixing it, it looks good.

Kovid Goyal (kovid) wrote :

I'm confused, are you saying that after fixing the typo in the tolino
driver the drives are correct? If that is the case then how is it that
they were correct on the previous firmware?

Kovid Goyal (kovid) wrote :

I an any case, I have fixed the typo in the tolino driver (and a couple of other places where it was present).

Martin (mdatab) wrote :

I'm confused, too. But yes, this is what I'm saying. I have to admit that it's quite some time ago since I used the Tolino with calibre. So I'm quite but not 100% sure that the devices *were* correct. Back then, I switched to another reading device. Now, with a new Tolino (and new firmware) the behaviour is as explained above. I apologize for the confusion. There might be few feedback, since this is a device only for German speaking countries and there might be only few Linux users with a Tolino Shine.

Martin (mdatab) wrote :

I spent some time adding the device swapping option to the Tolino driver. Here it works. Perhaps it would be a good idea adding it to the official calibre if there are device order problems coming up.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Won't Fix → Fix Released

It always swapped drives in windows, and it continues to do so by
default.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers