ePubcheck errors

Bug #1232790 reported by Dmitry Garanin on 2013-09-29
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

I have generated a nice ePub with Calibre 1.5 64 bit directly from my docx file under Windows 7 64 bit. Unfortunately, ePubcheck finds a couple of errors:

ERROR index_split_218.html customXml/item1.xml': referenced resource missing in the package.
ERROR index_split_247.html word/numbering.xml': referenced resource missing in the package.

Is there a bug in Calibre or I did something wrong?

Attach a docx file demonstrating/reproducing the problem to this bug report. You can do that by clicking the "Add attachment or patch" link at the bottom of the bug's page. If the file you are attaching is copyrighted, mark the bug as private. You can do this by clicking the tiny lock icon next to "This report contains Public information" in the top right area of the bug's page.

 status incomplete

Changed in calibre:
status: New → Incomplete
Dmitry Garanin (einschlag) wrote :

Here is my docx file. It is a poetry book in Russian and I use Heading 2 for poem titles. There is no Word TOC but Calibre 1.5 generates a TOC in ePub from the document structure. However, there are two ePubcheck errors.

information type: Public → Private
Dmitry Garanin (einschlag) wrote :

In the file attached above, the poems are not numbered. Of course, it is better to have them numbered. For this, I redefine Heading 2 style to include numbering. However, in this case Calibre 1.5 does not include poem titles into TOC. To correct this, I create a TOC in Word. In this case, Calibre is using the latter to build the TOC in ePub, and the result is nice. However, there is an additional ePubcheck error

ERROR index_split_008.html 13 53 attribute "value" not allowed here; expected attribute "dir", "id", "lang", "style", "title" or "xml:lang"

on multiple occasions. I attach the corresponding docx file, too.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
Kovid Goyal (kovid) wrote :

Note that the epubcheck complaints about attribute "value" are not going to be fixed, since the value attribute is the only way to implement numbering robustly and it works in all epub renderers (the value attribute was deprecated in html 4 but re-instated in html 5). The people that wrote epubcheck need to get their heads examined.

Kovid Goyal (kovid) wrote :

I have made one small change to avoid using the valu attribute for simple numbered lists, so as long as your lists are nothing fancy, the resulting HTML will validate. https://github.com/kovidgoyal/calibre/commit/1999622f4408f6013d3a6b22fffc9b4552e2ff4a

information type: Private → Public
Dmitry Garanin (einschlag) wrote :

Great! I hope the next Calibre edition within a week will implement this!

Hans Rottier (hans-rottier) wrote :

Thanks, looking forward to the release

Dmitry Garanin (einschlag) wrote :

I have just installed and tested Calibre 1.6. Two ePubcheck errors are gone but the error due to the "value" variable remains for my file where I have TOC with numbered items

As I said, I have done what I can about value. The only way to fix the
remaining value erorrs would be to actually degrade the quality of the
conversion, just to satisfy a broken tool like epubcheck. This is not
something I am willing to do.

Hans Rottier (hans-rottier) wrote :

Just as Dmitry : all errors gone but for a numbered list.
(attribute "value" not allowed here; expected attribute "dir", "id", "lang", "style", "title" or "xml:lang")

Is it anyway known how to contact the makers of the Epub Validator to discuss this issue (seen comment #5 of Kovid).

Kovid Goyal (kovid) wrote :

I have reported bugs many times to the epubcheck developers. They take
years to get fixed, or are ignored.

Hans Rottier (hans-rottier) wrote :

OK, fair enough.
Case closed as far as I am concerned.
Thanks!

Dmitry Garanin (einschlag) wrote :

What I have is probably not a simple numbered list because my list is a TOC that links to items in the document. This is why the fix is not working for me. Now I will simply suppress numbering and it will validate. They will get a slightly lower quality ePub without numbers but this will do, too. Thank you, Kovid!

Robin Murphy (murphyrm124) wrote :

Hello, I am still having an issue with referenced resource missing in the package. When I view my EPUF file in either Kindle or Nook, my images do not appear. They show a box with a big red X. Can I attach my file to see if I'm able to receive any help. It is a copyrighted document. At least I believe this is the only problem...yikes.

Thank you, Robin

Subhendu Das (subhendu-das) wrote :

Would someone help me please? I am getting similar errors, repeated many times, from EPUB Validator. I am not familiar with code that Edit Book shows. It seems many of them are related to Tables that I am using in docx file saved as Webpage, Filtered format.

Here is the first example of such errors: attribute "width" not allowed here; expected attribute "abbr", "align", "axis", "char", "charoff", "class", "colspan", "dir", "headers", "id", "lang", "rowspan", "scope", "style", "title", "valign" or "xml:lang

There is also a second type of errors: attribute "target" not allowed here; expected attribute "charset", "class", "dir", "hreflang", "id", "lang", "media", "rev", "style", "title", "type" or "xml:lang"

The second error is repeated many times by replacing "target" with "link" and then with "vlink"

I may be able to edit the code, if you suggest what to replace with. It may be easier to modify the Webpage Filtered file directly, if I know what to modify.

Best regards, Subhendu

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers