Calibre Crashes on Mac OS X Mavericks

Bug #1224491 reported by Martin Vernon on 2013-09-12
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

This version of Calibre now crashes when processing for any output format. I am on Mac OS X Mavericks beta 7.

I do not provide support for beta OS releases. Feel free to re-open this
bug report after OS X Mavericks is actually released.

 status invalid

Changed in calibre:
status: New → Invalid
Russell Ahlstrom (forum-5) wrote :

Now that Mavericks is released, this still appears to be an issue.

Changed in calibre:
status: Invalid → Confirmed
Kovid Goyal (kovid) wrote :

This is caused by incompatibilities in the graphics toolkit calibre uses
(Qt) and Mavericks. You will have to wait till the incompatibilities in
Qt are fixed. For example:
https://bugreports.qt-project.org/browse/QTBUG-32943

In the meantime post the crash report, it might help.

Kovid Goyal (kovid) wrote :

Another thing that might help is if you go to Prefrences->Look & Feel and disable notifications in the system tray

John M. (imabuddha) wrote :

Disabling notifications did stop the app from crashing when converting from epub to mobi format on 10.9 for me. Thanks!

Calibre was crashing with EXC_BAD_ACCESS on conversion, downloading metadata, etc. Turning off the tray notifications fixed all of my problems. Thanks very much!

Kovid Goyal (kovid) wrote :

The problem with notifications is fixed in calibre 1.8, since no one has reported any other source of crashes, I am closing this bug report. If any of you still experience crashes, feel free to re-open it and attach the crash log.

Changed in calibre:
status: Confirmed → Fix Released
san (www-guptasandeep) wrote :

I have downloaded calibre on mac running Yosemite.
Calibre doesnt show in apps or launchpad.
Please help

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers