ODT to MOBI - Images - Cover Image will not removed and other images are missed

Bug #1224157 reported by Jens Hoyer on 2013-09-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Hello,

I think ODT to MOBI conversion with images doesn't work as described.

Calibre 1.2
Windows 7
64 bit
Kindle Paperwhite

Steps to reproduce:
 - Add the attached ODT-File to the library
 - Start the conversion form
 - Start the conversion to MOBI with default Settings

Expected result:
- Image #1 should be the cover Image and should be removed
- all other Images should be converted

I think ODT to MOBI conversion doesn't work as described.

I will explain it:
 - Image #1 (Cover Image) visible (I think that's wrong)
 - Image #2: (Bicycles Image) visible (That's right)
 - Image #3: (Golf) unvisible (I think that's wrong)
 - Image #4: (Golf) unvisible (I think that's wrong)

Please check my attached file, convert it to MOBI and open the preview. You will see the first Image (that's wrong) and miss two other Images (#3 and #4).

Jens Hoyer (jhoyer) wrote :

Make your first dummy imaghe a large image, otherwise it will not be detected
as the cover. The first image whose width * height >= 12000 and whose
height/width is between (0.8 and 1.8) is the image chosen as the cover.
In the case of your ODT file the first such image is the golf ball
picture, which is why it gets removed.

 status invalid

Changed in calibre:
status: New → Invalid
Kovid Goyal (kovid) wrote :

In the next release, I will change the code to only take the first image
as a cover if it is large enough, instead of any image in the document.

great idea

>>> Kovid Goyal <email address hidden> 12.09.2013 17:00:47 >>>
In the next release, I will change the code to only take the first image
as a cover if it is large enough, instead of any image in the document.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1224157

Title:
  ODT to MOBI - Images - Cover Image will not removed and other images
  are missed

Status in calibre: e-book management:
  Invalid

Bug description:
  Hello,

  I think ODT to MOBI conversion with images doesn't work as described.

  Calibre 1.2
  Windows 7
  64 bit
  Kindle Paperwhite

  Steps to reproduce:
   - Add the attached ODT-File to the library
   - Start the conversion form
   - Start the conversion to MOBI with default Settings

  Expected result:
  - Image #1 should be the cover Image and should be removed
  - all other Images should be converted

  I think ODT to MOBI conversion doesn't work as described.

  I will explain it:
   - Image #1 (Cover Image) visible (I think that's wrong)
   - Image #2: (Bicycles Image) visible (That's right)
   - Image #3: (Golf) unvisible (I think that's wrong)
   - Image #4: (Golf) unvisible (I think that's wrong)

  Please check my attached file, convert it to MOBI and open the
  preview. You will see the first Image (that's wrong) and miss two
  other Images (#3 and #4).

To manage notifications about this bug go to:
https://bugs.launchpad.net/calibre/+bug/1224157/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers