Subscripted text is generated by chance (MOBI)

Bug #1218858 reported by Joachim Patzke on 2013-08-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

The problem was first observed when transforming a docx-file to a HTML-file and then to a MOBI-file with Calibre.
Subscripted text in the combination <i>Word</i><sub>text</sub> did not appear in the eBook. Two reproducable cases are filtered out in the 3 HTML-examples attached:
When transforming to MOBI-Format with calibre 1.1 (other formats were not tested), the subscripted Text in the LAST line (index to first and fourth word) appears under following conditions:
The font-size in the p.MsoNormal style definition is 13.0 AND The FIRST text line is long enough
The SECOND line allways shows the subscripted text, obviously because the style class is not used there.

1: CalibreTest_OK.htm -> Subscripted Text visible
2: CalibreTest_NOK_14p.htm -> Subscripted Text not visible
3: CalibreTest_NOK_shortText.htm -> Subscripted Text not visible

Other combinations of text length, style settings and other influencing factors may also lead to this behaviour but are not reproducably documented. Appears with Calibre 1.0 too but was not tested with the html examples.

Joachim Patzke (joachim-patzke) wrote :

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers