Database integrity issue with V 1.0.0

Bug #1217988 reported by Graham Dark on 2013-08-28
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

calibre, version 1.0.0
ERROR: Failed: Database integrity check failed, click Show details for details.

Traceback (most recent call last):
  File "site-packages\calibre\gui2\dialogs\check_library.py", line 56, in dump_and_restore
  File "site-packages\calibre\db\cache.py", line 55, in ans
  File "site-packages\calibre\db\cache.py", line 1668, in dump_and_restore
  File "site-packages\calibre\db\backend.py", line 1000, in dump_and_restore
  File "site-packages\calibre\db\backend.py", line 287, in execute
  File "c:\cygwin\home\kovid\sw\build\apsw-3.7.17-r1\src\cursor.c", line 990, in APSWCursor_execute.sqlite3_prepare
MemoryError

This happens each time despite reboot

Running on Windows Vista

Attach the metadata.db file from your calibre library folder.

 status incomplete

Changed in calibre:
status: New → Incomplete
Melanie Hotz (melanie80a) wrote :

I think i can reproduce the bug. I put long comments (~15000 Byte) into ~3000 Books of 19191 books. I will attach the metadata.db

calibre-debug --gui
calibre 1.1 isfrozen: True is64bit: False
Windows-XP-5.1.2600-SP3 Windows ('32bit', 'WindowsPE')
('Windows', 'XP', '5.1.2600')
Python 2.7.4
Windows: ('XP', '5.1.2600', 'SP3', 'Multiprocessor Free')
Starting up...
Plugin FanFictionDownLoader macmenuhack file_path:C:\Dokumente und Einstellungen
\Administrator\Anwendungsdaten\calibre\plugins\fanfictiondownloader_macmenuhack.
txt
style:
Started up in 49.72 seconds with 19191 books

calibre, version 1.1.0
ERROR: Failed: Database integrity check failed, click Show details for details.

Traceback (most recent call last):
  File "site-packages\calibre\gui2\dialogs\check_library.py", line 54, in dump_and_restore
  File "site-packages\calibre\db\cache.py", line 56, in ans
  File "site-packages\calibre\db\cache.py", line 1716, in dump_and_restore
  File "site-packages\calibre\db\backend.py", line 1001, in dump_and_restore
  File "site-packages\calibre\db\backend.py", line 287, in execute
  File "c:\cygwin\home\kovid\sw\build\apsw-3.7.17-r1\src\cursor.c", line 990, in APSWCursor_execute.sqlite3_prepare
MemoryError

Melanie Hotz (melanie80a) wrote :
Melanie Hotz (melanie80a) wrote :

Ok, i was to fast sending the metadata.db. The error was not there after restarting calibre. So i add another 1000 comments. After adding comments and checking database the following error appers.

calibre, version 1.1.0
ERROR: Failed: Database integrity check failed, click Show details for details.

Traceback (most recent call last):
  File "site-packages\calibre\gui2\dialogs\check_library.py", line 54, in dump_and_restore
  File "site-packages\calibre\db\cache.py", line 56, in ans
  File "site-packages\calibre\db\cache.py", line 1716, in dump_and_restore
  File "site-packages\calibre\db\backend.py", line 995, in dump_and_restore
  File "site-packages\calibre\utils\apsw_shell.py", line 927, in process_command
  File "site-packages\calibre\utils\apsw_shell.py", line 1174, in command_dump
  File "site-packages\calibre\utils\apsw_shell.py", line 879, in process_sql
  File "site-packages\calibre\utils\apsw_shell.py", line 633, in output_insert
  File "site-packages\calibre\utils\apsw_shell.py", line 2410, in write
MemoryError

And after restarting calibre and checking again:

calibre, version 1.1.0
ERROR: Failed: Database integrity check failed, click Show details for details.

Traceback (most recent call last):
  File "site-packages\calibre\gui2\dialogs\check_library.py", line 54, in dump_and_restore
  File "site-packages\calibre\db\cache.py", line 56, in ans
  File "site-packages\calibre\db\cache.py", line 1716, in dump_and_restore
  File "site-packages\calibre\db\backend.py", line 1001, in dump_and_restore
  File "site-packages\calibre\db\backend.py", line 287, in execute
  File "c:\cygwin\home\kovid\sw\build\apsw-3.7.17-r1\src\cursor.c", line 990, in APSWCursor_execute.sqlite3_prepare
MemoryError

Melanie Hotz (melanie80a) wrote :
Melanie Hotz (melanie80a) wrote :

Is this a duplicate of Bug #1219515?

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.