calibre: e-book management

'Reset Quick Search' no longer works after using 'Find Duplicates' plugin

Reported by Mario Herodotus on 2013-04-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

In calibre-64bit-0.9.28 on Windows 7 (x64), the "Reset Quick Search" button will no longer reset results from using the "Find Duplicates" plug in. The same results remain in the list. If the button is clicked a second time the list disappears completely and I haven't found a way to restore the list.

I've tried this with searches:

Title Matching 'Identical', Author matching 'Identical'
Title Matching 'Similar', Author matching 'similar'
Title Matching 'Similar', Author matching 'fuzzy'
Title Matching 'ignore', Author matching 'Soundex (8)'

The Find Duplicates search completes successfully each time, but I cannot use the Reset Quick Search to return to the full book list.

Steps to reproduce bug:
1. Click the "Find Duplicates" button on the Main Toolbad
2. Select the "Title/Author" radio button at the top
3. Select one of the searches I listed above - I used "Similar" for the Title Matching and "Fuzzy" for the Author Matching
    3a "Show all Groups at once with Highlighting" was selected
    3b "Highlight authors in the tag browser for ignore title searches" was also selected
4. Click OK
5. The book list is populated with the duplicate books
6. Click on the "Reset Quick Search button"
    6a The list does not change back to the full list of books (this is how it would have worked in previous Calibre versions)
7. Click on the "Reset Quick Search button" again
    7a The entire list goes blank and a restart of Calibre seems to be the only way to get the book list back.

Kind Regards,
Mario

I don not provide support for third party plugins. You should contact
the plugin author. I'm guessing this is because of the new virtual
libraries feature. You can probably get back to the full library by
click the Virtual library button and selecting <None> for both the
virtual library and the additional restriction.

 status invalid

Changed in calibre:
status: New → Invalid
Mario Herodotus (mherodotus) wrote :

Sorry, I reported it here, because the plugin seems to be doing what it was meant to do, and thought it was caliber that isn't doing what it used to do. I can get back to the full library list by selecting "Virtual Library -> Additional Restrictions -> None" as you suggested, thanks for that tip.

I prefer the previous way where I could just click a button, but I understand your decision as well.

Thanks,
Mario

Kovid Goyal (kovid) wrote :

If you want reset quick search to work then the plugin has to use a
quick search as opposed to a restriction.

Mario Herodotus (mherodotus) wrote :

I'm not trying to be belligerent, I don't write code so I honestly don't understand. The plugin didn't change, Calibre did. Is there something I can share with the author, is he doing something wrong, or is this just the way Calibre will behave now that the Virtual Libraries feature has been added?

Again, I really do appreciate what you've created, I love Calibre, and the fact that you do it for free is very gracious, I'm only asking to see if I can pass on information, not to argue the point.

Thanks for your quick responses...this is an amazing product with amazing support,
Mario

Kovid Goyal (kovid) wrote :

JUst post a link to this bug report. The plugin author will be able to
figure it out.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers