Some problems in Category Editor

Bug #1106172 reported by Duong Nguyen on 2013-01-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Charles Haley

Bug Description

Calibre 0.9.16 on Windows 8 Pro 32bit.

I have 4000+ tags, 1300 books in Calibre.

When open Manager Tags ->try to add text to "Was" columm -> OK -> show error:

Traceback (most recent call last):
  File "site-packages\calibre\gui2\dialogs\tag_list_editor.py", line 213, in finish_editing
AttributeError: 'QTableWidgetItem' object has no attribute 'initial_text'

The same error for manager Serise,Publishers.

In Category Editor. Select all tags (4420 tags) and press delete. Then Calibre "Not response" in 10 minutes, full load disk, over 200 MB in memory.

A question: What is "Was" columm ?
I think it is description. I need to enter description for my tags.

Related branches

Duong Nguyen (baziduz) on 2013-01-26
description: updated

Changing the component for this bug.

 assignee cbhaley
 status triaged

Changed in calibre:
assignee: nobody → Charles Haley (cbhaley)
status: New → Triaged
Charles Haley (cbhaley) wrote :

Fixed by making the "Was" column read-only.

That column shows the previous value for a tag after you edit it. There is no way to store a description.

The time to delete lots of tags won't change. For safety, each operation is done as an independent database transaction to ensure database integrity. Note that you can delete a tag from all books using bulk metadata edit, which uses a single transaction.

Changed in calibre:
status: Triaged → Fix Committed

Fixed in branch lp:calibre. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Fix Committed → Fix Released
Duong Nguyen (baziduz) wrote :

- Still got the same error when edit "Count" column like what did with "Was" column.

- With Tags and custom columns like tag, edit tag name (in Category Editor) not save the old name to "Was" column after edit ,save then reopen Category Editor.

- With Custom composite column(Column build from other column), this is read-only column but still can access Category Editor (by right click in Tags Browser) to edit it.

- Click on "Alter Tag Browser" button -> Manager Author, Tags etc -> not show the manager for custom columns.

- After edited in Category Editor( for tag and custom column show in Tag Browser) and click Save. It reload all sections in Tags Browser, this get delay time and not goto the position when I was right click to Manager tag.

Charles Haley (cbhaley) wrote :

Re:

- Still got the same error when edit "Count" column like what did with "Was" column.

Fix submitted.

- With Tags and custom columns like tag, edit tag name (in Category Editor) not save the old name to "Was" column after edit ,save then reopen Category Editor.

This is by design. The "was" is only valid during a single editing session

- With Custom composite column(Column build from other column), this is read-only column but still can access Category Editor (by right click in Tags Browser) to edit it.

Fix submitted.

- Click on "Alter Tag Browser" button -> Manager Author, Tags etc -> not show the manager for custom columns.

This is by design.

- After edited in Category Editor( for tag and custom column show in Tag Browser) and click Save. It reload all sections in Tags Browser, this get delay time and not goto the position when I was right click to Manager tag.

Reloading all sections is by design. Positioning works for me.

Duong Nguyen (baziduz) wrote :

On Windows 8 pro 32bit.
User Categories with many sub categories ( more than 30 categories) , when right click on a category and seclect "Add sub category to ... " ->add new name and enter -> not reload items after the new category in Tag Browser.

Charles Haley (cbhaley) wrote :

Works for me. To test I did:

1) created 35 subcategories in an empty user category
2) added items to the first 6 categories.
3) created a new subcategory that would sort to the fourth position.

All the user sub-categories after the newly added one were visible.

Duong Nguyen (baziduz) wrote :

Here is my screenshot.

Duong Nguyen (baziduz) wrote :

Items add to User Categoies are from #bisac_subject column. When I move mouse to empty space of Tags Broswer(under last item) it show only item I move over on it. I think this is render problem.

Charles Haley (cbhaley) wrote :

I cannot reproduce this on Win7 Pro. See the attached screenshot. I suspect that the problem is with Qt (the graphics toolkit) on Windows 8, but I don't know that.

In any event, I cannot fix what I cannot break.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers