Large margins when converting LibreOffice odt to mobi

Bug #1002702 reported by litcafe on 2012-05-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

LibreOffice 3.5.3.2 (and also 3.5.x)
Calibre 0.8.52 (and before)
All on MAX OSX

When converting a odt-document saved with LibreOffice 3.5 into mobi I have the following issues on the kindle (and with kindle previewer):

- large margin for every heading and chapter on the right side (nearly half of the kindle display)
- Very large margins before and after chapters, headings and the original table of content items inserted by LibreOffice (the margins are nearly a quarter or half the height of the kindle display)

When the odt file is opened with LibreOffice 3.4 again and saved and than converted with Calibre, everything is fine again. It only appears with odt-files saved with LibreOffice 3.5.x).

I noticed bug #941134 but this has not fixed the problem.
I can't attach a file due to copyright reasons but will provide further infos if needed.

Related branches

Attach a file demonstrating/reproducing the problem to this bug report. You can do that by clicking the "Add attachment or patch" link at the bottom of the bug's page. If the file you are attaching is copyrighted, mark the bug as private. You can do this by clicking the tiny yellow icon next to "This bug is public" in the top right area of the bug's page.

 status incomplete

Changed in calibre:
status: New → Incomplete
litcafe (redaktion) wrote :

As I have written I unfortunately can't attach the whole files due to copyright reasons.

But I extracted the styles.xml from the the two odt-files created with version 3.4 and 3.5 of LibreOffice and attached those.

In the 3.5-file I see the '<style:paragraph-properties fo:margin="100%"' as described in bug #941134. When I remove it, nothing changes and the layout is still bad.

But if I replace the styles.xml from the 3.5 odt-file with the one from the 3.4 odt-files the mobi-file looks great again.

So there still must be something in the styles.xml of odt-files from LibreOffice 3.5 that causes these margins.

Kovid Goyal (kovid) wrote :

If you cannot atach the original file, extract a relevant portion from it, or
create a test file demonstrating the problem.

 status new
 status incomplete

litcafe (redaktion) wrote :

Attached you can find a testversion which results (in my case) in a mobi-version with strange margins

Fixed in branch lp:calibre. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
litcafe (redaktion) wrote :

Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers