calendar indicator crashes on startup

Bug #1348080 reported by Christian Stepanek on 2014-07-24
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Calendar-Indicator
Undecided
Unassigned

Bug Description

On ubuntu 14.04, 32 bit, calendar indicator crashes upon start if it is registered in Startup Applications. It has to be explicitly closed and restarted in order to get a correctly running instance.

I have no solution but a potential bypass for others that are likewise bugged by this behavior:
Instead of directly adding calendar-indicator to the list of Startup Applications, add a shell script that starts the applet with a delay.

For example:
---
#!/bin/bash
sleep 10
/opt/extras.ubuntu.com/calendar-indicator/bin/calendar-indicator
---

Under these circumstances calendar-indicator starts smoothly for me.

Oleg Cherkasov (o1e9) wrote :

Hi, the same issue over here. If there are no connected to network yet and calendar-indicator starts then it crashes. It may happen that network (ethernet, wifi or 4G) are no available so it would be nice to tolerate that rather crash. Nonetheless it is very good software indeed! Please fix that!

Luca Ciavatta (cialu) wrote :

Same issue over Ubuntu 15.04 if no internet connection is available at start.
When pc is connected, if I launch calendar-indicator all is ok.

sk8erass (l-liberatore) wrote :

Hi I've had the same problem and I fixed it in linux mint with this workaround:

1)go to the path of your personal autostart

      cd ~/.config/autostart/

2)there create a file called:

       sudo gedit calendar-indicator.desktop

3)copy and paste this on the file

[Desktop Entry]
Type=Application
Exec=/opt/extras.ubuntu.com/calendar-indicator/bin/calendar-indicator
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[it_IT]=Calendar Indicator
Name=Calendar Indicator
Comment[it_IT]=Google calendar
Comment=Google calendar
X-GNOME-Autostart-Delay=0

4)then save the file

5)change permissions to the file

     sudo chmod u=rw,g=r,o=r script.sh calendar-indicator.desktop

6) That's it ... now it should work again!

sk8erass (l-liberatore) wrote :

ooops...I've found an error, sorry the 5) point should be :

            sudo chmod u=rw,g=r,o=r calendar-indicator.desktop

sk8erass (l-liberatore) on 2015-07-07
Changed in calendar-indicator:
status: New → Confirmed
Nora Drenalin (lurxen) wrote :

sk8erass' workaround worked for me, too (Ubuntu Mate 16.04 64bit).
Might the actual bug being somehow connected to the following typo?

There are two files in ~/.config/autostart for calendar-indicator:

calendar-indicator-autostart.desktop
calender-indicator.desktop

So I cannot do "sudo gedit calendar-indicator.desktop", because the files name here is calendEr-indicator.desktop

Hope, this helps

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers