Activity log for bug #1823569

Date Who What changed Old value New value Message
2019-04-07 20:30:58 Scott Cowles Jacobs bug added bug
2019-04-07 20:30:58 Scott Cowles Jacobs attachment added CalamaresCrash_FromTerminal.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253788/+files/CalamaresCrash_FromTerminal.txt
2019-04-07 20:39:05 Scott Cowles Jacobs attachment added CalamaresSuccess_FromTerminal.txt https://bugs.launchpad.net/ubuntu/+source/calamares/+bug/1823569/+attachment/5253789/+files/CalamaresSuccess_FromTerminal.txt
2019-04-07 23:05:21 Walter Lapchynski bug added subscriber Walter Lapchynski
2019-04-07 23:06:12 Launchpad Janitor calamares (Ubuntu): status New Confirmed
2019-04-07 23:06:32 Walter Lapchynski tags apport-collected disco
2019-04-07 23:06:35 Walter Lapchynski attachment added .etc.calamares.modules.after_bootloader_context.conf.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253814/+files/.etc.calamares.modules.after_bootloader_context.conf.txt
2019-04-07 23:06:37 Walter Lapchynski attachment added .etc.calamares.modules.before_bootloader_context.conf.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253815/+files/.etc.calamares.modules.before_bootloader_context.conf.txt
2019-04-07 23:06:40 Walter Lapchynski attachment added .etc.calamares.modules.before_bootloader_mkdirs_context.conf.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253816/+files/.etc.calamares.modules.before_bootloader_mkdirs_context.conf.txt
2019-04-07 23:06:42 Walter Lapchynski attachment added .etc.calamares.modules.bootloader.conf.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253817/+files/.etc.calamares.modules.bootloader.conf.txt
2019-04-07 23:06:44 Walter Lapchynski attachment added .etc.calamares.modules.displaymanager.conf.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253818/+files/.etc.calamares.modules.displaymanager.conf.txt
2019-04-07 23:06:46 Walter Lapchynski attachment added .etc.calamares.modules.fstab.conf.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253819/+files/.etc.calamares.modules.fstab.conf.txt
2019-04-07 23:06:47 Walter Lapchynski attachment added .etc.calamares.modules.locale.conf.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253820/+files/.etc.calamares.modules.locale.conf.txt
2019-04-07 23:06:49 Walter Lapchynski attachment added .etc.calamares.modules.machineid.conf.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253821/+files/.etc.calamares.modules.machineid.conf.txt
2019-04-07 23:06:50 Walter Lapchynski attachment added .etc.calamares.modules.mount.conf.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253822/+files/.etc.calamares.modules.mount.conf.txt
2019-04-07 23:06:52 Walter Lapchynski attachment added .etc.calamares.modules.packages.conf.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253823/+files/.etc.calamares.modules.packages.conf.txt
2019-04-07 23:06:54 Walter Lapchynski attachment added .etc.calamares.modules.users.conf.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253824/+files/.etc.calamares.modules.users.conf.txt
2019-04-07 23:06:56 Walter Lapchynski attachment added .etc.calamares.modules.welcome.conf.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253825/+files/.etc.calamares.modules.welcome.conf.txt
2019-04-07 23:06:58 Walter Lapchynski attachment added .etc.calamares.settings.conf.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253826/+files/.etc.calamares.settings.conf.txt
2019-04-07 23:07:00 Walter Lapchynski attachment added .home.lubuntu..cache.Calamares.session.log.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253827/+files/.home.lubuntu..cache.Calamares.session.log.txt
2019-04-07 23:07:02 Walter Lapchynski attachment added Dependencies.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253828/+files/Dependencies.txt
2019-04-07 23:07:05 Walter Lapchynski attachment added ProcCpuinfoMinimal.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253829/+files/ProcCpuinfoMinimal.txt
2019-04-07 23:07:07 Walter Lapchynski attachment added ProcEnviron.txt https://bugs.launchpad.net/bugs/1823569/+attachment/5253830/+files/ProcEnviron.txt
2019-04-07 23:18:08 Walter Lapchynski description I have tested this a couple of times, and will attach a text file of terminal output. I was installing the beta of Lubuntu 19.04 (03/26), and manually editing partitions. I had edited a partition, and either hit "Enter" from the partition name field, or clicked on "OK" (depending on which partition I was editing at the time). I realized that I had made a mistake that I wished to correct, so I clicked immediately on "Edit", and Calamares disappeared. I re-invoked Calamares, and when I reached the point where I was editing partitions, I intentionally did the same thing - this time, noting that after the Edit window left, that a) no partition was selected (not the partition I had been editing, nor any other) and b) that the "Edit" button was blue (the same color used for selected partitions). I clicked on "Edit", and Calamares disappeared, as I had expected. Third time, I searched for the exec line in the Calamares .desktop file, and invoked Calamares from the terminal. All happened exactly as before. All lines in the text file except the SegFault appeared BEFORE I clicked on Edit. The final line is: "bash: line 1: 3096 Segmentation fault sudo -E calamares" (whether any of the previous lines indicate something needing to be addressed (whether relating to this issue or not), I will leave to your expertise...) -------------------------------------------- calamares 3.2.4-0ubuntu1 calamares-settings-lubuntu 1:19.04.3 calamares-settings-ubuntu-common 1:19.04.3 partitionmanager 3.3.1-5 STEPS TO REPRODUCE 1. Boot Lubuntu 2. Run the installer (Calamres) 3. Select manual partitioning 4. Making sure a partition table exists and that at least one partition exists, click on a partition 5. Click Edit 6. Click ok 7. Noting that no partition is selected but the Edit button is highlighted (blue), click it EXPECTED RESULTS Nothing happens since no partition is selected, or if it was really smart, the last selected partition is edited. ACTUAL RESULTS Calamares segfaults. AFFECTED VERSIONS calamares 3.2.4-0ubuntu1 calamares-settings-lubuntu 1:19.04.3 calamares-settings-ubuntu-common 1:19.04.3 partitionmanager 3.3.1-5 Cosmic/calamares 3.2.2-0ubuntu1 does not suffer from this bug.
2019-04-07 23:18:42 Walter Lapchynski calamares (Ubuntu): importance Undecided Medium
2019-04-08 04:57:11 Walter Lapchynski calamares (Ubuntu): status Confirmed Triaged
2019-04-08 04:57:20 Walter Lapchynski bug watch added https://github.com/calamares/calamares/issues/1097
2019-04-08 04:57:20 Walter Lapchynski bug task added calamares
2019-04-08 05:00:24 Walter Lapchynski summary Lubuntu 19.04 beta - SegFault from manual partitioning when "Edit" clicked on with no partition selected Lubuntu 19.04 beta - SegFault from manual partitioning when "Create" or "Edit" clicked on with no partition selected
2019-04-08 05:01:41 Walter Lapchynski description STEPS TO REPRODUCE 1. Boot Lubuntu 2. Run the installer (Calamres) 3. Select manual partitioning 4. Making sure a partition table exists and that at least one partition exists, click on a partition 5. Click Edit 6. Click ok 7. Noting that no partition is selected but the Edit button is highlighted (blue), click it EXPECTED RESULTS Nothing happens since no partition is selected, or if it was really smart, the last selected partition is edited. ACTUAL RESULTS Calamares segfaults. AFFECTED VERSIONS calamares 3.2.4-0ubuntu1 calamares-settings-lubuntu 1:19.04.3 calamares-settings-ubuntu-common 1:19.04.3 partitionmanager 3.3.1-5 Cosmic/calamares 3.2.2-0ubuntu1 does not suffer from this bug. STEPS TO REPRODUCE  1. Boot Lubuntu  2. Run the installer (Calamres)  3. Select manual partitioning  4. Making sure a partition table exists and that at least one partition exists, click on a partition  5. Click Edit or Create  6. Click ok  7. Noting that no partition is selected but the Edit or Create button is highlighted (blue), click it EXPECTED RESULTS Nothing happens since no partition is selected. ACTUAL RESULTS Calamares segfaults. AFFECTED VERSIONS calamares 3.2.4-0ubuntu1 calamares-settings-lubuntu 1:19.04.3 calamares-settings-ubuntu-common 1:19.04.3 partitionmanager 3.3.1-5 Cosmic/calamares 3.2.2-0ubuntu1 does not suffer from this bug.
2019-04-08 05:31:06 Bug Watch Updater calamares: status Unknown Fix Released
2019-04-11 08:54:04 Launchpad Janitor calamares (Ubuntu): status Triaged Fix Released