Incorrect down/up speeds in Netspeed

Bug #672452 reported by Tsu Jan on 2010-11-08
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Cairo-Dock Plug-ins
Undecided
Matthieu Baerts

Bug Description

Recently, I began to use Netspeed applet on the dock and found that it doesn't show the up/down speeds correctly.

I think the following two lines, near the end of "applet-netspeed.c", are incorrect:

s_fValues[0] = fDownValue;
s_fValues[1] = fUpValue;

Changing them to:

s_fValues[1] = fDownValue;
s_fValues[0] = fUpValue;

fixed the issue for me.

BTW, 'Network-Monitor/src/applet-netspeed.c' has the same issue.

Related branches

Fabounet (fabounet03) wrote :

actually I don't see how you know the values are incorrect. The applet just shows 2 values, the first one (usually on top) being the download speed.
could you please give more details (gauge/graphic ? maybe a sceenshot).
thanks !

Tsu Jan (tsujan2000) wrote :

I compared the values with those of Conky, System Monitor and GKrellm. All of these network monitors showed the same speeds, while Cairo-Dock's Netspeed (on the dock) showed irrelevant values. Since I made those changes, Netspeed shows what the other network monitors do. As I was satisfied with the effect, I didn't think about the cause ;) Now the lower value is the correct download speed, while the upper one is the correct upload speed.

ok thanks for the detail :-)
do you use a graphic or a gauge ? if so, which gauge theme ?

2011/1/25 Tsu Jan <email address hidden>

> I compared the values with those of Conky, System Monitor and GKrellm.
> All of these network monitors showed the same speeds, while Cairo-Dock's
> Netspeed (on the dock) showed irrelevant values. Since I made those
> changes, Netspeed shows what the other network monitors do. As I was
> satisfied with the effect, I didn't think about the cause ;) Now the
> lower value is the correct download speed, while the upper one is the
> correct upload speed.
>
> --
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Plug-ins.
> https://bugs.launchpad.net/bugs/672452
>
> Title:
> Incorrect down/up speeds in Netspeed
>
> Status in Cairo-Dock : Plug-ins:
> New
>
> Bug description:
> Recently, I began to use Netspeed applet on the dock and found that it
> doesn't show the up/down speeds correctly.
>
> I think the following two lines, near the end of "applet-netspeed.c",
> are incorrect:
>
> s_fValues[0] = fDownValue;
> s_fValues[1] = fUpValue;
>
> Changing them to:
>
> s_fValues[1] = fDownValue;
> s_fValues[0] = fUpValue;
>
> fixed the issue for me.
>
> BTW, 'Network-Monitor/src/applet-netspeed.c' has the same issue.
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Tsu Jan (tsujan2000) wrote :

The graph mode doesn't show both values on the icon for me. I use Ubuntu Light Theme with values on the icon.

Soos Gergely (sogerc1) wrote :

For me the main problem is that the up speed is always 0.
I can also confirm that the up and down speeds are switched.
I've just made a download and an upload to a fast server nearby me.
The value for the download speed on the label agrees with azureus, the upload speed is always zero.
On the graph on the other hand the labels are probably reversed because the top graph shows a correct graph for the download however it is marked "UP". The lower graph is marked as "DOWN" and stays 0.

If I switch to the gauge view the same thing happens.

SQP (sqp) wrote :

Patch commited that should fix the netspeed bugs.
Please give it a try and tell me if you still have problems.

http://bazaar.launchpad.net/~cairo-dock-team/cairo-dock-plug-ins/plug-ins/revision/2109

Changed in cairo-dock-plug-ins:
status: New → Fix Committed
Fabounet (fabounet03) wrote :

thanks SQP :-)
actually your patch fixes half of the bug (sometimes there is a space after
the ':', sometimes not)
so I've improved the fix and Matttbe should be about to push it into the 2.4
release.

2011/9/25 SQP <email address hidden>

> Patch commited that should fix the netspeed bugs.
> Please give it a try and tell me if you still have problems.
>
> http://bazaar.launchpad.net/~cairo-dock-team/cairo-dock-plug-ins/plug-
> ins/revision/2109
>
> ** Changed in: cairo-dock-plug-ins
> Status: New => Fix Committed
>
> --
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Plug-ins.
> https://bugs.launchpad.net/bugs/672452
>
> Title:
> Incorrect down/up speeds in Netspeed
>
> Status in Cairo-Dock: Plug-ins:
> Fix Committed
>
> Bug description:
> Recently, I began to use Netspeed applet on the dock and found that it
> doesn't show the up/down speeds correctly.
>
> I think the following two lines, near the end of "applet-netspeed.c",
> are incorrect:
>
> s_fValues[0] = fDownValue;
> s_fValues[1] = fUpValue;
>
> Changing them to:
>
> s_fValues[1] = fDownValue;
> s_fValues[0] = fUpValue;
>
> fixed the issue for me.
>
> BTW, 'Network-Monitor/src/applet-netspeed.c' has the same issue.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/672452/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team
> More help : https://help.launchpad.net/ListHelp
>

Matthieu Baerts (matttbe) wrote :

Hello,

This new patch has been committed and pushed (rev 2112).
@Fabounet: Thank you again ;)

PS: but the 2.4 release is for tonight or tomorrow... it depends if my latest modifications are ok and if I have time to prepare a little announce and other things ;)
@ Fabounet and SQP: don't hesitate to check my latest modifications if you have a few time and report it on our forum (or by mail or something else!)

* http://bazaar.launchpad.net/~cairo-dock-team/cairo-dock-plug-ins/plug-ins/revision/2112

Changed in cairo-dock-plug-ins:
status: Fix Committed → Fix Released
assignee: nobody → Matthieu Baerts (matttbe)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers