Dust Bin Hang and Incorrect Configuration

Bug #616176 reported by Tsu Jan on 2010-08-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Plug-ins
Undecided
Unassigned

Bug Description

The trash applet makes Cairo-Dock hang when its quick info setting is changed and the apply button is clicked. I found out that this behavior is because of the g_print lines in dustbin/src/applet-trashes-manager.c: I commented them out and the problem was fixed.

Yet another problem: when the quick info setting is changed to "None", there will still be an empty information on the trash icon in the form of "...". I think that with the "None" setting, nothing should be displayed on the trash icon.

However, with these bugs fixed, the trash applet is more functional now because it recognizes non-root partitions too :)

Related branches

Tsu Jan (tsujan2000) wrote :

I forgot to say that I use the latest version on https://edge.launchpad.net/~cairo-dock-team/+archive/weekly-debian/+packages, compiled from the source (2.2.0-0beta4-20100807). Compilation of the latest bazaar version gave me errors.

Hi,
thanks again for your bug reports ! :-)
about the g_print, I don't see which one could cause a problem. I'm afraid
it's a memory corruption somewhere in the reolad (I'll check at home).
ok for the quick-info.

2010/8/11 Tsu Jan <email address hidden>

> I forgot to say that I use the latest version on
> https://edge.launchpad.net/~cairo-dock-team/+archive/weekly-<https://edge.launchpad.net/%7Ecairo-dock-team/+archive/weekly->
> debian/+packages, compiled from the source (2.2.0-0beta4-20100807).
> Compilation of the latest bazaar version gave me errors.
>
> --
> Dust Bin Hang and Incorrect Configuration
> https://bugs.launchpad.net/bugs/616176
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is the registrant for Cairo-Dock Plug-ins.
>
> Status in Cairo-Dock : Plug-ins: New
>
> Bug description:
> The trash applet makes Cairo-Dock hang when its quick info setting is
> changed and the apply button is clicked. I found out that this behavior is
> because of the g_print lines in dustbin/src/applet-trashes-manager.c: I
> commented them out and the problem was fixed.
>
> Yet another problem: when the quick info setting is changed to "None",
> there will still be an empty information on the trash icon in the form of
> "...". I think that with the "None" setting, nothing should be displayed on
> the trash icon.
>
> However, with these bugs fixed, the trash applet is more functional now
> because it recognizes non-root partitions too :)
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Tsu Jan (tsujan2000) wrote :

> about the g_print, I don't see which one could cause a problem

I thought the great number of printings in .xsession-errors -- perhaps, thousands of them -- caused the hang-like behavior when I changed the above setting from "None" to showing the number of all files, while so many files were in the trash.

Tsu Jan (tsujan2000) wrote :

My bad, I was wrong and you're right; g_print lines aren't the cause. A hang occurs when the total number of files is displayed and, perhaps, there are too many files in a trashed folder. Sorry for misinformation.

Fabounet (fabounet03) wrote :

ok I've removed them anyway :-)
I don't experience such a bug, I've trid with a thousand of small files.
How many files do you need to reproduce this behavior ?

2010/8/14 Tsu Jan <email address hidden>

> My bad, I was wrong and you're right; g_print lines aren't the cause. A
> hang occurs when the total number of files is displayed and, perhaps,
> there are too many files in a trashed folder. Sorry for misinformation.
>
> --
> Dust Bin Hang and Incorrect Configuration
> https://bugs.launchpad.net/bugs/616176
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is the registrant for Cairo-Dock Plug-ins.
>
> Status in Cairo-Dock : Plug-ins: New
>
> Bug description:
> The trash applet makes Cairo-Dock hang when its quick info setting is
> changed and the apply button is clicked. I found out that this behavior is
> because of the g_print lines in dustbin/src/applet-trashes-manager.c: I
> commented them out and the problem was fixed.
>
> Yet another problem: when the quick info setting is changed to "None",
> there will still be an empty information on the trash icon in the form of
> "...". I think that with the "None" setting, nothing should be displayed on
> the trash icon.
>
> However, with these bugs fixed, the trash applet is more functional now
> because it recognizes non-root partitions too :)
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Tsu Jan (tsujan2000) wrote :

> How many files do you need to reproduce this behavior ?

I usually make deb packages from Cairo-Dock and its plugins and afterward, move the temporary folders to trash. There are many files is these folders, although I don't know how many. Then, if I use "display dustbin information" by right clicking on the trash icon or try to change the trash settings so that it displays total number of files, Cairo-Dock will hang. In both cases, the trash applet tries to show total number of files (and their size).

BTW, I fixed the "empty information" problem ("...") by making simple changes in dustbin/src/applet-trashes-manager.c. As a temporary workaround for the above problem, I just removed the information on size when right clicking on the trash icon (in dustbin/src/applet-notifications.c).

Fabounet (fabounet03) wrote :

so the problem is not when you throw away the files, but when you change the
settings of the applet with many files in the trash ?
if you throw away the files, does the applet displays correctly the size ?
it would mean that the problem lies in the reloading of the applet.

2010/8/16 Tsu Jan <email address hidden>

> > How many files do you need to reproduce this behavior ?
>
> I usually make deb packages from Cairo-Dock and its plugins and
> afterward, move the temporary folders to trash. There are many files is
> these folders, although I don't know how many. Then, if I use "display
> dustbin information" by right clicking on the trash icon or try to
> change the trash settings so that it displays total number of files,
> Cairo-Dock will hang. In both cases, the trash applet tries to show
> total number of files (and their size).
>
> BTW, I fixed the "empty information" problem ("...") by making simple
> changes in dustbin/src/applet-trashes-manager.c. As a temporary
> workaround for the above problem, I just removed the information on size
> when right clicking on the trash icon (in dustbin/src/applet-
> notifications.c).
>
> --
> Dust Bin Hang and Incorrect Configuration
> https://bugs.launchpad.net/bugs/616176
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is the registrant for Cairo-Dock Plug-ins.
>
> Status in Cairo-Dock : Plug-ins: New
>
> Bug description:
> The trash applet makes Cairo-Dock hang when its quick info setting is
> changed and the apply button is clicked. I found out that this behavior is
> because of the g_print lines in dustbin/src/applet-trashes-manager.c: I
> commented them out and the problem was fixed.
>
> Yet another problem: when the quick info setting is changed to "None",
> there will still be an empty information on the trash icon in the form of
> "...". I think that with the "None" setting, nothing should be displayed on
> the trash icon.
>
> However, with these bugs fixed, the trash applet is more functional now
> because it recognizes non-root partitions too :)
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Tsu Jan (tsujan2000) wrote :

Hi,

> so the problem is not when...

Yes. The problem appears only when I change the settings of trash to "Total number of files" or when I right click on the trash to see dustbin information, and only when there are trashed folders with many files in them.

> if you throw away the files, does the applet displays correctly the size ?

If Cairo-Dock doesn't hang, yes. But in case of trashed folders with too many files (like in the example I provided above), it just hangs and CPU usage is high.

Fabounet (fabounet03) wrote :

is it the dock that uses CPU or another process (I'm thinking of gvfs-trash)
?

2010/8/16 Tsu Jan <email address hidden>

> Hi,
>
> > so the problem is not when...
>
> Yes. The problem appears only when I change the settings of trash to
> "Total number of files" or when I right click on the trash to see
> dustbin information, and only when there are trashed folders with many
> files in them.
>
> > if you throw away the files, does the applet displays correctly the
> size ?
>
> If Cairo-Dock doesn't hang, yes. But in case of trashed folders with too
> many files (like in the example I provided above), it just hangs and CPU
> usage is high.
>
> --
> Dust Bin Hang and Incorrect Configuration
> https://bugs.launchpad.net/bugs/616176
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is the registrant for Cairo-Dock Plug-ins.
>
> Status in Cairo-Dock : Plug-ins: New
>
> Bug description:
> The trash applet makes Cairo-Dock hang when its quick info setting is
> changed and the apply button is clicked. I found out that this behavior is
> because of the g_print lines in dustbin/src/applet-trashes-manager.c: I
> commented them out and the problem was fixed.
>
> Yet another problem: when the quick info setting is changed to "None",
> there will still be an empty information on the trash icon in the form of
> "...". I think that with the "None" setting, nothing should be displayed on
> the trash icon.
>
> However, with these bugs fixed, the trash applet is more functional now
> because it recognizes non-root partitions too :)
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Tsu Jan (tsujan2000) wrote :

It's Cairo-Dock because when I kill it in such cases, CPU usage gets normal again.

Tsu Jan (tsujan2000) wrote :

Please see if the patch is OK (don't display "..." when info is set to "None").

With the changes you recently made, the right click information doesn't cause any hang :) although it still causes high CPU usage for several seconds in some cases.

Fabounet (fabounet03) wrote :

thanks for confirming the first part is fixed :-)

" it still causes high CPU usage for several seconds in some cases."
that's gfvs-trash listing all the files in all the trashes. It's quite slow
and uses CPU, but it does handle all the disks, so let's stick with it.
Maybe it worth reporting this as a bug to the gvfs team.

Thanks for the patch, it's indeed the right place !

2010/8/22 Tsu Jan <email address hidden>

> Please see if the patch is OK (don't display "..." when info is set to
> "None").
>
> With the changes you recently made, the right click information doesn't
> cause any hang :) although it still causes high CPU usage for several
> seconds in some cases.
>
>
> ** Patch added: "don't display "..." when info is set to "None""
>
> https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/616176/+attachment/1509781/+files/applet-trashes-manager.c.diff
>
> --
> Dust Bin Hang and Incorrect Configuration
> https://bugs.launchpad.net/bugs/616176
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is the registrant for Cairo-Dock Plug-ins.
>
> Status in Cairo-Dock : Plug-ins: New
>
> Bug description:
> The trash applet makes Cairo-Dock hang when its quick info setting is
> changed and the apply button is clicked. I found out that this behavior is
> because of the g_print lines in dustbin/src/applet-trashes-manager.c: I
> commented them out and the problem was fixed.
>
> Yet another problem: when the quick info setting is changed to "None",
> there will still be an empty information on the trash icon in the form of
> "...". I think that with the "None" setting, nothing should be displayed on
> the trash icon.
>
> However, with these bugs fixed, the trash applet is more functional now
> because it recognizes non-root partitions too :)
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Fabounet (fabounet03) on 2010-08-23
Changed in cairo-dock-plug-ins:
status: New → Fix Committed
Changed in cairo-dock-plug-ins:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers