Terminal applet shortkey behaviour

Bug #537943 reported by Oliver Weise on 2010-03-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Plug-ins
Undecided
Unassigned

Bug Description

The cairo dock terminal applet with it's shortkey function would be really a great way to instantly bring up a terminal if those two issues would be addressed:

- When activated via shortkey the terminal does not take input focus. So I still have to click into the terminal window to actually type commands.

- Sometimes, at yet mostly undeterminable situations, the shortkey does not work. This f.e. is the case right after cairo dock was started. Then, when I click the applet icon once, the shortkey works, at least for some time. (Sorry for not being able to narrow it down further)

My version information:
Latest Cairo Dock in OpenGL mode 2.1.3-7 on Ubuntu 9.10 64Bit, Gnome/Compiz

Related branches

Hi,
maybe there is a rule to set in your Window Manager, since the terminal is
supposed to take the focus when it appears. Could you try the shortcut of
the GMenu applet for instance (it pops up an ALT+F2-like command box)

also, could you specify a way to reproduce the 2nd point ?
the terminal has 3 states : hidden, no focus, has focus.
it is supposed to switch like that :
1&2 -> 3
3 -> 1

2010/3/12 Oliver Weise <email address hidden>

> Public bug reported:
>
> The cairo dock terminal applet with it's shortkey function would be
> really a great way to instantly bring up a terminal if those two issues
> would be addressed:
>
> - When activated via shortkey the terminal does not take input focus. So
> I still have to click into the terminal window to actually type
> commands.
>
> - Sometimes, at yet mostly undeterminable situations, the shortkey does
> not work. This f.e. is the case right after cairo dock was started.
> Then, when I click the applet icon once, the shortkey works, at least
> for some time. (Sorry for not being able to narrow it down further)
>
> My version information:
> Latest Cairo Dock in OpenGL mode 2.1.3-7 on Ubuntu 9.10 64Bit, Gnome/Compiz
>
> ** Affects: cairo-dock-plug-ins
> Importance: Undecided
> Status: New
>
> --
> Terminal applet shortkey behaviour
> https://bugs.launchpad.net/bugs/537943
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is the registrant for Cairo-Dock Plug-ins.
>
> Status in Cairo-Dock : Plug-ins: New
>
> Bug description:
> The cairo dock terminal applet with it's shortkey function would be really
> a great way to instantly bring up a terminal if those two issues would be
> addressed:
>
> - When activated via shortkey the terminal does not take input focus. So I
> still have to click into the terminal window to actually type commands.
>
> - Sometimes, at yet mostly undeterminable situations, the shortkey does not
> work. This f.e. is the case right after cairo dock was started. Then, when I
> click the applet icon once, the shortkey works, at least for some time.
> (Sorry for not being able to narrow it down further)
>
> My version information:
> Latest Cairo Dock in OpenGL mode 2.1.3-7 on Ubuntu 9.10 64Bit, Gnome/Compiz
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Fabounet (fabounet03) wrote :

ok I confirm the bug if you make it appear from the shortcut (not by clicking on the icon)
I'm on it.

Changed in cairo-dock-plug-ins:
status: New → In Progress
Fabounet (fabounet03) wrote :

ok it's fixed. :-)
thanks for reporting this !

Changed in cairo-dock-plug-ins:
status: In Progress → Fix Committed
Oliver Weise (ow-bannkreis) wrote :

Thanks a lot :-)

Sorry for my intermittent silence. If you still want to get on point 2: The only stable way to reproduce it is immediately after start of cairo dock. The terminal will not appear in shortkey until I once click on it. After that the shortkey works.

Then again this may be just an issue on my machine as I tend to fiddle a lot with various shortcuts from different applications.

So can you reproduce this behaviour or is your shortkey mapping available right from the start?

Fabounet (fabounet03) wrote :

ok I'll try to trigger the shortcut on startup and see if the dialog appears.
by the way did you try in desklet mode ?

Oliver Weise (ow-bannkreis) wrote :

No, it's still attached to the dock.

Just tried it in desklet mode. Now the terminal appears directly on cairo-dock start (as I suppose it should) and the shortcut is also directly usable.

Fabounet (fabounet03) wrote :

ok thanks for the detail, I'll see what's wrong.
by the way, do you have the same behaviour with the GMenu applet (it also has a shortcut that pops up a dialog with a widget inside) ?

Changed in cairo-dock-plug-ins:
status: Fix Committed → In Progress
Oliver Weise (ow-bannkreis) wrote :

On the GMenu applet both key shortcuts - for menu and execute command - work instantly.

But the "execute command" dialog has the same focus issue as the terminal applet. After raising it via shortcut key I must click it so I can enter the command text.

ok, I really think this problem comes from the WM, because I have the focus
directly on the entry box.
also for the terminal since my patch the focus is correct.
so I'll focus on the dialog's first appearance.

2010/3/15 Oliver Weise <email address hidden>

> On the GMenu applet both key shortcuts - for menu and execute command -
> work instantly.
>
> But the "execute command" dialog has the same focus issue as the
> terminal applet. After raising it via shortcut key I must click it so I
> can enter the command text.
>
> --
> Terminal applet shortkey behaviour
> https://bugs.launchpad.net/bugs/537943
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is the registrant for Cairo-Dock Plug-ins.
>
> Status in Cairo-Dock : Plug-ins: In Progress
>
> Bug description:
> The cairo dock terminal applet with it's shortkey function would be really
> a great way to instantly bring up a terminal if those two issues would be
> addressed:
>
> - When activated via shortkey the terminal does not take input focus. So I
> still have to click into the terminal window to actually type commands.
>
> - Sometimes, at yet mostly undeterminable situations, the shortkey does not
> work. This f.e. is the case right after cairo dock was started. Then, when I
> click the applet icon once, the shortkey works, at least for some time.
> (Sorry for not being able to narrow it down further)
>
> My version information:
> Latest Cairo Dock in OpenGL mode 2.1.3-7 on Ubuntu 9.10 64Bit, Gnome/Compiz
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Oliver Weise (ow-bannkreis) wrote :

You are right regarding the WM. The compiz settings manager, section "general options", tab "Focus & Raise Behaviour" has a setting "Focus Stealing Prevention" which....well prevents windows from "stealing focus".

By default it says "any", so it prevents all windows from stealing focus. I now extended it like that:

(any) & !(class=Cairo-dock)

And voila! Now the terminal applet correctly gains focus when called. I cannot yet say if this has some other side effects (I would have liked to more specificly exclude the terminal applet rather than the whole cairo-dock application, but didn't know how) but right now I consider this problem solved. Sorry for the confusion!

Great, so now finally I have a powerful replacement for tilda dropdown console, which became impractical with my current dual screen setup.

Fabounet (fabounet03) wrote :

thanks for sharing your solution.
by the way I've solved the problem of the first shortcut action not popping
the dialog. :-)

2010/3/16 Oliver Weise <email address hidden>

> You are right regarding the WM. The compiz settings manager, section
> "general options", tab "Focus & Raise Behaviour" has a setting "Focus
> Stealing Prevention" which....well prevents windows from "stealing
> focus".
>
> By default it says "any", so it prevents all windows from stealing
> focus. I now extended it like that:
>
> (any) & !(class=Cairo-dock)
>
> And voila! Now the terminal applet correctly gains focus when called. I
> cannot yet say if this has some other side effects (I would have liked
> to more specificly exclude the terminal applet rather than the whole
> cairo-dock application, but didn't know how) but right now I consider
> this problem solved. Sorry for the confusion!
>
> Great, so now finally I have a powerful replacement for tilda dropdown
> console, which became impractical with my current dual screen setup.
>
> --
> Terminal applet shortkey behaviour
> https://bugs.launchpad.net/bugs/537943
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is the registrant for Cairo-Dock Plug-ins.
>
> Status in Cairo-Dock : Plug-ins: In Progress
>
> Bug description:
> The cairo dock terminal applet with it's shortkey function would be really
> a great way to instantly bring up a terminal if those two issues would be
> addressed:
>
> - When activated via shortkey the terminal does not take input focus. So I
> still have to click into the terminal window to actually type commands.
>
> - Sometimes, at yet mostly undeterminable situations, the shortkey does not
> work. This f.e. is the case right after cairo dock was started. Then, when I
> click the applet icon once, the shortkey works, at least for some time.
> (Sorry for not being able to narrow it down further)
>
> My version information:
> Latest Cairo Dock in OpenGL mode 2.1.3-7 on Ubuntu 9.10 64Bit, Gnome/Compiz
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Changed in cairo-dock-plug-ins:
status: In Progress → Fix Committed
Changed in cairo-dock-plug-ins:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers