please check the version of cairo-dock when building the plugin

Bug #531319 reported by Sylvestre Ledru on 2010-03-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Plug-ins
Undecided
Unassigned

Bug Description

Hello

Since the cairo-dock API is changing, it would be nice to check the cairo-dock version when building the plugging.

For example, building cairo-dock-plugins-2.1.3-6 against cairo-dock-2.1.3-1 will fail on CairoDockImageBuffer which is unavailable.
Detection this error on configure time will save some time to users.

Related branches

Fabounet (fabounet03) wrote :

well you are not supposed to take the sources in 2 different versions ^_^
But if I find a way to make the test, I'll add it just in case.

Fabounet (fabounet03) on 2010-03-04
Changed in cairo-dock-plug-ins:
status: New → In Progress
Fabounet (fabounet03) on 2010-03-04
Changed in cairo-dock-plug-ins:
status: In Progress → Fix Committed
Changed in cairo-dock-plug-ins:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers