Cairo-Dock resize problem

Bug #449422 reported by Tsu Jan on 2009-10-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Plug-ins
Medium
Fabounet
cairo-dock-plug-ins (Ubuntu)
Undecided
Unassigned

Bug Description

When a window is closed and its icon on the dock disappears, the dock resizes itself and gets shorter. This is normal. But sometimes, during the resizing, the dock gets distorted instantly and some artifacts appear on its left side for less than a second.

I use bazaar Cairo-dock with nVidia in Debian squeeze/sid, Cairo 1.8.8.

Related branches

Matthieu Baerts (matttbe) wrote :

Thanks to have reported this bug.
In fact this is a knew bug.
 * If you are on Metacity : can you confirm (and insist ;) ) the bug #437378 ? (and / or to the bug tracker of Gnome https://bugzilla.gnome.org/show_bug.cgi?id=596464)
 * If you are on Compiz : can you confirm (and insist ;) ) the bug #434963 ?
 * If you use another WM : can you click on "Also affects project" and add the project name (or directly on the bug tracker of this WM)

Thanks for your help !

------

@ Fab : for the provided workaround it can be interesting to use the whole width of the screen(s) ;)

Changed in cairo-dock-plug-ins:
importance: Undecided → Medium
milestone: none → 2.1.0
status: New → Incomplete
Tsu Jan (tsujan2000) wrote :

Thanks for your rapid reply and sorry for reporting a known bug. I'll confirm the bug #434963.

Tsu Jan (tsujan2000) wrote :

After reading the bug #434963, I don't think that this bug is related to Compiz (please take a look at bug #434963 again). And because I do use Compiz and not Metacity, I'm afraid that the bug might belong to Cairo-Dock itself.

By the way, this flash effect on resizing didn't exist with Cairo-Dock 2.0.0.

Matthieu Baerts (matttbe) wrote :

Can you try to update Compiz ? I see that I have the 0.8.2-6 release on Squeeze (Debian Testing).

PS: another thing: if you want we have a 'weekly build' ppa for Debian users too ;) => https://launchpad.net/~cairo-dock-team/+archive/weekly-debian

Tsu Jan (tsujan2000) wrote :

Thanks for your suggestion. I upgraded Compiz to v0.8.2-6 in spite of a nasty bug in its scale add-on but unfortunately, the flash effect accompanying the dock contraction is still present.

Whether with Compiz 0.7.6 or with 0.7.8, this flash effect happens only occasionally. I couldn't find any pattern for its occurrence.

Cairo-Dock is a nice way of controlling ones computer and is more practical than a panel. But this little bug and the bug related to Shortcuts and Stack applets are somehow annoying. However, thanks for your efforts for developing such an excellent application.

Matthieu Baerts (matttbe) wrote :

We have seen that it's not easy for all WM to have a good resizing without any problems like these flashes. So fabounet has planed a workaround for the next 'micro' release (2.1.1) available soon ;)

Tsu Jan (tsujan2000) wrote :

I look forward to the new version in bazaar :)

However, I still think that the bugs I reported today (resize + Shortcuts and Stack applets) are regressions in Cairo-Dock because after compiling and installing the old Cairo-Dock 2.0.0 in Squeeze, there's no flash effect and no double Nautilus anymore. (Unfortunately, its weather applet makes the dock crash when there's no Internet connection.) I'm not a programer and couldn't find something meaningful by comparing the older and newer versions with each other. But I hope this information will be useful.

Fabounet (fabounet03) wrote :

could we have a video please ? If I could see what kind of artifacts there are, I could say if it's the WM's fault or not.
because obviously there is a bug in almost all WM about window resizing.

Tsu Jan (tsujan2000) wrote :

I attached an SWF file. The word "flash" suits it but it's not what I saw in http://videobin.org/+f6/hn.html or http://videobin.org/+f7/hp.html.

As I said above, it doesn't occur with 2.0.0.

Fabounet (fabounet03) wrote :

thanks a lot for the video !
indeed it seems different, the "flash" occurs on the left side, whereas in the other bugs it appears on the top left corner.
more than a flash, it seems that the background is not drawn at the correct position for a tiny instant.
do you have the option to make the decoration follow the mouse ? if so, could you please try with static decoratoins ?
also, does it happen with opengl or cairo backend ?

Changed in cairo-dock-plug-ins:
status: Incomplete → Confirmed
assignee: nobody → Fabounet (fabounet03)
Tsu Jan (tsujan2000) wrote :

Hurrah! With the static decoration, this "flash" disappeared. Good workaround! I use the opengl backend and have Compiz 0.8.4.

But unfortunately, a totally different bug has appeared: after updating some packages of my Debian squeeze/sid, the notification area on the dock can't be closed with a middle click anymore. Do I report it separately? Once again, Cairo-Dock 2.0.0 doesn't show this behavior. I use the latest bazaar release of Cairo-Dock and my updated packages include:

notification-daemon 0.4.0-2
GLIB 2.22.2
libboost packages 1.40.0
libgnomevfs2 packages 2.24.2
GTK+ 2.18.2 (had been updated before)

So back to GNOME panel until you fix these problems ;)

Fabounet (fabounet03) wrote :

I could reproduce the bug even with static decorations, so it is fixed now :)
the bug with the dialog has already been fixed before (so if you try the bzr version there should be no more bugs, at least from this thread ;-) )

Changed in cairo-dock-plug-ins:
status: Confirmed → Fix Committed
Tsu Jan (tsujan2000) wrote :

The bug with the Systray dialog is still present :( I'll report it separately.

Fabounet (fabounet03) on 2009-10-24
Changed in cairo-dock-plug-ins:
status: Fix Committed → Fix Released
Changed in cairo-dock-plug-ins (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock-plug-ins - 2.1.3-10-lucid-0ubuntu1

---------------
cairo-dock-plug-ins (2.1.3-10-lucid-0ubuntu1) lucid; urgency=low

  [ Matthieu Baerts (matttbe) ]
  * New upstream release (LP: #568083)
  * Fixed some bugs:
   - LP: #455261 (Cannot Modify / Add Custom Launchers)
   - LP: #449422 (Cairo-Dock resize problem)
   - LP: #489349 (showDesktop Applet only seems to work
          every second time you click on it)
   - LP: #526742 (The system monitor plugin and netspeed
          plugin inverts upside-down continuously)
   - Dbus: Used the right DBus API of Cairo-Dock (2.1.3 stable)
   - Used icons of the system
   - alsaMixer: fixed a crash when read several xml data
   - musicPlayer:
    * Removed some annoying warnings
    * Banshee-plugin: fixed some bugs due to the new version (1.4.0)

  [ Iain Lane ]
  * debian/watch: Update to match against current version
 -- Matthieu Baerts (matttbe) <email address hidden> Tue, 20 Apr 2010 01:52:21 +0200

Changed in cairo-dock-plug-ins (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.