erratic callback along top and left screen edges

Bug #993612 reported by S. Christian Collins
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Medium
Fabounet

Bug Description

I have upgraded my laptop (specs below) to Kubuntu 12.04, and along with it came the 2.0.0.1 version of Glx-Dock. I am experiencing a bug that happens when using the trackpad, but is not reproducible with a mouse. I have the dock on the left side of the screen, set to auto-hide and to appear when hitting a 200 x 2 zone. If I keep my cursor at the very left edge of the screen while I move it up and down the dock, or if I continue to press the cursor to the left edge of the screen, the dock will continuously disappear and reappear. I have created a YouTube video so you can see this bug in action: http://youtu.be/7rZrldD9hZU

This bug did not occur with the version of Glx-Dock in Oneiric. Here are some other notes on this bug:

 . The bug occurs whether the callback mode is the screen border, "where the dock is", or "hit a zone".
 . The bug occurs when the dock is on the top or left edge of the screen, but *not* on the bottom or right.
 . The bug occurs whether using Cairo-Dock or Glx-Dock.
 . The bug occurs whether desktop effects are enabled or disabled.
 . I tried deleting my ~/.config/cairo-dock folder, but the bug still persists.

One more thing: on multiple systems, I can reproduce what I believe is a related symptom of this same bug even when using a mouse. Here's how:

1. With the dock set to auto-hide on the left, move the cursor to the very left edge of the screen. Right-click on the dock. This should bring up a menu, but instead causes GLX-Dock to hide.
2. Move the cursor to the edge to show the dock again, but this time, move the cursor one pixel from the left and right-click... the menu appears!

** My System **
OS: Kubuntu 12.04 i386 w/ KDE SC 4.8.2
PC: HP Pavilion dv1550se laptop
CPU: Intel(R) Pentium(R) M processor 1.60GHz
RAM: 1.5GB DDR400
Video: Mobile 915GM/GMS/910GML Express Graphics Controller
Linux Kernel: 3.2.0-24-generic
Screen Resolution: 1280 x 768

Revision history for this message
Fabounet (fabounet03) wrote :

Thanks for the detailled bug report !
I'm going to give it a try, maybe there is a 1 pixel offset somewhere.

Revision history for this message
Matthieu Baerts (matttbe) wrote :

Hello and thank you for this bug report!

> I am experiencing a bug that happens when using the trackpad, but is not reproducible with a mouse.
This is strange... But I think this bug is not due to Cairo-Dock but maybe GTK+3.0. I already had the bug #949414 but it's a bit different (as you can see there: https://launchpadlibrarian.net/96124653/bug949029_with_cairo-dock.ogv )
I know that GTK+3.0 detects if you're using a trackpad, touchscreen or a mouse but you shouldn't have this bug with a trackpad or a mouse (except if your trackpad is detected as a touchscreen).
What's the output of this command (launched from a terminal):
    $ xinput

Also it can be interesting to have GTK logs about the input and events by launching the dock with this command:
    $ GDK_DEBUG=input,events cairo-dock
(But I think GTK+3 needs to be recompiled with this option: --enable-debug=yes)

Is it maybe possible to launch the dock with this command and post here all messages that you'll have only when you try to reproduce the bug with your trackpad and with your mouse?
   $ cairo-dock -l debug

But about this bug I'm not able to reproduce it (with a trackpad, the dock on the left of the screen and with this callback mode: "hit a zone").
Is it maybe possible to try with another WM? (e.g. with Compiz instead of Kwin?)

Revision history for this message
Fabounet (fabounet03) wrote :

Hi,
There are actually 2 problems: one with the dock and one with Compiz.

I've pushed a patch to fix the one in the dock (the first pixel was not considered to be inside the dock, now it's ok).

The other one though depends on your Compiz settings:
if you activate the "cube rotation" plug-in in Compiz (via ccsm), then Compiz reserves the left and right edges of the screen for itself (to be able to drag windows from a face of the cube to another for instance).
which means that the left and right pixels lines are virtually out of the screen.
deactivating the plug-in solves the problem.

Can you confirm please ?

Changed in cairo-dock-core:
status: New → Triaged
importance: Undecided → Medium
Revision history for this message
S. Christian Collins (s-chriscollins) wrote :

I tried the latest Cairo-Dock from BZR, and I can confirm that the bug is now fixed. I couldn't confirm the Compiz settings tweak, though, since I'm running KDE.

Fabounet (fabounet03)
Changed in cairo-dock-core:
assignee: nobody → Fabounet (fabounet03)
status: Triaged → Fix Committed
Changed in cairo-dock-core:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers