glx-dock does not work with kde 4.8.1

Bug #961048 reported by José Filipe on 2012-03-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Undecided
Matthieu Baerts

Bug Description

Hi !
I use cairo-dock a times ago, with no problems ... !
But yesterday i upgraded my software, and upgraded from kde 4.7.4 to kde 4.8.1 !
And cairo-dock with glx, does not work again, only without glx :-(
Im using Fedora 16

Related branches

Matthieu Baerts (matttbe) wrote :

Hello and thank you for this bug report.

Can you explain more what's the problem? Does it crash with KDE 4.8?
Can you also give us more details about your video card and its drivers?

BTW if you have this problem just after an update of KDE, it's maybe a bug with KDE... (or maybe this new version needs more GPU resources...)

description: updated
Matthieu Baerts (matttbe) wrote :

And what's the version of the dock? (and how did you install it)

Thanks!

Changed in cairo-dock-core:
status: New → Invalid
status: Invalid → Incomplete
José Filipe (jfilipe) wrote :

Yes it crashes with KDE 4.8.1, but not with previows KDE 4.7.4

Vídeo card (lspci):
00:02.0 VGA compatible controller: Intel Corporation 82Q35 Express Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
        Subsystem: Dell OptiPlex 755
        Flags: bus master, fast devsel, latency 0, IRQ 43
        Memory at fea00000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at ec90 [size=8]
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Memory at feb00000 (32-bit, non-prefetchable) [size=1M]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Kernel driver in use: i915
        Kernel modules: i915

I use cairo dock
from cairo dock help about
Cairo-Dock (2007-2009)
 version 2.0.8.2
from yum list cairo
cairo-dock.i686 2.4.0.2-2.fc17 @rpmfusion-free-rawhide

Do you want more informations ?

Matthieu Baerts (matttbe) wrote :

> from cairo dock help about
> Cairo-Dock (2007-2009)
> version 2.0.8.2
> from yum list cairo
> cairo-dock.i686 2.4.0.2-2.fc17

Strange!
What's the output of this command:
  $ cairo-dock -v

Can you check that you're using the 2.4.0 version? (for cairo-dock and its plug-ins)

José Filipe (jfilipe) wrote :

Hi !

I had answered !
But i execute what your request :-)

[jfilipe@localhost ~]$ cairo-dock -v
2.0.8.2

José Filipe (jfilipe) wrote :

Today when i stop to think, i see that i had two versions of the cairo dock
the version 2.0.8.2 and other 2.4.0~2 :-D
the old is in /usr/local/bin and the new in the /usr/bin
But the new has many bugs and dont open

It shows the bug:
warning : (/builddir/build/BUILD/cairo-dock-2.4.0.2/cairo-dock/src/cairo-dock.c:_cairo_dock_intercept_signal:167)
  Cairo-Dock has crashed (sig 11).
It will be restarted now.
Feel free to report this bug on glx-dock.org to help improving the dock!
info on the system :
Linux localhost.localdomain 3.3.0-4.fc16.i686.PAE #1 SMP Tue Mar 20 18:24:16 UTC 2012 i686 i686 i386 GNU/Linux
The applet 'Dbus' may be the culpritrestarting with '/usr/bin/cairo-dock -x "Dbus" -q 4'...
Sorry, Cairo-Dock has encoutered some problems, and will quit.

Matthieu Baerts (matttbe) wrote :

Thank you for these new informations.

Is it possible to quit all running versions of the dock and launch this command:
  $ /usr/bin/cairo-dock -l debug
If it still crashes, can you join a file with the output messages?

PS: But if it crashes, it can be interesting to give us the backtrace of the crash but I guess you'll have to compile the dock by yourself (it's not so complicated): http://wiki.glx-dock.org/?p=ddd

José Filipe (jfilipe) wrote :

Hi !

How do i talk a times ago, i use Fedora 16, and in this distro we use rpm's and yum to update !
I had installed the following packages of cairo-dock in my computer !
Tha backtrace, as you asked is in attach !

[root@localhost ~]# yum list cairo-dock*
Loaded plugins: auto-update-debuginfo, changelog, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
updates-debuginfo/metalink | 15 kB 00:00
rpmfusion-free-updates-debuginfo | 2.7 kB 00:00
rpmfusion-free-updates-debuginfo/primary_db | 38 kB 00:00
rpmfusion-nonfree-updates-debuginfo | 2.7 kB 00:00
updates-debuginfo | 3.1 kB 00:00
updates-debuginfo/primary_db | 463 kB 00:00
Installed Packages
cairo-dock.i686 2.4.0.2-2.fc17 @rpmfusion-free-rawhide
cairo-dock-core.i686 2.4.0.2-2.fc17 @rpmfusion-free-rawhide
cairo-dock-debuginfo.i686 2.4.0.2-2.fc17 @rpmfusion-free-rawhide-debuginfo
cairo-dock-devel.i686 2.4.0.2-2.fc17 @rpmfusion-free-rawhide
cairo-dock-plug-ins.i686 2.4.0.2.1-2.fc17 @rpmfusion-free-rawhide
cairo-dock-plug-ins-kde.i686 2.4.0.2.1-2.fc17 @rpmfusion-free-rawhide
cairo-dock-plug-ins-webkit.i686 2.4.0.2.1-2.fc17 @rpmfusion-free-rawhide
cairo-dock-plug-ins-xfce.i686 2.4.0.2.1-2.fc17 @rpmfusion-free-rawhide
cairo-dock-python.i686 2.4.0.2.1-2.fc17 @rpmfusion-free-rawhide

Matthieu Baerts (matttbe) wrote :

Hello,

It seems this crash is due to our Dbus plugin... it's strange!

Is it possible to launch these commands in a terminal and check if the dock still crash:
  $ killall cairo-dock ## (just to be sure...)
  $ /usr/bin/cairo-dock -d $HOME/cairo-dock-test
  $ rm -r cairo-dock-test

if it crashes, can you uninstall cairo-dock and compile it by yourself? Then launch the dock with GDB and try to reproduce the crash => http://wiki.glx-dock.org/?p=ddd
About the compilation of the dock and its plug-ins: http://www.glx-dock.org/ww_page.php?p=From%20BZR&lang=en#8-Fedora

Thx

José Filipe (jfilipe) wrote :

Thank you Mattieu, very mutch ! ;-)
The new cairo dock work very well. and has a so many new features like rotation ... ! :-D
Its solved my problem !

Its bad that upstream of the distros, do not available new versions ! :-(
Cairo dock 2.4 by fedora upstream, by current 3.0 is a big difference ... !

Bye

Changed in cairo-dock-core:
status: Incomplete → Fix Committed
Changed in cairo-dock-core:
status: Fix Committed → Fix Released
assignee: nobody → Matthieu Baerts (matttbe)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers