GLX-Dock Hardware acc. UNDO!

Bug #875975 reported by Jacus on 2011-10-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Undecided
Matthieu Baerts

Bug Description

I opened the file "GLX-Dock (Cairo-Dock with OpenGl)" and checked off Hardware Acceleration & Checked off don't show window any more! I can't open that window any more to uncheck it, I see the window glitch and disappear like everything else.

Related branches

I don't really understand, but you can launch cairo-dock without the
hardware acceleration (choose the entry without Opengl, or from the
terminal, run "cairo-dock -c")
to show the configuration window on startup, run "cairo-dock -m"

2011/10/16 Jacus <email address hidden>

> Public bug reported:
>
> I opened the file "GLX-Dock (Cairo-Dock with OpenGl)" and checked off
> Hardware Acceleration & Checked off don't show window any more! I can't
> open that window any more to uncheck it, I see the window glitch and
> disappear like everything else.
>
> ** Affects: cairo-dock-core
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
> https://bugs.launchpad.net/bugs/875975
>
> Title:
> GLX-Dock Hardware acc. UNDO!
>
> Status in Cairo-Dock : Core:
> New
>
> Bug description:
> I opened the file "GLX-Dock (Cairo-Dock with OpenGl)" and checked off
> Hardware Acceleration & Checked off don't show window any more! I
> can't open that window any more to uncheck it, I see the window glitch
> and disappear like everything else.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cairo-dock-core/+bug/875975/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team
> More help : https://help.launchpad.net/ListHelp
>

Jacus (toadmail69) wrote :

Hi again, the problem is that I checked off the "do not show this window
anymore" when i turned on the accelerator. So i hit, ok with the label
telling me it might now work properly. So it didn't, now why is there a
check box to not show that window anymore, I need it back to turn the
accelerator off! what do I do? uninstall does nothing!

Matthieu Baerts (matttbe) wrote :

Is it better after having launched this command from a terminal? (it's better to quit the dock before and launch it just after)
  $ sed -i "s/opengl/cairo/g" ~/.config/cairo-dock/.cairo-dock

@ fabounet: Do you have any idea how to solve this problem without the terminal? Maybe a checkbox in the config panel? Or in the menu if we use the other backend?

Fabounet (fabounet03) wrote :

the value written in the file is only used if you don't specify anything.

but you can always force the backend with the option -o or -c
moreover the cairo backend is also available from the menu.

we could possibly delete this file when the program is deinstalled.

Matthieu Baerts (matttbe) wrote :

With the development version, it's now possible to use this option:
  -A, --ask-backend

Changed in cairo-dock-core:
status: New → Fix Committed
Changed in cairo-dock-core:
status: Fix Committed → Fix Released
assignee: nobody → Matthieu Baerts (matttbe)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers