Quick-Hide hides the dock forever

Bug #580596 reported by Tsu Jan on 2010-05-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Undecided
Matthieu Baerts

Bug Description

With v2.2.0-beta, Quick-Hide hides the dock forever.

BTW, the settings in "Visibility > Visibility of the main dock" are grayed out when "Prevent windows from..." is chosen. I think, at least, "Keyboard shortcut to pop up the dock" could be used for quick hide.

None of these happened in the latest bzr version prior to v2.2.0-beta.

Related branches

Hi,
how do you reproduce this bug exactly ?

"BTW, the settings in "Visibility > Visibility of the main dock" are
grayed out when "Prevent windows from..." is chosen. I think, at least,
"Keyboard shortcut to pop up the dock" could be used for quick hide."

>>> The effect is active, maybe the "corner" one will be too, I need some
feedbacks.
The shortcut is dedicated to the last option, I see no point in making the
dock re-appear with a shortcut, since you will eventually have to move the
mouse where the dock is.

2010/5/14 Tsu Jan <email address hidden>

> Public bug reported:
>
> With v2.2.0-beta, Quick-Hide hides the dock forever.
>
> BTW, the settings in "Visibility > Visibility of the main dock" are
> grayed out when "Prevent windows from..." is chosen. I think, at least,
> "Keyboard shortcut to pop up the dock" could be used for quick hide.
>
> None of these happened in the latest bzr version prior to v2.2.0-beta.
>
> ** Affects: cairo-dock-core
> Importance: Undecided
> Status: New
>
> --
> Quick-Hide hides the dock forever
> https://bugs.launchpad.net/bugs/580596
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: New
>
> Bug description:
> With v2.2.0-beta, Quick-Hide hides the dock forever.
>
> BTW, the settings in "Visibility > Visibility of the main dock" are grayed
> out when "Prevent windows from..." is chosen. I think, at least, "Keyboard
> shortcut to pop up the dock" could be used for quick hide.
>
> None of these happened in the latest bzr version prior to v2.2.0-beta.
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Tsu Jan (tsujan2000) wrote :

Hi,

The way to reproduce the bug:

I right click on Cairo-Dock and click on Quick-Hide in the Cairo-Dock menu. The dock gets hidden as it should. But it remains hidden and I can find no way to un-hide it. With previous versions, I just put the cursor on an area near the middle of the screen bottom and the dock showed up again.

Tsu Jan (tsujan2000) wrote :

In fact, it seems that you've removed the setting related to the callback zone. Or it's dropped unintentionally?

oh you're right, I've forgotten something :-)
it's fixed now, thank you.

yes the callback zone is gone, because it wouldn't work with Compiz except
at the bottom of the screen. But you still have to touch the screen's border
to call the dock back.

2010/5/14 Tsu Jan <email address hidden>

> In fact, it seems that you've removed the setting related to the
> callback zone. Or it's dropped unintentionally?
>
> --
> Quick-Hide hides the dock forever
> https://bugs.launchpad.net/bugs/580596
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: New
>
> Bug description:
> With v2.2.0-beta, Quick-Hide hides the dock forever.
>
> BTW, the settings in "Visibility > Visibility of the main dock" are grayed
> out when "Prevent windows from..." is chosen. I think, at least, "Keyboard
> shortcut to pop up the dock" could be used for quick hide.
>
> None of these happened in the latest bzr version prior to v2.2.0-beta.
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Changed in cairo-dock-core:
status: New → Fix Released
status: Fix Released → Fix Committed
Tsu Jan (tsujan2000) wrote :

The problem with restoring the dock is fixed. Thanks.

However, Quick-Hide, in its present form, has no use. Previously, when the windows were prevented from overlapping the dock, quick hiding made the whole screen available to the maximized windows. But now, the maximized windows don't expand when quick-hide is used, so that there remains no point to quick hiding.

Fabounet (fabounet03) wrote :

actually I didn't know that quick-hiding the dock would make the windows
expand to the whole screen ^^
it's a side-effect that was not expected, since for me, quick-hiding the
dock is just a way to hide the dock temporarily (for instance, if you're
going to watch a vide and if the dock stays in front)

2010/5/16 Tsu Jan <email address hidden>

> The problem with restoring the dock is fixed. Thanks.
>
> However, Quick-Hide, in its present form, has no use. Previously, when
> the windows were prevented from overlapping the dock, quick hiding made
> the whole screen available to the maximized windows. But now, the
> maximized windows don't expand when quick-hide is used, so that there
> remains no point to quick hiding.
>
> --
> Quick-Hide hides the dock forever
> https://bugs.launchpad.net/bugs/580596
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: Fix Committed
>
> Bug description:
> With v2.2.0-beta, Quick-Hide hides the dock forever.
>
> BTW, the settings in "Visibility > Visibility of the main dock" are grayed
> out when "Prevent windows from..." is chosen. I think, at least, "Keyboard
> shortcut to pop up the dock" could be used for quick hide.
>
> None of these happened in the latest bzr version prior to v2.2.0-beta.
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Tsu Jan (tsujan2000) wrote :

All right, but it was a useful property, even a feature, because one could use the whole screen at will, even when windows were prevented from overlapping the dock.

Tsu Jan (tsujan2000) wrote :

... and if the user wanted to see what's behind the dock, he could change the desktop, where there was no maximized window.

Fabounet (fabounet03) wrote :

I see, but in this case why using the "reserve space" visibility option ?
also, if it's a video or a web page, you can set the window fullscreen.
for me it's just a way to say "you're in front of this window and I want to
see it now".

maybe we can think of another visibility option.

2010/5/17 Tsu Jan <email address hidden>

> All right, but it was a useful property, even a feature, because one
> could use the whole screen at will, even when windows were prevented
> from overlapping the dock.
>
> --
> Quick-Hide hides the dock forever
> https://bugs.launchpad.net/bugs/580596
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: Fix Committed
>
> Bug description:
> With v2.2.0-beta, Quick-Hide hides the dock forever.
>
> BTW, the settings in "Visibility > Visibility of the main dock" are grayed
> out when "Prevent windows from..." is chosen. I think, at least, "Keyboard
> shortcut to pop up the dock" could be used for quick hide.
>
> None of these happened in the latest bzr version prior to v2.2.0-beta.
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Changed in cairo-dock-core:
status: Fix Committed → Fix Released
assignee: nobody → Matthieu Baerts (matttbe)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers