Hide when a window is maximized doesn't work if the taskbar is turned off

Bug #580284 reported by Mike Vaughn on 2010-05-14
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Undecided
Matthieu Baerts

Bug Description

The summary pretty much says it. This is the same for "Hide when a window obstructs the dock" but the two are so similar I figured they'd be filed as duplicates. The dock simply doesn't hide, unless a window is fullscreen.

Related branches

Indeed, the taskbar needs to be activated in order to get this feature.
this is because it's the taskbar that tracks the opened windows.
not sure how to fix this at the moment, but why not using the taskbar of the
dock ?

2010/5/14 contrast <email address hidden>

> Public bug reported:
>
> The summary pretty much says it. This is the same for "Hide when a
> window obstructs the dock" but the two are so similar I figured they'd
> be filed as duplicates. The dock simply doesn't hide, unless a window is
> fullscreen.
>
> ** Affects: cairo-dock-core
> Importance: Undecided
> Status: New
>
> --
> Hide when a window is maximized doesn't work if the taskbar is turned off
> https://bugs.launchpad.net/bugs/580284
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: New
>
> Bug description:
> The summary pretty much says it. This is the same for "Hide when a window
> obstructs the dock" but the two are so similar I figured they'd be filed as
> duplicates. The dock simply doesn't hide, unless a window is fullscreen.
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Matthieu Baerts (matttbe) wrote :

@ fabounet: yes but if it's possible to not activate the taskbar (e.g if you launch CD 2 times, one for each monitor), this option should be supported (or having a message which mention the problem)

Mike Vaughn (mikevaughn) wrote :

I'm not using the taskbar because I prefer Smooth Tasks. It just seems to me that the window-tracking functionality of the taskbar that allows "Hide when a window obstructs..." to work could be kept on while the part of the taskbar that actually displays representations of windows in the dock could be disabled.

Mike Vaughn (mikevaughn) wrote :

Just thought of something: Couldn't the taskbar be minimized to a single icon, which, when clicked or hovered depending on the user's setup, show a list of all open windows? This way, the window-tracking could still be active and the taskbar could be easily ignored for people who don't use it. Easily implemented in the settings GUI while maintaining user-friendliness, methinks: "Show tasks as a separate list [_]"

actually the Switcher applet already does that, so it would be redundant.
but if you want to have a very little intrusive taskbar, you can use the
MacOSX mode (only show minimized window).
the advantage is that your launchers will get their indicator.

2010/5/27 contrast <email address hidden>

> Just thought of something: Couldn't the taskbar be minimized to a single
> icon, which, when clicked or hovered depending on the user's setup, show
> a list of all open windows? This way, the window-tracking could still be
> active and the taskbar could be easily ignored for people who don't use
> it. Easily implemented in the settings GUI while maintaining user-
> friendliness, methinks: "Show tasks as a separate list [_]"
>
> --
> Hide when a window is maximized doesn't work if the taskbar is turned off
> https://bugs.launchpad.net/bugs/580284
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: New
>
> Bug description:
> The summary pretty much says it. This is the same for "Hide when a window
> obstructs the dock" but the two are so similar I figured they'd be filed as
> duplicates. The dock simply doesn't hide, unless a window is fullscreen.
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

ktp (kari-petersen) wrote :

I would also like to just use it as a launcher, since I use dockbarx with my bottom gnome panel. I just want quick access to some aplications an therefore use cairo-dock with autohide. I dislike, that I have to hold down the shift key to start another instance of the application.

Matthieu Baerts (matttbe) wrote :

In the advanced mode of the config panel of Cairo-Dock / taskbar section, you can disable the mix between launchers and applications. There is also an option into the configuration panel of each launcher.

ktp (kari-petersen) wrote :

Perfect. Now cairo-dock behaves like I wanted it to behave. Could this be set via simple interface option "taskbar-none" ?

ktp (kari-petersen) wrote :

Sorry, I was too fast. It now shows the icons of the minimized windows. So still not the desired behavior.

ktp (kari-petersen) wrote :

*bump*

Fabounet (fabounet03) wrote :

There is already such an option if I remember correctly.

2010/6/8 ktp <email address hidden>

> *bump*
>
> --
> Hide when a window is maximized doesn't work if the taskbar is turned off
> https://bugs.launchpad.net/bugs/580284
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: New
>
> Bug description:
> The summary pretty much says it. This is the same for "Hide when a window
> obstructs the dock" but the two are so similar I figured they'd be filed as
> duplicates. The dock simply doesn't hide, unless a window is fullscreen.
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

ktp (kari-petersen) wrote :

There is an option to show running applications. When I disable it, the dock won't hide any more.
Same behaviour like no taskbar, so this needs a fix I think.

ktp (kari-petersen) wrote :

btw. coud anyone remove my email address from the posting above? thanks.

Matthieu Baerts (matttbe) wrote :

Hello,

@ktp, can you test our latest beta version:
 * Compiled from bzr => http://www.glx-dock.org/ww_page.php?p=From%20BZR&lang=en
 * Or by using our Weekly ppa => http://www.glx-dock.org/ww_page.php?p=ppa%20Weekly&lang=en

Your email address is hidden for all guests (all persons who aren't loggued) and we can't edit messages but you can contact a member of the Launchpad team.

Fabounet (fabounet03) wrote :

the problem isn't fixed yet.

2010/6/14 Matthieu Baerts <email address hidden>

> Hello,
>
> @ktp, can you test our latest beta version:
> * Compiled from bzr =>
> http://www.glx-dock.org/ww_page.php?p=From%20BZR&lang=en
> * Or by using our Weekly ppa =>
> http://www.glx-dock.org/ww_page.php?p=ppa%20Weekly&lang=en
>
> Your email address is hidden for all guests (all persons who aren't
> loggued) and we can't edit messages but you can contact a member of the
> Launchpad team.
>
> --
> Hide when a window is maximized doesn't work if the taskbar is turned off
> https://bugs.launchpad.net/bugs/580284
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: New
>
> Bug description:
> The summary pretty much says it. This is the same for "Hide when a window
> obstructs the dock" but the two are so similar I figured they'd be filed as
> duplicates. The dock simply doesn't hide, unless a window is fullscreen.
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

ktp (kari-petersen) wrote :

I just installed from the weekly ppa, and it doesn't fix the problem.

I'll use it with mac style taskbar enabled until this is fixed.
Btw. I like the new hide-animations and finally it hides whenever a window gets in the way. Thanks for that.

Fabounet (fabounet03) on 2011-01-25
Changed in cairo-dock-core:
status: New → Fix Committed
Changed in cairo-dock-core:
assignee: nobody → Matthieu Baerts (matttbe)
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers