xinerama:doc in one screen, subdocs in another

Bug #540979 reported by Alienation on 2010-03-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Medium
Fabounet

Bug Description

I have sometimes a second screen connected to my laptop. I've configured cairo-doc to use Xinerama and 0 is the screen number.

The doc then appears in my fixed screen, but sub-docs appear in my laptop screen, and that makes it unusable.
If I choose screen 1 then its ok (all on the laptop screen), but I had some problems with auto-hide if I do it this way.

Thanks

Related branches

can you specify the version you use please ?
also, what are the resolutions of the screen ?
could you please test with the same resolution for both ?
Thanks.

2010/3/18 Alienation <email address hidden>

> Public bug reported:
>
> I have sometimes a second screen connected to my laptop. I've configured
> cairo-doc to use Xinerama and 0 is the screen number.
>
> The doc then appears in my fixed screen, but sub-docs appear in my laptop
> screen, and that makes it unusable.
> If I choose screen 1 then its ok (all on the laptop screen), but I had some
> problems with auto-hide if I do it this way.
>
> Thanks
>
> ** Affects: cairo-dock-core
> Importance: Undecided
> Status: New
>
> --
> xinerama:doc in one screen, subdocs in another
> https://bugs.launchpad.net/bugs/540979
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: New
>
> Bug description:
> I have sometimes a second screen connected to my laptop. I've configured
> cairo-doc to use Xinerama and 0 is the screen number.
>
> The doc then appears in my fixed screen, but sub-docs appear in my laptop
> screen, and that makes it unusable.
> If I choose screen 1 then its ok (all on the laptop screen), but I had some
> problems with auto-hide if I do it this way.
>
> Thanks
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Alienation (miguel-andrade) wrote :

Version 2.1.4-0alpha . But it happens in prior versions too.

My resolutions:

screen 1: 1280x800 (LVDS1)
screen 0: 1440x900 (VGA1)

at 1024x768 in both screens the behavior is still there.

I think i should mention I'm using KDE 4.4.1 and i have one activity per screen.

Thanks

ok thanks
I've commited a fix, although I can't say if it will work.
should be available in the next weekly.

2010/3/23 Alienation <email address hidden>

> Version 2.1.4-0alpha . But it happens in prior versions too.
>
> My resolutions:
>
> screen 1: 1280x800 (LVDS1)
> screen 0: 1440x900 (VGA1)
>
> at 1024x768 in both screens the behavior is still there.
>
> I think i should mention I'm using KDE 4.4.1 and i have one activity per
> screen.
>
> Thanks
>
> --
> xinerama:doc in one screen, subdocs in another
> https://bugs.launchpad.net/bugs/540979
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: New
>
> Bug description:
> I have sometimes a second screen connected to my laptop. I've configured
> cairo-doc to use Xinerama and 0 is the screen number.
>
> The doc then appears in my fixed screen, but sub-docs appear in my laptop
> screen, and that makes it unusable.
> If I choose screen 1 then its ok (all on the laptop screen), but I had some
> problems with auto-hide if I do it this way.
>
> Thanks
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Alienation (miguel-andrade) wrote :

Well, now subdocs appear centered in the middle of both screens, that is half subdoc in screen 0 and the other half in screen 1.

But at least I can reach them now ;)

Alienation (miguel-andrade) wrote :

Btw: I've tried v2.1.4-0beta0
thanks

Alienation (miguel-andrade) wrote :

Upgraded the following packages:
cairo-dock (2.1.4-0beta0-20100324-0ubuntu1~ppa2~karmic) to 2.1.4-0beta0-20100327-0ubuntu1~ppa0~karmic
cairo-dock-core (2.1.4-0beta0-20100324-0ubuntu1~ppa2~karmic) to 2.1.4-0beta0-20100327-0ubuntu1~ppa0~karmic
cairo-dock-data (2.1.4-0beta0-20100324-0ubuntu1~ppa2~karmic) to 2.1.4-0beta0-20100327-0ubuntu1~ppa0~karmic
cairo-dock-plug-ins (2.1.4-0beta0-20100324-0ubuntu1~ppa2~karmic) to 2.1.4-0beta0-20100327-0ubuntu1~ppa0~karmic
cairo-dock-plug-ins-data (2.1.4-0beta0-20100324-0ubuntu1~ppa2~karmic) to 2.1.4-0beta0-20100327-0ubuntu1~ppa0~karmic
cairo-dock-plug-ins-integration (2.1.4-0beta0-20100324-0ubuntu1~ppa2~karmic) to 2.1.4-0beta0-20100327-0ubuntu1~ppa0~karmic

Now subdocs appear on the most-right of screen 0 (VGA)

I've attached some screenshots

screensoht4 is subdoc of the weather plugin

screenshot5 is a custom subdoc for the graphics (third icon from left)

Alienation (miguel-andrade) wrote :

screenshot5

Matthieu Baerts (matttbe) wrote :

Thanks for this bug report !
But due to some occupancies, this bug can't be fixed before 10 or 15 days
Thank you

Changed in cairo-dock-core:
assignee: nobody → Fabounet (fabounet03)
status: New → Confirmed
Alienation (miguel-andrade) wrote :

Hi, after 1 year and 6 months this is still happening. You might get it to a "will not fix" state...

this bug is a duplicate of 549683, which has been marked as fixed.
so is it actually not fixed ? Do you have your X session configured to use
Xinerama ?.

if so, would it be possible to run the dock with the debug outputs ?
"cairo-dock -l debug"
Thanks !

2011/7/28 Alienation <email address hidden>

> *** This bug is a duplicate of bug 549683 ***
> https://bugs.launchpad.net/bugs/549683
>
> Hi, after 1 year and 6 months this is still happening. You might get it
> to a "will not fix" state...
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/540979
>
> Title:
> xinerama:doc in one screen, subdocs in another
>
> Status in Cairo-Dock : Core:
> Confirmed
>
> Bug description:
> I have sometimes a second screen connected to my laptop. I've
> configured cairo-doc to use Xinerama and 0 is the screen number.
>
> The doc then appears in my fixed screen, but sub-docs appear in my laptop
> screen, and that makes it unusable.
> If I choose screen 1 then its ok (all on the laptop screen), but I had
> some problems with auto-hide if I do it this way.
>
> Thanks
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cairo-dock-core/+bug/540979/+subscriptions
>

Alienation (miguel-andrade) wrote :

No, not fixed :(. Yes I', using xinerama. Debug output attached.

Tnx

Fabounet (fabounet03) wrote :

thanks for the output
I've tried to reproduce the bug at home, without success.
However, I note some strange values in the output:

  "pVirtualScreenSizeBuffer : 5124x1604 ; screen : 1281x802"

this seems a weird number for a screen resolution

also, it means you have 4x2 desktops, I guess you use the Compiz wall ?
did you ever try with a 4x1 cube ?

later I see that Xinerama gives a 1280x800 resolution, more conventional.

Then we have
"debug :
(/build/buildd/cairo-dock-2.4.0~0beta2~20110722/src/gldit/cairo-dock-X-utilities.c:cairo_dock_update_screen_geometry:177)

new screen size : 2720x900
message :
(/build/buildd/cairo-dock-2.4.0~0beta2~20110722/src/gldit/cairo-dock-X-manager.c:_on_change_desktop_geometry:108)
resolution alteree
message :
(/build/buildd/cairo-dock-2.4.0~0beta2~20110722/src/gldit/cairo-dock-X-utilities.c:cairo_dock_get_screen_offsets:625)
* screen 0 => (1280;0) 1440x900
debug :
(/build/buildd/cairo-dock-2.4.0~0beta2~20110722/src/gldit/cairo-dock-X-utilities.c:cairo_dock_get_nb_viewports:290)
pVirtualScreenSizeBuffer : 10880x1800 ; screen : 2720x900 "

did you manually change the screen resolution or the number of desktops ?
there seem to be a conflict between the values (1280, 1440, 2720) but I
don't see why.

was the dock launched on session-startup or manually in a terminal ?
what's the output of "xrandr" ?

2011/7/29 Alienation <email address hidden>

> *** This bug is a duplicate of bug 549683 ***
> https://bugs.launchpad.net/bugs/549683
>
> No, not fixed :(. Yes I', using xinerama. Debug output attached.
>
> Tnx
>
>
> ** Attachment added: "Debug output"
>
> https://bugs.launchpad.net/cairo-dock-core/+bug/540979/+attachment/2240024/+files/cairo-doc.dbg
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/540979
>
> Title:
> xinerama:doc in one screen, subdocs in another
>
> Status in Cairo-Dock : Core:
> Confirmed
>
> Bug description:
> I have sometimes a second screen connected to my laptop. I've
> configured cairo-doc to use Xinerama and 0 is the screen number.
>
> The doc then appears in my fixed screen, but sub-docs appear in my laptop
> screen, and that makes it unusable.
> If I choose screen 1 then its ok (all on the laptop screen), but I had
> some problems with auto-hide if I do it this way.
>
> Thanks
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cairo-dock-core/+bug/540979/+subscriptions
>

Fabounet (fabounet03) wrote :

oh actually the numbers are correct (1280 + 1440 = 2720) and the offset is
1280 which seems correct too ...
but the heights are different (800 vs 900), not sure if it has any impact
though.

what if you start the dock with the 2 screens already connected ?
and what if then you remove one of them ?
finally, what if you reproduce the bug, and then create a sub-dock (for
instance by activating the Shortcuts applet). is the sub-dock correctly
placed ?

2011/7/29 Fabrice Rey <email address hidden>

> thanks for the output
> I've tried to reproduce the bug at home, without success.
> However, I note some strange values in the output:
>
> "pVirtualScreenSizeBuffer : 5124x1604 ; screen : 1281x802"
>
> this seems a weird number for a screen resolution
>
> also, it means you have 4x2 desktops, I guess you use the Compiz wall ?
>
> did you ever try with a 4x1 cube ?
>
> later I see that Xinerama gives a 1280x800 resolution, more conventional.
>
> Then we have
> "debug :
> (/build/buildd/cairo-dock-2.4.0~0beta2~20110722/src/gldit/cairo-dock-X-utilities.c:cairo_dock_update_screen_geometry:177)
>
> new screen size : 2720x900
> message :
> (/build/buildd/cairo-dock-2.4.0~0beta2~20110722/src/gldit/cairo-dock-X-manager.c:_on_change_desktop_geometry:108)
> resolution alteree
> message :
> (/build/buildd/cairo-dock-2.4.0~0beta2~20110722/src/gldit/cairo-dock-X-utilities.c:cairo_dock_get_screen_offsets:625)
> * screen 0 => (1280;0) 1440x900
> debug :
> (/build/buildd/cairo-dock-2.4.0~0beta2~20110722/src/gldit/cairo-dock-X-utilities.c:cairo_dock_get_nb_viewports:290)
> pVirtualScreenSizeBuffer : 10880x1800 ; screen : 2720x900 "
>
> did you manually change the screen resolution or the number of desktops ?
> there seem to be a conflict between the values (1280, 1440, 2720) but I
> don't see why.
>
> was the dock launched on session-startup or manually in a terminal ?
> what's the output of "xrandr" ?
>
>
> 2011/7/29 Alienation <email address hidden>
>
>> *** This bug is a duplicate of bug 549683 ***
>> https://bugs.launchpad.net/bugs/549683
>>
>> No, not fixed :(. Yes I', using xinerama. Debug output attached.
>>
>> Tnx
>>
>>
>> ** Attachment added: "Debug output"
>>
>> https://bugs.launchpad.net/cairo-dock-core/+bug/540979/+attachment/2240024/+files/cairo-doc.dbg
>>
>> --
>> You received this bug notification because you are a bug assignee.
>> https://bugs.launchpad.net/bugs/540979
>>
>> Title:
>> xinerama:doc in one screen, subdocs in another
>>
>> Status in Cairo-Dock : Core:
>> Confirmed
>>
>> Bug description:
>> I have sometimes a second screen connected to my laptop. I've
>> configured cairo-doc to use Xinerama and 0 is the screen number.
>>
>> The doc then appears in my fixed screen, but sub-docs appear in my laptop
>> screen, and that makes it unusable.
>> If I choose screen 1 then its ok (all on the laptop screen), but I had
>> some problems with auto-hide if I do it this way.
>>
>> Thanks
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/cairo-dock-core/+bug/540979/+subscriptions
>>
>
>

Alienation (miguel-andrade) wrote :

try this to reproduce:

1. Start cairo-dock with only one screen (like laptop)
2. Have cairo-dock to use xinerama on screen 0
3. Connect second screen, change resolutions appropriately, set second screen as primary.

In my case, I have 1280x800 (laptop lvds1) and 1440x900 (VGA1) Primary output VGA1

4. Cairo-dock should be now on the second connected (vga) screen. If you hover on a subdock, the subdock will appear in the 1st screen (lvds1 in my case).

The debug output attached was captured following this steps..

My screen configuration is as attached.

Alienation (miguel-andrade) wrote :

If I start cairo-dock with the screens already connected, then it's ok. Actually, every time I attach a second screen I have to kill the dock and then restart.

Alienation (miguel-andrade) wrote :

If I add a new subdoc (shortcuts), new new subdoc opens OK, the others still opens in the wrong screen.

Alienation (miguel-andrade) wrote :

Don't know if this was addressed in the last few reviews, but it seams it is not happening anymore!

Thanks. I guess this can be closed

Fabounet (fabounet03) wrote :

yep, this was fixed in the rev 817 :-)
thank you for confirming the fix is working !

2011/8/18 Alienation <email address hidden>

> *** This bug is a duplicate of bug 549683 ***
> https://bugs.launchpad.net/bugs/549683
>
> Don't know if this was addressed in the last few reviews, but it seams
> it is not happening anymore!
>
> Thanks. I guess this can be closed
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/540979
>
> Title:
> xinerama:doc in one screen, subdocs in another
>
> Status in Cairo-Dock : Core:
> Confirmed
>
> Bug description:
> I have sometimes a second screen connected to my laptop. I've
> configured cairo-doc to use Xinerama and 0 is the screen number.
>
> The doc then appears in my fixed screen, but sub-docs appear in my laptop
> screen, and that makes it unusable.
> If I choose screen 1 then its ok (all on the laptop screen), but I had
> some problems with auto-hide if I do it this way.
>
> Thanks
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cairo-dock-core/+bug/540979/+subscriptions
>

Changed in cairo-dock-core:
importance: Undecided → Medium
status: Confirmed → Fix Committed
Changed in cairo-dock-core:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers