Trash applet detects drag-and-dropped items twice

Bug #530975 reported by Santiago Ward on 2010-03-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Undecided
Matthieu Baerts

Bug Description

cairo-dock version: 2.1.3-6
Distribution: Xubuntu 9.10 32bits
Desktop Manager: Xfce 4.6.1.1

When drag-and-dropping a file from Thunar or Xfdesktop to Cairo-Dock's trash applet, the applet reports 2 elements in the dustbin. When emptying the trash, either from the applet's menu or from Thunar, the file is deleted, but the applet still reports 1 element in the dustbin.
This behavior isn't present when sending the file to Trash by any other method.
Reloading the applet fixes the number reported.

Related branches

Fabounet (fabounet03) on 2010-03-04
Changed in cairo-dock-core:
status: New → Confirmed

This issue is no longer present on cairo-dock 2.1.3-7.
Thank you for your time.

Changed in cairo-dock-core:
status: Confirmed → Fix Released

Sorry for the rushed report. It seems to be there still, just not always (I got a few "right" reports, but after a while it started reporting double again).

Changed in cairo-dock-core:
status: Fix Released → Confirmed
Fabounet (fabounet03) wrote :

this will be fixed with the new gio backend for the XFCE plug-in.

Changed in cairo-dock-core:
status: Confirmed → In Progress
Fabounet (fabounet03) wrote :

fixed with XFCE 4.6 and CD 2.2

Changed in cairo-dock-core:
status: In Progress → Fix Committed
Changed in cairo-dock-core:
status: Fix Committed → Fix Released
assignee: nobody → Matthieu Baerts (matttbe)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers