dock appears under all windows after a full screen app is run

Bug #518453 reported by Carlos Troncoso Phillips on 2010-02-07
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Undecided
Unassigned
Compiz
Undecided
Unassigned

Bug Description

Version:
Cairo-Dock (2007-2009)
 version 2.1.2-4

Ubuntu 9.10 running compiz 0.8.4

Test1:
- Open terminal window.
- Press F11 (cairo respects the full screen app and stays in the background while poping up.)
- Press F11 again. (cairo now pops up behind any other window)

Test2:
- Open any video on VLC
- Go full screen [Press F] (cairo stays behind as expected)
- Return to window mode [Press F again] (cairo stays behind)
-------------

Playing with visibility settings doesn't help. Only closing and restarting cairo solves the issue.
Tested on openGL and non openGL modes (happens more often with openGL)

Related branches

Fabounet (fabounet03) wrote :

Hi,
could you please try that with the current stable version (2.1.3) ?
Thanks.

Fabounet (fabounet03) on 2010-02-18
Changed in cairo-dock-core:
status: New → Fix Committed
James Cuzella (trinitronx) wrote :

I'm seeing this behavior running the OpenGL version 2.2.0-4. Could there be a possible regression?

Matthieu Baerts (matttbe) wrote :

@ TrinitronX:

Hello,

What's the 'visibility' option that you're using? (Config panel of Cairo-Dock / (Simple Mode) / Visibility)

How can we reproduce it?

also did you upgrade the dock only or the whole system at the same time ?

2010/10/24 Matthieu Baerts <email address hidden>

> @ TrinitronX:
>
> Hello,
>
> What's the 'visibility' option that you're using? (Config panel of
> Cairo-Dock / (Simple Mode) / Visibility)
>
> How can we reproduce it?
>
> --
> dock appears under all windows after a full screen app is run
> https://bugs.launchpad.net/bugs/518453
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: Fix Committed
>
> Bug description:
> Version:
> Cairo-Dock (2007-2009)
> version 2.1.2-4
>
> Ubuntu 9.10 running compiz 0.8.4
>
> Test1:
> - Open terminal window.
> - Press F11 (cairo respects the full screen app and stays in the background
> while poping up.)
> - Press F11 again. (cairo now pops up behind any other window)
>
> Test2:
> - Open any video on VLC
> - Go full screen [Press F] (cairo stays behind as expected)
> - Return to window mode [Press F again] (cairo stays behind)
> -------------
>
> Playing with visibility settings doesn't help. Only closing and restarting
> cairo solves the issue.
> Tested on openGL and non openGL modes (happens more often with openGL)
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

James Cuzella (trinitronx) wrote :

I'm using the new visibility option "hide the dock when it overlaps the current window"

Usually the dock will show up on top of all windows when the mouse is at the bottom border of my screen. However, after opening a full screen app and closing it, the dock appears under all windows. This happens until the dock is restarted.

I've been able to reproduce this by opening the mythtv frontend program, or konsole (using the View->Full Screen Mode option). After opening one of these apps, glx dock shows this behavior.

I've installed the following packages:

cairo-dock 2.2.0-4-1ubuntu1~lucid
cairo-dock-core 2.2.0-4-1ubuntu1~lucid
cairo-dock-data 2.2.0-4-1ubuntu1~lucid
cairo-dock-plug-ins 2.2.0-4-1ubuntu1~lucid
cairo-dock-plug-ins-data 2.2.0-4-1ubuntu1~lucid
cairo-dock-plug-ins-integration 2.2.0-4-1ubuntu1~lucid

These were from the following repository: http://repository.glx-dock.org/ubuntu

Fabounet (fabounet03) wrote :

this bug have been fixed in the 2.2.1
as a workaround, you can disable the option "hide the dock on a fullscreen
window" in advanced mode.

2010/11/5 James Cuzella <email address hidden>

> I'm using the new visibility option "hide the dock when it overlaps the
> current window"
>
> Usually the dock will show up on top of all windows when the mouse is at
> the bottom border of my screen. However, after opening a full screen
> app and closing it, the dock appears under all windows. This happens
> until the dock is restarted.
>
> I've been able to reproduce this by opening the mythtv frontend program,
> or konsole (using the View->Full Screen Mode option). After opening one
> of these apps, glx dock shows this behavior.
>
> I've installed the following packages:
>
> cairo-dock 2.2.0-4-1ubuntu1~lucid
> cairo-dock-core 2.2.0-4-1ubuntu1~lucid
> cairo-dock-data 2.2.0-4-1ubuntu1~lucid
> cairo-dock-plug-ins 2.2.0-4-1ubuntu1~lucid
> cairo-dock-plug-ins-data 2.2.0-4-1ubuntu1~lucid
> cairo-dock-plug-ins-integration 2.2.0-4-1ubuntu1~lucid
>
> These were from the following repository: http://repository.glx-
> dock.org/ubuntu
>
> --
> dock appears under all windows after a full screen app is run
> https://bugs.launchpad.net/bugs/518453
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: Fix Committed
>
> Bug description:
> Version:
> Cairo-Dock (2007-2009)
> version 2.1.2-4
>
> Ubuntu 9.10 running compiz 0.8.4
>
> Test1:
> - Open terminal window.
> - Press F11 (cairo respects the full screen app and stays in the background
> while poping up.)
> - Press F11 again. (cairo now pops up behind any other window)
>
> Test2:
> - Open any video on VLC
> - Go full screen [Press F] (cairo stays behind as expected)
> - Return to window mode [Press F again] (cairo stays behind)
> -------------
>
> Playing with visibility settings doesn't help. Only closing and restarting
> cairo solves the issue.
> Tested on openGL and non openGL modes (happens more often with openGL)
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

James Cuzella (trinitronx) wrote :

I had thought that 2.2.0 was most current. Is there a repo I can use to get the latest, or is this still a development build?

Fabounet (fabounet03) wrote :

well, I'm not sure if this bug has been fixed in the 2.2.0 or in the 2.2.1,
so you can try this one through our weekly PPA (see our wiki).
did you try to disable the option I mentionned ? I think it should solve the
problem.

2010/11/8 James Cuzella <email address hidden>

> I had thought that 2.2.0 was most current. Is there a repo I can use to
> get the latest, or is this still a development build?
>
> --
> dock appears under all windows after a full screen app is run
> https://bugs.launchpad.net/bugs/518453
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: Fix Committed
>
> Bug description:
> Version:
> Cairo-Dock (2007-2009)
> version 2.1.2-4
>
> Ubuntu 9.10 running compiz 0.8.4
>
> Test1:
> - Open terminal window.
> - Press F11 (cairo respects the full screen app and stays in the background
> while poping up.)
> - Press F11 again. (cairo now pops up behind any other window)
>
> Test2:
> - Open any video on VLC
> - Go full screen [Press F] (cairo stays behind as expected)
> - Return to window mode [Press F again] (cairo stays behind)
> -------------
>
> Playing with visibility settings doesn't help. Only closing and restarting
> cairo solves the issue.
> Tested on openGL and non openGL modes (happens more often with openGL)
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

James Cuzella (trinitronx) wrote :

After a synaptic update and reboot, I'm no longer seeing this behaviour. The strange part is that the last updates were to unrelated packages. Not sure why I cannot reproduce it anymore, as the package versions for cairo-dock I have installed are the same.

Very weird, however, I'm not complaining ;-)

If I see this again, I'll repost here.

James Cuzella (trinitronx) wrote :

Started seeing the problem intermittently again, so I just updated to version 2.2.1~0alpha1 using the weekly build PPA. I've been able to start fullscreen apps, close them and the behavior hasn't re-appeared yet.

James Cuzella (trinitronx) wrote :

After testing out 2.2.1~0alpha1 for a bit, I ran into the problem again. The dock is drawn behind all windows after mythfrontend is run on occasion. Doesn't seem to happen all the time, but still appears.

Tried switching the visibility option to "Always on top" after it happened, and although the dock is not hidden, it still draws below other windows.

See: http://img253.imageshack.us/img253/8613/dockbelowpu.png

James Cuzella (trinitronx) wrote :

Note that when in this state, the dock still responds to mouseover, and any subdocks are still drawn on top. However, the main dock is drawn below.

Fabounet (fabounet03) wrote :

do you use Compiz ?
what if you do a
  metacity --replace&
and/or a
  compiz --replace&
?
it is to know if it can be a WM problem or not. thanks !

2010/12/29 James Cuzella <email address hidden>

> After testing out 2.2.1~0alpha1 for a bit, I ran into the problem again.
> The dock is drawn behind all windows after mythfrontend is run on
> occasion. Doesn't seem to happen all the time, but still appears.
>
> Tried switching the visibility option to "Always on top" after it
> happened, and although the dock is not hidden, it still draws below
> other windows.
>
> See: http://img253.imageshack.us/img253/8613/dockbelowpu.png
>
> --
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
> https://bugs.launchpad.net/bugs/518453
>
> Title:
> dock appears under all windows after a full screen app is run
>
> Status in Cairo-Dock : Core:
> Fix Committed
>
> Bug description:
> Version:
> Cairo-Dock (2007-2009)
> version 2.1.2-4
>
> Ubuntu 9.10 running compiz 0.8.4
>
> Test1:
> - Open terminal window.
> - Press F11 (cairo respects the full screen app and stays in the background
> while poping up.)
> - Press F11 again. (cairo now pops up behind any other window)
>
> Test2:
> - Open any video on VLC
> - Go full screen [Press F] (cairo stays behind as expected)
> - Return to window mode [Press F again] (cairo stays behind)
> -------------
>
> Playing with visibility settings doesn't help. Only closing and restarting
> cairo solves the issue.
> Tested on openGL and non openGL modes (happens more often with openGL)
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

James Cuzella (trinitronx) wrote :

Fabounet,

Yes I use compiz. After doing a metacity --replace&, I get the following:

http://img94.imageshack.us/img94/2161/metacity.png

Then, if I run compiz again with 'compiz --replace&', the dock is redrawn on top again! Perhaps you are right, and it has to do with the WM.

Fabounet (fabounet03) wrote :

thanks for doing the test.
so I guess it is worth opening this bug on the Compiz side, because
obviously with Metacity it's drawn on top (with a black background), and
when reloading Compiz it's drawn on top too.

2010/12/30 James Cuzella <email address hidden>

> Fabounet,
>
> Yes I use compiz. After doing a metacity --replace&, I get the
> following:
>
> http://img94.imageshack.us/img94/2161/metacity.png
>
> Then, if I run compiz again with 'compiz --replace&', the dock is
> redrawn on top again! Perhaps you are right, and it has to do with the
> WM.
>
> --
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
> https://bugs.launchpad.net/bugs/518453
>
> Title:
> dock appears under all windows after a full screen app is run
>
> Status in Cairo-Dock : Core:
> Fix Committed
>
> Bug description:
> Version:
> Cairo-Dock (2007-2009)
> version 2.1.2-4
>
> Ubuntu 9.10 running compiz 0.8.4
>
> Test1:
> - Open terminal window.
> - Press F11 (cairo respects the full screen app and stays in the background
> while poping up.)
> - Press F11 again. (cairo now pops up behind any other window)
>
> Test2:
> - Open any video on VLC
> - Go full screen [Press F] (cairo stays behind as expected)
> - Return to window mode [Press F again] (cairo stays behind)
> -------------
>
> Playing with visibility settings doesn't help. Only closing and restarting
> cairo solves the issue.
> Tested on openGL and non openGL modes (happens more often with openGL)
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

James Cuzella (trinitronx) wrote :

Just found that I am able to reproduce this reliably by running the realvnc client.

James Cuzella (trinitronx) wrote :

After reviewing some old bugs linked to my launchpad account... I have some good news!

This behavior seems linked to the workaround for bug #348934

I realized today that I had the "Legacy Fullscreen Support" in compiz config settings manager selected in order to fix a bug in mythtv where gnome-panel was showing above mythfrontend in full screen mode.

The good news is that since I'm no longer using gnome-panel, I have no need for this workaround. After disabling the "Legacy Fullscreen Support" in compiz config manager, cairo-dock shows above all windows again!

I tested both with mythfrontend and the realvnc client, and was unable to get cairo-dock to appear below windows.

Changed in compiz:
status: New → Fix Released
Fabounet (fabounet03) wrote :

great, thanks for the reply ! :-)

2011/2/6 James Cuzella <email address hidden>

> After reviewing some old bugs linked to my launchpad account... I have
> some good news!
>
> This behavior seems linked to the workaround for bug #348934
>
> I realized today that I had the "Legacy Fullscreen Support" in compiz
> config settings manager selected in order to fix a bug in mythtv where
> gnome-panel was showing above mythfrontend in full screen mode.
>
> The good news is that since I'm no longer using gnome-panel, I have no
> need for this workaround. After disabling the "Legacy Fullscreen
> Support" in compiz config manager, cairo-dock shows above all windows
> again!
>
> I tested both with mythfrontend and the realvnc client, and was unable
> to get cairo-dock to appear below windows.
>
> ** Changed in: compiz
> Status: New => Fix Released
>
> --
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
> https://bugs.launchpad.net/bugs/518453
>
> Title:
> dock appears under all windows after a full screen app is run
>
> Status in Cairo-Dock : Core:
> Fix Committed
> Status in Compiz:
> Fix Released
>
> Bug description:
> Version:
> Cairo-Dock (2007-2009)
> version 2.1.2-4
>
> Ubuntu 9.10 running compiz 0.8.4
>
> Test1:
> - Open terminal window.
> - Press F11 (cairo respects the full screen app and stays in the
> background while poping up.)
> - Press F11 again. (cairo now pops up behind any other window)
>
> Test2:
> - Open any video on VLC
> - Go full screen [Press F] (cairo stays behind as expected)
> - Return to window mode [Press F again] (cairo stays behind)
> -------------
>
> Playing with visibility settings doesn't help. Only closing and restarting
> cairo solves the issue.
> Tested on openGL and non openGL modes (happens more often with openGL)
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Changed in cairo-dock-core:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers