Cannot Modify / Add Custom Launchers

Bug #455261 reported by Alin Andrei on 2009-10-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Undecided
Unassigned
cairo-dock-plug-ins (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using Ubuntu Karmic Koala beta and when I try to edit an existing launcher or add a new custom launcher, when I click on any of the fields to try and modify it, Cairo Dock freezes. This is because the Clipper launcher.

I tried the stable version (2.1.) and then the weekly build (2.1.1-0beta0) and the same thing occurs.

There is no error message displayed in the terminal, so I'm not sure what's causing this. Also, running ubuntu-bug cairo-dock says it cannot report anything because this is not a genuine Ubuntu package.

Running cairo-dock -l debug > debug.txt, this are the last lines in the debug report, then it freezes:

debug :  (applet-clipboard.c:cd_clipper_selection_owner_changed:217) 
  cd_clipper_selection_owner_changed ()
message :  (applet-clipboard.c:_on_text_received:61) 
  _on_text_received (Pidgin, 3)
debug :  (applet-clipboard.c:_on_text_received:152) 
  0 items / 10
debug :  (applet-clipboard.c:_on_text_received:164) 
  Clipper : Pidgin est ajoute
message :  (applet-clipboard.c:_on_text_received:173) 
  iNbItems[3] <- 1
message :  (applet-clipboard.c:cd_clipper_load_actions:233) 
  cd_clipper_load_actions (/home/andrei/.config/cairo-dock/Clipper-actions-gnome.conf)

Related branches

Fabounet (fabounet03) wrote :

thanks for reporting this bug.
can you please confirm that it only appears with the Clipper applet activated ?
and what if you uncheck the option in the Clipper's config that says to display the associated actions ?
are you running glx-dock or cairo ? if glx, can you try with cairo ?

Alin Andrei (nilarimogard) wrote :

As soon as I deactivated Clipper, everything was fine so yes, I can confirm that.

It happens with both GLX and Cairo mode.

After unchecking the "Enable Actions" under Clipper's config, Cairo-Dock still freezes when trying to modify a launcher and it even freezes when clicking the uncheck button for "Enable actions". If you meant something else with "associated actions", please explain.

ok thanks a lot, I'll try to reproduce and fix the bug at home.

2009/10/19 hotice <email address hidden>

> As soon as I deactivated Clipper, everything was fine so yes, I can confirm
> that. It happens with both GLX and Cairo mode. After unchecking the "Enable
> Actions" under Clipper's config, Cairo-Dock still freezes when trying to
> modify a launcher and it even freezes when clicking the uncheck button for
> "Enable actions". If you meant something else with "associated actions",
> please explain. Cannot Modify / Add Custom Launchers
> https://bugs.launchpad.net/bugs/455261 You received this bug notification
> because you are a member of Cairo- Dock Team, which is subscribed to
> Cairo-Dock Core. Status in Cairo-Dock : Core: New Bug description: I'm using
> Ubuntu Karmic Koala beta and when I try to edit an existing launcher or add
> a new custom launcher, when I click on any of the fields to try and modify
> it, Cairo Dock freezes. This is because the Clipper launcher. I tried the
> stable version (2.1.) and then the weekly build (2.1.1-0beta0) and the same
> thing occurs. There is no error message displayed in the terminal, so I'm
> not sure what's causing this. Also, running ubuntu-bug cairo-dock says it
> cannot report anything because this is not a genuine Ubuntu package. Running
> cairo-dock -l debug > debug.txt, this are the last lines in the debug
> report, then it freezes: [1;35mdebug : [0m
> [0;37m(applet-clipboard.c:cd_clipper_selection_owner_changed:217) [0m
> cd_clipper_selection_owner_changed () [1;32mmessage : [0m
> [0;37m(applet-clipboard.c:_on_text_received:61) [0m _on_text_received
> (Pidgin, 3) [1;35mdebug : [0m
> [0;37m(applet-clipboard.c:_on_text_received:152) [0m 0 items / 10
> [1;35mdebug : [0m [0;37m(applet-clipboard.c:_on_text_received:164) [0m
> Clipper : Pidgin est ajoute [1;32mmessage : [0m
> [0;37m(applet-clipboard.c:_on_text_received:173) [0m iNbItems[3] <- 1
> [1;32mmessage : [0m [0;37m(applet-clipboard.c:cd_clipper_load_actions:233)
> [0m cd_clipper_load_actions
> (/home/andrei/.config/cairo-dock/Clipper-actions-gnome.conf)
> _______________________________________________ Mailing list:
> https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>Post to :
> <email address hidden> Unsubscribe :
> https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>More help :
> https://help.launchpad.net/ListHelp

shachafgo (shachaf-gold) wrote :

not sure if this helps but same thing happened with my glx-dock... took me a while to figure out that clipper was making it freeze all the time...

I

Fabounet (fabounet03) wrote :

ok I might have found the culprit !
will be commited tonight.
don't hesitate to re-open this thread if the problem with Clipper persists.
Thanks for your help !

Changed in cairo-dock-core:
status: New → Fix Committed
Changed in cairo-dock-core:
status: Fix Committed → Fix Released
Changed in cairo-dock-plug-ins (Ubuntu):
status: New → In Progress
Fabounet (fabounet03) on 2009-10-24
Changed in cairo-dock-plug-ins (Ubuntu):
status: In Progress → Fix Released
Matthieu Baerts (matttbe) wrote :
Changed in cairo-dock-plug-ins (Ubuntu):
status: Fix Released → Fix Committed
Fabounet (fabounet03) wrote :

you're right, sorry :-)

2009/10/25 Matthieu Baerts <email address hidden>

> @ Fabounet: we have to wait for :
> https://bugs.launchpad.net/ubuntu/+source/cairo-dock-plug-
> ins/+bug/460028<https://bugs.launchpad.net/ubuntu/+source/cairo-dock-plug-%0Ains/+bug/460028>
>
> ** Changed in: cairo-dock-plug-ins (Ubuntu)
> Status: Fix Released => Fix Committed
>
> --
> Cannot Modify / Add Custom Launchers
> https://bugs.launchpad.net/bugs/455261
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: Fix Released
> Status in “cairo-dock-plug-ins” package in Ubuntu: Fix Committed
>
> Bug description:
> I'm using Ubuntu Karmic Koala beta and when I try to edit an existing
> launcher or add a new custom launcher, when I click on any of the fields to
> try and modify it, Cairo Dock freezes. This is because the Clipper launcher.
>
> I tried the stable version (2.1.) and then the weekly build (2.1.1-0beta0)
> and the same thing occurs.
>
> There is no error message displayed in the terminal, so I'm not sure what's
> causing this. Also, running ubuntu-bug cairo-dock says it cannot report
> anything because this is not a genuine Ubuntu package.
>
> Running cairo-dock -l debug > debug.txt, this are the last lines in the
> debug report, then it freezes:
>
>
> [1;35mdebug : [0m
> [0;37m(applet-clipboard.c:cd_clipper_selection_owner_changed:217) [0m
> cd_clipper_selection_owner_changed ()
> [1;32mmessage : [0m [0;37m(applet-clipboard.c:_on_text_received:61) [0m
> _on_text_received (Pidgin, 3)
> [1;35mdebug : [0m [0;37m(applet-clipboard.c:_on_text_received:152)
> [0m
> 0 items / 10
> [1;35mdebug : [0m [0;37m(applet-clipboard.c:_on_text_received:164)
> [0m
> Clipper : Pidgin est ajoute
> [1;32mmessage : [0m [0;37m(applet-clipboard.c:_on_text_received:173)
> [0m
> iNbItems[3] <- 1
> [1;32mmessage : [0m
> [0;37m(applet-clipboard.c:cd_clipper_load_actions:233) [0m
> cd_clipper_load_actions
> (/home/andrei/.config/cairo-dock/Clipper-actions-gnome.conf)
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock-plug-ins - 2.1.3-10-lucid-0ubuntu1

---------------
cairo-dock-plug-ins (2.1.3-10-lucid-0ubuntu1) lucid; urgency=low

  [ Matthieu Baerts (matttbe) ]
  * New upstream release (LP: #568083)
  * Fixed some bugs:
   - LP: #455261 (Cannot Modify / Add Custom Launchers)
   - LP: #449422 (Cairo-Dock resize problem)
   - LP: #489349 (showDesktop Applet only seems to work
          every second time you click on it)
   - LP: #526742 (The system monitor plugin and netspeed
          plugin inverts upside-down continuously)
   - Dbus: Used the right DBus API of Cairo-Dock (2.1.3 stable)
   - Used icons of the system
   - alsaMixer: fixed a crash when read several xml data
   - musicPlayer:
    * Removed some annoying warnings
    * Banshee-plugin: fixed some bugs due to the new version (1.4.0)

  [ Iain Lane ]
  * debian/watch: Update to match against current version
 -- Matthieu Baerts (matttbe) <email address hidden> Tue, 20 Apr 2010 01:52:21 +0200

Changed in cairo-dock-plug-ins (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers