[i945gm] Opengl is unstable with cairo-dock drmWaitVBlank returned -1

Bug #428900 reported by taiebot65 on 2009-09-13
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Medium
Dietrich Liegl
mesa (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

I have been testing cairo-dock for quite a while now and the opengl as always been unstable for me.
 When i was testing Jaunty, in alpha 6 i managed to get a full working dock in opengl mode for 2 days since then it never worked fully again.
I am back in Karmic to test the drivers and hopefully fix this unstable opengl.

I am using xorg edgers and i have noticed a great amelioration but OPengl version failed because after some use the background turn to white.

I think it s related to this debug

 do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.

I am attaching a video of the problem..

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
     Subsystem: Gateway 2000 Device [107b:0366]

taiebot65 (taiebot65) wrote :

Architecture: i386
DistroRelease: Ubuntu 9.10
MachineType: Gateway ML6226B
Package: xserver-xorg-video-intel 2:2.8.99.901~git20090909.efbcf29d-0ubuntu0tormod
PackageArchitecture: i386
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-10-generic root=UUID=eb810d92-7d4a-4892-852c-31fe059b65be ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_FR.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-10.32-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.7.0~git20090911.a79eecb9-0ubuntu0tormod
 libdrm2 2.4.13-1ubuntu1
 xserver-xorg-video-intel 2:2.8.99.901~git20090909.efbcf29d-0ubuntu0tormod
 xserver-xorg-video-ati 1:6.12.99+git20090911.ac853ca0-0ubuntu0tormod
Uname: Linux 2.6.31-10-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 03/06/2007
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 77.10
dmi.board.vendor: Gateway
dmi.board.version: 77.10
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 8
dmi.chassis.vendor: Gateway
dmi.chassis.version: Rev.1
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr77.10:bd03/06/2007:svnGateway:pnML6226B:pvr3408386R:rvnGateway:rn:rvr77.10:cvnGateway:ct8:cvrRev.1:
dmi.product.name: ML6226B
dmi.product.version: 3408386R
dmi.sys.vendor: Gateway
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-10-generic

tags: added: apport-collected

Thank you for reporting this bug and attaching a video to illustrate the problem. Could you also write what the problem is? It is hard to know what to look for in the video. Is the problem the changing background color in the panel, or is there something more I didn't notice?

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
taiebot65 (taiebot65) wrote :

yes the background changing color is actually the problem. It s certainly the dock which trigers some parameters and my background turns to white

Using normal drivers (i use xorg edgers ) the opengl dock is totally translucent so totally unusable for me so there was a lot of improvements but this

taiebot65 (taiebot65) wrote :

yes the background changing color is actually the problem. It s certainly the dock which trigers some parameters and my background turns to white

Using normal drivers (i use xorg edgers ) the opengl dock is totally translucent so totally unusable for me so there was a lot of improvements

Matthieu Baerts (matttbe) wrote :

Hello

Just to say that this bug is present only with taiebot65's Intel graphic card and when cairo-dock is launched with the OpenGL mode and not with the Cairo backend. So we suppose that this white background is due to this error (drmWaitVBlank returned -1)
On an eeepc with an Intel graphic card, Cairo-Dock works perfectly with the OpenGL, without any background and without the error of taeibot65 (drmWaitVBlank returned -1) with these new drivers included in Karmic (without the use of the 'xorg edgers' ppa) ! Thanks to the Xorg team for this hard work !

Thanks for your support,

Changed in cairo-dock-core:
assignee: nobody → Matthieu Baerts (matttbe)
importance: Undecided → Medium
milestone: none → cairo-dock-2.0
status: New → Incomplete
nochka85 (nochka85) wrote :

Hello,
I'm part of the Cairo-Dock team and I also have some troubles using Cairo-Dock (installed with packages from ppa weekly) in opengl on my eeepc701 on karmic alpha6 :
Some icons (Analogic Clock, Slider, System Monitor, Wifi) are invisibles when they are placed IN the dock (no trouble when they are on a desklet mode ) !
I don't see any message like those of Taiebot65 in the terminal.
Fabounet (the main Cairo-Dock dev) thinks that there is maybe a problem with the 'pbuffers' support in these Intel drivers.
You can test Cairo-Dock easily with our ppa-weekly : https://edge.launchpad.net/~cairo-dock-team/+archive/weekly
(Sources are also available from bzr : https://code.edge.launchpad.net/cairo-dock

Thanks

nochka85 (nochka85) on 2009-09-20
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Geir Ove Myhr (gomyhr) on 2009-09-20
tags: added: 945gm corruption karmic
Geir Ove Myhr (gomyhr) wrote :

Does
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
show up on STDERR when the problem occurs (the background changes) or before?

The warning comes from mesa, in http://cgit.freedesktop.org/mesa/mesa/tree/src/mesa/drivers/dri/common/vblank.c (in do_wait() around line 260). drmWaitVBlank() is in http://cgit.freedesktop.org/mesa/drm/tree/libdrm/xf86drm.c .

Geir Ove Myhr (gomyhr) wrote :

Btw, there is an old and invalid bug report for that warning at https://bugs.freedesktop.org/show_bug.cgi?id=8722
There it was asked for the output of `grep i915 /proc/interrupts` so that is probably useful here too.

taiebot65 (taiebot65) wrote :

There is no debug on cairo-dock to know what causes this problem...

What is doing the dock is loading opengl before it starts and see if your drivers are able to handle opengl and this is the only debug i have got. but it may not be the reason why my dock is turning white after a refresh.

nochka85 (nochka85) wrote :

@ Geir Ove Myhr : note that my problem is present on a eeepc 701 with an Intel 915GM. Do you want that I open another bug report ?

Geir Ove Myhr (gomyhr) wrote :

> @ Geir Ove Myhr : note that my problem is present on a eeepc 701 with an Intel 915GM. Do you want that I open another bug report ?

Usually we do for bugs in the intel driver. There are, however, many indications that this is a bug in the i915 part of mesa, which handles both 915GM and 945GM. So it is very likely that you have the exact same bug and another bug report shouldn't be necessary.

If you want to contribute your log files you may open a new bug report (with ubuntu-bug) and mark it as a duplicate of this one. Then we will have two slightly different data sets available, without them getting mixed in the same bug report.

Bryce Harrington (bryce) on 2009-09-21
Changed in mesa (Ubuntu):
status: New → Confirmed
taiebot65 (taiebot65) wrote :

Ok after a fresh install of alpha6 this bug does not appear anymore but i have exactly the same problem as Nochka85

Some icons (Analogic Clock, Slider, System Monitor, Wifi) are invisibles when they are placed IN the dock (no trouble when they are on a desklet mode ) !

Fabounet (the main Cairo-Dock dev) thinks that there is maybe a problem with the 'pbuffers' support in these Intel drivers.

Shall i close this bug and open an other one?

taiebot65 (taiebot65) wrote :

Sorry for spamming you but it s not fixed after loading an other theme.. I am back with a white background...

Bryce Harrington (bryce) on 2009-10-09
description: updated
jajaX (jajaplanet) wrote :

hi ! (sorry for my bad english)

same problem with intel video card. with opengl's on, the background is white not transparent.

glxinfo |grep OpenGL =>
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 945GM GEM 20090712 2009Q2 RC3 x86/MMX/SSE2
OpenGL version string: 1.4 Mesa 7.6

glxinfo | grep direct =>
direct rendering: Yes

jajaX (jajaplanet) wrote :

more information =>

kubuntu karmic 9.10 beta (after update since kubuntu jaunty)
kwin works with opengl very well.
laptop => A CER 5612WLMI

gunthers (hackmetz) wrote :

For everyone having the problem with some icons (clock, powermanager etc) being invisible, try running cairo with indirect rendering:

cairo-dock -o -i

This fixed the problem for me. Please follow up if it works on your system.

Fabounet (fabounet03) on 2009-10-27
Changed in cairo-dock-core:
status: Incomplete → Confirmed
jajaX (jajaplanet) wrote :

Hi (sorry for my bad english)

I try "cairo-dock -o -i";

see this screenshot :

http://img194.imageshack.us/img194/6223/cairodockopengl.jpg

same problem.

taiebot65 (taiebot65) wrote :

There is actually a "work around for this bug" if you select an image as a background in "Apparance" "Arriere Plan" or in English "Appearance" "Background" .. You select a random image as a backgorund and put the transparency as 0 and apply and you should not see the white background anymore...

Bryce Harrington (bryce) on 2009-11-02
summary: - Opengl is unstable with cairo-dock drmWaitVBlank returned -1
+ [i945gm] Opengl is unstable with cairo-dock drmWaitVBlank returned -1
DenisP (denisp) wrote :

I use ubuntu 9.10 with gnome and cairo-dock version 2.1.1-2 and I have Intel graphic card. If I use opengl version of cairo dock and start it with -o -i parameters then PowerManager addons gauge icon doesnt show the on charge and on battery states as a symbol on the gauge as it does when cairo-dock is started with -c parameter. If I start cairo-dock with only -o parameter then clock and PowerManager are not rendered at all.

My graphics card is:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03

Bryce Harrington (bryce) wrote :

[I don't think we need to track this against both mesa and -intel; the mesa task should be sufficient.]

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Invalid
jbld (umberto-baldini) wrote :

No applets seen with Lucid AMD 64 on kernel 2.3.32-21 with an ATI hd 3200

paulaner@ciompizzz:~$ glxinfo | grep direct
direct rendering: Yes
paulaner@ciompizzz:~$ glxinfo | grep OpenGL
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: Mesa DRI R600 (RS780 9610) 20090101 TCL DRI2
OpenGL version string: 1.5 Mesa 7.7.1
OpenGL extensions:
paulaner@ciompizzz:~$

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi taiebot65,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 428900

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 428900 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/428900

Changed in mesa (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
jbld (umberto-baldini) wrote :

No any problem with Catalyst 10.4 I will unsubscrive ...

paulaner@ciompizzz:~$ glxinfo | grep OpenGL
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 3200 Graphics
OpenGL version string: 3.2.9756 Compatibility Profile Context
OpenGL shading language version string: 1.50
OpenGL extensions:
paulaner@ciompizzz:~$ uname -a
Linux ciompizzz 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux
paulaner@ciompizzz:~$

taiebot65 (taiebot65) wrote :

Ok we ve got someone in our forum http://www.glx-dock.org/bg_topic.php?t=4300&pos=0#mess_56273
which got exactly the same behaviour and this has been tested under lucid. He is not using the same chipset as me (i945 for my self and GMA3100 for him).

Igor Korobka (igokoro) wrote :

As taiebot65 said I can reproduce this bug on my Intel graphic card with CD from the weekly ppa. I'm using Lucid (upgraded from Karmic).

Igor Korobka (igokoro) wrote :

Looks like this bug has been fixed in either latest updates of the lucid or latest betas of the CD. No white background even on my old Intel graphics card.
Great job!

Matthieu Baerts (matttbe) wrote :

Oh great, good news!
Someone else can confirm that it's fixed for other video cards?

Changed in cairo-dock-core:
milestone: cairo-dock-2.0 → 2.1.3
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

closing as fixed, thanks.

Changed in mesa (Ubuntu):
status: Incomplete → Fix Released
Changed in cairo-dock-core:
assignee: Matthieu Baerts (matttbe) → Dietrich Liegl (diet-rich-ld)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.