GTK 3.14 - right click causes a crash

Bug #1380715 reported by Roman Ďuriška on 2014-10-13
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
High
Matthieu Baerts
cairo-dock (Ubuntu)
High
Matthieu Baerts

Bug Description

Hi,

I have a problem with Cairo-dock. When I click on panel with right mouse button, Cairo-dock crash and restart itself. I tried it with and without OpenGL. All informations about version and about system is in debug file.

Roman.

Roman Ďuriška (johnnycage23) wrote :
Matthieu Baerts (matttbe) wrote :

Hello and thank you for this bug report!

Are you using Cairo-Dock with the new GTK 3.14?
Is it the same bug (with the same backtrace) as this one? => http://glx-dock.org/bg_topic.php?t=8054

Changed in cairo-dock-core:
status: New → Incomplete
Roman Ďuriška (johnnycage23) wrote :

Aaa yes, it's same bug, same backtrace. Sorry for duplicity.

Matthieu Baerts (matttbe) wrote :

No problem, it's maybe better to track it on Launchpad due to the importance of the crash!

This crash seems a bit tricky...

*@fabounet*: any idea of what can be interesting to test?

Changed in cairo-dock-core:
status: Incomplete → Confirmed
milestone: none → 3.4.0
importance: Undecided → Critical
importance: Critical → High
Changed in cairo-dock-core:
assignee: nobody → Matthieu Baerts (matttbe)
summary: - Cairodock - right mouse button crash
+ GTK 3.14 - right click causes a crash
Changed in cairo-dock (Ubuntu):
status: New → In Progress
Changed in cairo-dock-core:
status: Confirmed → Fix Committed
Changed in cairo-dock (Ubuntu):
importance: Undecided → High
assignee: nobody → Matthieu Baerts (matttbe)
milestone: none → ubuntu-14.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock - 3.4.0-0ubuntu1

---------------
cairo-dock (3.4.0-0ubuntu1) utopic; urgency=medium

  * New upstream release.
  * Detailed Upstream ChangeLog (bzr r1820 -> r1837)
    - Workaround for a crash with GTK 3.14 (LP: #1380715)
    - Fixed some possible bugs thanks to CPPCheck:
      - used of wrong variables
      - unused variables
      - wrong comparation
      - reducing scope of variables unused outside the next 'if'
      - moving the check of some if null before using the structure
      - redondant if condition
    - X Mgr: a WM class can contain whitespaces (when devs don't respect
      rules...)
    - Misc: translate Fr comments -> English
    - Updated translations
  * debian/control:
    - Bumped plug-ins versions
 -- Matthieu Baerts (matttbe) <email address hidden> Wed, 15 Oct 2014 16:47:11 +0200

Changed in cairo-dock (Ubuntu):
status: In Progress → Fix Released
Changed in cairo-dock-core:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments