no notification with Skype 4.0.0.7

Bug #1013635 reported by adesso on 2012-06-15
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Undecided
Fabounet

Bug Description

Unfurtunately, after the release of Skype 4.0.0.7 yesterday many users experienced a problem that they don't receive notifications about new skype messages. When we receive new messages we only see a notification on Unity launcher (Ubuntu 12.04) but Cairo dock is doing nothing.

Here is an attachment with the screenshot - Unity has a notification and also Skype gives an option to see popup messages. Cairo does nothing here

Revision history for this message
adesso (adesso-sevici) wrote :
Revision history for this message
Matthieu Baerts (matttbe) wrote :

Hello and thank you for this bug report

Unfortunately, if Skype devs decide to only send a notification to its Unity launcher, we can do nothing to see this notification on Cairo-Dock. But it's a bit strange because all other applications send a signal to the X server when the user has to be warned and I don't understand why they don't do the same thing! (because Unity dock is not used on Gnome Shell, KDE, XFCE, Cairo-Dock session, OpenBox, etc.)

So, for me it's a bug in Skype, don't hesitate to report it to Skype devs ;)

PS: note that it's expected to catch Unity notifications (quick-info, progress bar, menu and notifications) in the next version of Cairo-Dock ;)

Changed in cairo-dock-core:
status: New → Invalid
Revision history for this message
Fabounet (fabounet03) wrote : Re: [Cairo-dock-team] [Bug 1013635] Re: no notification with Skype 4.0.0.7

Hi,
let's try to narrow the bug before giving up ;-)

First, what used to happen before this new version of Skype ?
is it possible to have the debug traces ?
launch the dock with "cairo-dock -l debug > log.txt", and then
reproduce the bug, and attach the log.txt file here.

Now, if Unity launcher reacts, it's maybe because Ubuntu has a plug-in
or a patch for Skype. Maybe we can track that.
launch dbus-monitor in a terminal, and then let Skype produce a
notification, and copy-paste all the messages that appeared in the
terminal.

Thanks for your help ! :-)

2012/6/15 Matthieu Baerts <email address hidden>:
> Hello and thank you for this bug report
>
> Unfortunately, if Skype devs decide to only send a notification to its
> Unity launcher, we can do nothing to see this notification on Cairo-
> Dock. But it's a bit strange because all other applications send a
> signal to the X server when the user has to be warned and I don't
> understand why they don't do the same thing! (because Unity dock is not
> used on Gnome Shell, KDE, XFCE, Cairo-Dock session, OpenBox, etc.)
>
> So, for me it's a bug in Skype, don't hesitate to report it to Skype
> devs ;)
>
> PS: note that it's expected to catch Unity notifications (quick-info,
> progress bar, menu and notifications) in the next version of Cairo-Dock
> ;)
>
> ** Changed in: cairo-dock-core
>       Status: New => Invalid
>
> --
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
> https://bugs.launchpad.net/bugs/1013635
>
> Title:
>  no notification with Skype 4.0.0.7
>
> Status in Cairo-Dock : Core:
>  Invalid
>
> Bug description:
>  Unfurtunately, after the release of Skype 4.0.0.7 yesterday many users
>  experienced a problem that they don't receive notifications about new
>  skype messages. When we receive new messages we only see a
>  notification on Unity launcher (Ubuntu 12.04) but Cairo dock is doing
>  nothing.
>
>  Here is an attachment with the screenshot - Unity has a notification
>  and also Skype gives an option to see popup messages. Cairo does
>  nothing here
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cairo-dock-core/+bug/1013635/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team
> More help   : https://help.launchpad.net/ListHelp

Revision history for this message
Salvatore Pulvirenti (ktrls-nl) wrote :

Hi, I have make a test and send you my cairo log

Revision history for this message
Salvatore Pulvirenti (ktrls-nl) wrote :

Same test, dbus log

Revision history for this message
Matthieu Baerts (matttbe) wrote :

Hello and thank you for this new informations.

How many new messages/notifications did you receive during this test? And when? (it's just to find what you have when there are new messages ;) )

Revision history for this message
Salvatore Pulvirenti (ktrls-nl) wrote :

Hi, only one and it would be in the final part of the files. I have made a test with a friend and soon close the logs.
I have the last version of skype 4.0.0.8 and, like adesso, I have no notifications about messages in Cairo

Revision history for this message
Davinel (trueblamed) wrote :

I dont think it's skype problem. I have notifications in awn and xfce-panel, but not in cairo-dock.

Revision history for this message
Matthieu Baerts (matttbe) wrote :

Thank you for this comments!

This is strange to not have these notifications... Maybe there is something wrong and the dock blacklist this notification...
Is there more than one Skype window? (do you have two or more Skype icons in a subdock?)

*@Fabounet*: can you have a look to this bug? :-)

Changed in cairo-dock-core:
assignee: nobody → Fabounet (fabounet03)
status: Invalid → New
Revision history for this message
Fabounet (fabounet03) wrote : Re: [Bug 1013635] Re: no notification with Skype 4.0.0.7

is it possible that Skype uses the Unity Launcher API ?

in which case, we should see the notification with the current BZR
version of the dock.

2012/7/27 Matthieu Baerts <email address hidden>:
> Thank you for this comments!
>
> This is strange to not have these notifications... Maybe there is something wrong and the dock blacklist this notification...
> Is there more than one Skype window? (do you have two or more Skype icons in a subdock?)
>
> *@Fabounet*: can you have a look to this bug? :-)
>
> ** Changed in: cairo-dock-core
> Status: Invalid => New
>
> ** Changed in: cairo-dock-core
> Assignee: (unassigned) => Fabounet (fabounet03)
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1013635
>
> Title:
> no notification with Skype 4.0.0.7
>
> Status in Cairo-Dock : Core:
> New
>
> Bug description:
> Unfurtunately, after the release of Skype 4.0.0.7 yesterday many users
> experienced a problem that they don't receive notifications about new
> skype messages. When we receive new messages we only see a
> notification on Unity launcher (Ubuntu 12.04) but Cairo dock is doing
> nothing.
>
> Here is an attachment with the screenshot - Unity has a notification
> and also Skype gives an option to see popup messages. Cairo does
> nothing here
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cairo-dock-core/+bug/1013635/+subscriptions

Revision history for this message
Matthieu Baerts (matttbe) wrote :

Is someone can install the latest development release by adding our 'weekly ppa' and confirm if this bug is fixed or not?
  $ sudo add-apt-repository ppa:cairo-dock-team/weekly
  $ sudo apt-get update >/dev/null
  $ sudo apt-get install cairo-dock cairo-dock-plug-ins

Revision history for this message
adesso (adesso-sevici) wrote :

unfortunately, adding "weekly ppa" will not fix this bug = (

Revision history for this message
tof (giovanni-toffetti) wrote :

hi, any news on this? thank you in advance...

Revision history for this message
Fabounet (fabounet03) wrote :

about this bug, where should the notification be seen ?
is it on the launcher/taskbar, like for normal applications which want to signal an urgency, or in the notification area, with possibly a message bubble ?
in the second case, did you try with the old systray, just to be sure ?

Revision history for this message
adesso (adesso-sevici) wrote :

Here I marked what I have: notification from Unity launcher and pop-up notification from systray (it is at the lower right corner). And also I marked a place where should Cairo notification appear, but it doesn't.

P.S. I noticed that AWN dock is working normally (Skype notification appears with the dock), so maybe there is a problem with the code and there is a possibility to check in the AWN code what is missing in Cairo =)

Revision history for this message
Fabounet (fabounet03) wrote :

ok, so actually, the notification does appear in the systray (=
notification area) applet of the dock, but not in the taskbar, right ?
In this case, it's maybe because it uses the
_NET_WM_STATE_DEMANDS_ATTENTION; I've made a patch, could you please
tets if it solves the problem ?
thanks for your help :-)

2012/9/30 adesso <email address hidden>:
> Here I marked what I have: notification from Unity launcher and pop-up
> notification from systray (it is at the lower right corner). And also I
> marked a place where should Cairo notification appear, but it doesn't.
>
> P.S. I noticed that AWN dock is working normally (Skype notification
> appears with the dock), so maybe there is a problem with the code and
> there is a possibility to check in the AWN code what is missing in Cairo
> =)
>
> ** Attachment added: "skype-cairo.png"
> https://bugs.launchpad.net/cairo-dock-core/+bug/1013635/+attachment/3357743/+files/skype-cairo.png
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1013635
>
> Title:
> no notification with Skype 4.0.0.7
>
> Status in Cairo-Dock : Core:
> New
>
> Bug description:
> Unfurtunately, after the release of Skype 4.0.0.7 yesterday many users
> experienced a problem that they don't receive notifications about new
> skype messages. When we receive new messages we only see a
> notification on Unity launcher (Ubuntu 12.04) but Cairo dock is doing
> nothing.
>
> Here is an attachment with the screenshot - Unity has a notification
> and also Skype gives an option to see popup messages. Cairo does
> nothing here
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cairo-dock-core/+bug/1013635/+subscriptions

Revision history for this message
adesso (adesso-sevici) wrote :

how to test it?
I have 3.0.99rc1 from weekly repo, and do not really see an option to apply a patch

Revision history for this message
Fabounet (fabounet03) wrote :

It's not yet in the weekly, and I'm not sure we'll have the time to
build a weekly before the release, so you will have to compile it from
sources :-)
you can either use our script that-does-everything-automatically:
http://glx-dock.org/ww_page.php?p=From%20BZR&lang=en#4-First
installation
or do it manually, which is just about installing the dev packages and
then typing "make":
http://glx-dock.org/ww_page.php?p=From%20BZR&lang=en#2-Generic Method

2012/10/1 adesso <email address hidden>:
> how to test it?
> I have 3.0.99rc1 from weekly repo, and do not really see an option to apply a patch
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1013635
>
> Title:
> no notification with Skype 4.0.0.7
>
> Status in Cairo-Dock : Core:
> New
>
> Bug description:
> Unfurtunately, after the release of Skype 4.0.0.7 yesterday many users
> experienced a problem that they don't receive notifications about new
> skype messages. When we receive new messages we only see a
> notification on Unity launcher (Ubuntu 12.04) but Cairo dock is doing
> nothing.
>
> Here is an attachment with the screenshot - Unity has a notification
> and also Skype gives an option to see popup messages. Cairo does
> nothing here
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cairo-dock-core/+bug/1013635/+subscriptions

Revision history for this message
adesso (adesso-sevici) wrote :

It's working!

Changed in cairo-dock-core:
status: New → Fix Committed
Revision history for this message
Marco (macoviz) wrote :

I don't know if is related to this bug but my skype icon on the notification area stays always off-line and doesn't reflect the real skype status. Give a look at this screenshot, please. Any suggestion?

Revision history for this message
glennric (glennric) wrote :

I have the same problem that Marco does. Does the the fix that was committed upstream for this bug, fix that also?

Revision history for this message
Matthieu Baerts (matttbe) wrote :

@glennric: this bug should be fixed with Cairo-Dock 3.1.0. Feel free to test this new version ;)
=> http://www.glx-dock.org/ww_page.php?p=Accueil&lang=en#0-Installation

E.g. for Ubuntu:
    sudo add-apt-repository ppa:cairo-dock-team/ppa
    sudo apt-get update
    sudo apt-get dist-upgrade

Changed in cairo-dock-core:
status: Fix Committed → Fix Released
Revision history for this message
Marco (macoviz) wrote :

Dear Matthieu,

Unfortunately, even after upgrading to 3.1.0 version, Skype icon in notification area remains always off-line.

Revision history for this message
Matthieu Baerts (matttbe) wrote :

@Marco: please open a new bug report because this one is about "notifications for new skype messages" and not about the Skype icon in notification area.
About this new bug, can you also launch this command and wait for new status and notifications.
   $ dbus-monitor
Can you join the output messages produced in the terminal?

Revision history for this message
Marco (macoviz) wrote :

Please find in attachment the output produced by dbus-monitor starting from skype launch till successfully log-in.

Thanks a lot
Marco

Revision history for this message
Matthieu Baerts (matttbe) wrote :

@Marco: thank you but can you just re-open a new bug report with this file and a screenshot (because this one is about another bug and about 'cairo-dock-core' and not 'cairo-dock-plug-ins') ==> https://bugs.launchpad.net/cairo-dock-plug-ins/+filebug

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers