Clicking 'New Document' from Cairo-Dock gives an error

Bug #1002691 reported by Indian Art on 2012-05-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Undecided
Unassigned
cairo-dock (Ubuntu)
Undecided
Unassigned

Bug Description

Clicking 'New Document' from Cairo-Dock gives an error.

Steps to reproduce bug:

1. Right click LibreOffice (LO) icon on Cairo-Dock & click 'New Document'.
2. The error message appears. I have attached the error message.

More information:

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu Release 12.04 (precise) 32-bit,
Kernel Linux 3.2.0-24-generic-pae GNOME 3.4.1

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center
Cairo-Dock with GLX 3.0.0
LibreOffice 3.5.3.2 Build ID: 350m1(Build:2)

3) What you expected to happen
  'New Document' of LO would load

4) What happened instead
Error Message that is attached pops up.

Please help. Thanks.

Related branches

Indian Art (goldfish-aol) wrote :
Matthieu Baerts (matttbe) wrote :

Hello and thank you for this bug report!

This is strange, I can't reproduce it.
Are you using a custom version of LibreOffice? Do you also have this bug with the latest stable version of Cairo-Dock (3.0.1) (=> you can use our repository or ppa: http://www.glx-dock.org/ww_page.php?p=From%20the%20repository&lang=en )

If you still have the bug, can you launch the dock from the terminal with this command and post all output messages that you will have just after having clicked on the LibreOffice launcher? (You should have something like that:
    (...)
    activate (...)
    cairo_dock_launch_command_full (libreoffice --writer , (null))
    (...)

Changed in cairo-dock-core:
status: New → Incomplete
Indian Art (goldfish-aol) wrote :

Hi Matthieu Baerts,

Thanks for the help. The info you required:

1. I am on Cairo Dock Version 3.0.0

2. Please give me the exact command that I must paste in Terminal because I am not tech savvy.

3. The workaround I use is after I launch the 1st LO Writer document (Left click from Cairo Dock ). I click New in LO or press Control + n. In addition, Cairo Dock's context specific Menu option with a plus sign ("Launch a New" got by right clicking LO icon on Cairo Dock) works well. Its just that clicking on the "New Document " continues to give the same error (described above with attached picture).

Indian Art (goldfish-aol) wrote :

@ Matthieu Baerts

I am not using a custom version of LibreOffice. Just the standard version that comes with Ubuntu 12.04 with all the updates and all.

Matthieu Baerts (matttbe) wrote :

Sorry, I forgot the command:
    $ cairo-dock -l debug

Can you try with the latest stable version simply by adding our ppa?
    $ sudo add-apt-repository ppa:cairo-dock-team/ppa
    $ sudo apt-get update
    $ sudo apt-get install cairo-dock cairo-dock-core libgldi3 cairo-dock-plug-ins

Fabounet (fabounet03) on 2012-05-28
Changed in cairo-dock-core:
status: Incomplete → Confirmed
Fabounet (fabounet03) wrote :

ok I could finally reproduce it and fix it :-)
Thanks for your help !

Changed in cairo-dock-core:
status: Confirmed → Fix Committed
Indian Art (goldfish-aol) wrote :

Thank you Matthieu Baerts & Fabounet.

Changed in cairo-dock-core:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock - 3.0.2-0ubuntu1

---------------
cairo-dock (3.0.2-0ubuntu1) quantal; urgency=low

  * New upstream bug-fix release. (LP: #1014801)
  * Upstream ChangeLog (3.0.0 -> 3.0.1):
   - Dialogs: fixed a bug where the dock could auto-hide when a modal dialog
      was raised
   - Dialog: fixed a crash with gcc-4.7: the local variable can be corrupted
      due to optimisations
   - Fixed a bug where the dock didn't accept clicks when the mouse touches
      the screen edge (with auto-hide)
   - Added a compilation option to not force the display of icons in menus
      (design request but disable by default)
   - Fixed a bug where the hidden dock background color was not updated
      properly
   - Class-Manager: fixed a bug with Windows applications whose name is in
      upper case (.EXE)
   - GUI: use cairo_dock_get_xwindow_class to link a program with a launcher
   - French translations: fixed 2 small errors
  * Upstream ChangeLog (3.0.1 -> 3.0.2):
   - Main GUI: Fixed a crash when hovering group buttons too quickly
   - Main GUI: The dialog and preview didn't appear when hovering the button
   - Accelerators: On recent distro, 'Control' key is now called 'Primary'
   - Icon Mgr: Added a mutex because of occasional crashes with
      gtk_icon_theme_lookup_icon
   - Icon Mgr: Don't call a 'change-icon' callback when clicking or scrolling
      on an icon, and trigger an unneeded animation on the icon
   - Dock Mgr: Avoid emitting an 'enter' event when not needed
   - Class Mgr: Fixed 2 typos (special case for kdesu and not kdes)
   - Class Mgr: Remove launching options (%U) in quick-list Exec command
      (LP: #1002691)
   - Dialogues: Prevent closing the dialog unexpectedly when clicking on it,
      if the click is actually inside the interactive widget
   - Background: When set to 'always visible', applets' background couldn't
      be turned off
   - Added a workaround for the Unity-panel which has a wrong window type
   - po: Updated translations
  * debian/patches:
   - Removed all patches (now in upstream)
  * debian/cairo-dock-data:
   - Removed a lintian warning by added symlinks (binary-without-manpage)
 -- Matthieu Baerts (matttbe) <email address hidden> Sat, 23 Jun 2012 14:25:10 -0400

Changed in cairo-dock (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments