caffeine does not inhibit on gnome-shell

Bug #789401 reported by Jeremy Newton on 2011-05-28
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Caffeine
Medium
Unassigned

Bug Description

 I'm currently using Ubuntu 11.04 with gnome-shell, install using the gnome 3 ppa (https://launchpad.net/~gnome3-team/+archive/gnome3)

Caffiene seems to install and run in the notification bar but does not seem to be able to activate "disable screensaver" mode.

I take this is either caused by gnome-shell or gnome 3, either way this will be an issue come the next version of Ubuntu.

Is there perhaps a workaround for the time being?

Related branches

Jeremy Newton (alexjnewt) wrote :

I do want to note that Gnome-Screensaver version 3.0.0.2ubuntu1 is installed

Tommy Brunn (tommybrunn) wrote :

It seems that the screensaver functionality has been stripped from gnome-screensaver, which is being phased out. Some of that functionality will be moved into gnome-shell and/or gnome-session. As of right now, I don't think there's a workaround.

Jeremy Newton (alexjnewt) wrote :

Okay thanks for your help, I'll just have to wait till a gnome 3 inhibitor is developed.

Charith Ellawala (charith-h) wrote :

This one has been driving me nuts for a couple of weeks. There's not much documentation on it, but what I found out was that in Gnome 3, the Inhibit method has been moved to a different DBus interface.
I have branched and added code to inhibit using the new interface. Since I am a Fedora user, it has only been tested on Fedora though. If anybody is interested, my changes are in the repo lp:~charith-h/caffeine/gnome3

Jeremy Newton (alexjnewt) wrote :

This is also available to anyone interested: https://github.com/RaphaelKimmig/Gnome-Presentation-Mode
I found it not too long ago, and it integrates nicely with gnome-shell (add option to the battery menu, or at least for now)

Perhaps caffeine can get such integration? I'm sure it would be just as useful for gnome-shell users, as it would for Unity users.

Changed in caffeine:
importance: Undecided → Medium
status: New → Fix Committed
Changed in caffeine:
status: Fix Committed → Fix Released
phillamg (me-phillg) wrote :

Is it possible to get a pre-built deb that works with the Gnome 3 libraries? As it stands caffeine doesn't work under Oneiric (now at Beta 2) and although I'm using Unity, it's the same gnome-screensaver / session backends.

quequotion (quequotion) wrote :

>>Isaiah

Is this bug related to but 878690?

What version of Caffeine is this fixed in?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers