caffeine does not start

Bug #434435 reported by aloctavodia on 2009-09-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Caffeine
High
Isaiah Heyer

Bug Description

Caffeine does not start and when i try to run caffeine from the terminal i get the following message

 File "/usr/bin/caffeine", line 40, in <module>
    caffeine.main()
  File "/usr/bin/../lib/python2.6/dist-packages/caffeine/main.py", line 266, in main
    main = GUI()
  File "/usr/bin/../lib/python2.6/dist-packages/caffeine/main.py", line 57, in __init__
    "GUI.glade"))
glib.GError: ID «hbuttonbox1» de objeto duplicado en la línea 359 (anteriormente en la línea 208)

thanks in advance

pragmattica (bnsmith) wrote :

I have confirmed that the double definition does exist in the 0.3 glade file, though it didn't refuse to run for me. Strange how intermittent this problem seems to be...

Anyway, I'm working on putting a fix into the 0.3 branch right now.

Changed in caffeine:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → pragmattica (bnsmith)
pragmattica (bnsmith) on 2009-09-22
Changed in caffeine:
status: Confirmed → Fix Committed
pragmattica (bnsmith) wrote :

All we need now is to upload a new deb to the PPA, and all of our users will get the update. I love package management.

Changed in caffeine:
assignee: pragmattica (bnsmith) → Isaiah Heyer (freshapplepy)
Changed in caffeine:
status: Fix Committed → Fix Released
Mo-Yu Mandy Zhou (zhou-mandy) wrote :

I'm experiencing a similar problem in version 1.02. I can't start Caffeine and get the following message:

Traceback (most recent call last):
  File "/usr/bin/caffeine", line 38, in <module>
    import caffeine
  File "/usr/bin/../lib/python2.6/dist-packages/caffeine/__init__.py", line 171, in <module>
    from caffeine.main import main
  File "/usr/bin/../lib/python2.6/dist-packages/caffeine/main.py", line 46, in <module>
    generic = icon_theme.load_icon("application-x-executable", 16, gtk.ICON_LOOKUP_NO_SVG)
glib.GError: Icon 'application-x-executable' not present in theme

Any idea what's wrong?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers