Caffeine wont activate

Bug #1768801 reported by Calvin Cutts on 2018-05-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Caffeine
Undecided
Unassigned

Bug Description

When I right click on the caffeine indicator and click activate nothing happens. It has worked fine up to now.

I'm running Ubuntu Budgie 18.04.

I tried terminating the processes (caffeine and caffeine indicator) then re-running them, but it didn't work.

Reuben Thomas (rrt) wrote :

Sorry you're having problems!

When you say "nothing happens", do you mean that the indicator doesn't change to show that Caffeine is active? Or that having activated the indicator, the screensaver still kicks in?

Calvin Cutts (astralogic) wrote :

The indicator doesn't change, and the screensaver still kicks in.

Reuben Thomas (rrt) wrote :

If you run caffeine-indicator from a terminal, do you get any error messages?

Also, does caffeine itself work? (It seems that might be a separate problem: if the indicator doesn't change when you click it, it may simply not be activating caffeine).

Calvin Cutts (astralogic) wrote :

Running "caffeine-indicator" from the terminal doesn't produce any errors, it doesn't have any output at all, although it does launch the indicator.

None of the menu options available from the indicator (activate/about/quit) do anything when clicked.

I'm new to Linux and I don't know how to test/use caffeine without using the indicator.

Reuben Thomas (rrt) wrote :

Thanks for the feedback. Sounds like something has gone wrong with the user interface of caffeine-indicator, I guess because of changes in the underlying libraries in Ubuntu 18.04. Unfortunately I won't be upgrading to 18.04 until late August (when 18.04.1 is released), so I'm unlikely to be able to test it before then.

To test caffeine on its own, just run "caffeine" (in a terminal is probably best, again you can then see any output). Then see whether it works (that is, whether setting a window full-screen disables the screensaver).

Reuben Thomas (rrt) wrote :

I can confirm that caffeine-indicator works fine on Ubuntu 18.04 in GNOME. Your problem is most likely with xdg-screensaver. Closing the bug.

Changed in caffeine:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers